mis-fire codes but does not mis-fire - Page 3 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 09-27-2015, 04:58 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529482
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: mis-fire codes but does not mis-fire

Did you get the bluetooth dongle and be able to check live data now?

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Sponsored Links
Advertisement
 
  #26  
Old 09-30-2015, 12:41 PM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Aug 2013
Location: Crossville TN
Posts: 15
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 1265
DonGreen is on a distinguished road
Garage
Re: mis-fire codes but does not mis-fire

Problem solved - exhaust restriction caused by failed catalytic converters. The only codes that were thorn were random misfires and the Jeep Dealer told me that there was not a problem with exhaust back pressure, sending me on a wild goose chase.

1st: cleaned the throttle body and replaced the TPS - no improvement
2nd: replaced the spark plugs and all eight coils - no improvement
3ed: replaced the fuel filter/regulator - no improvement
4th: replaced the fuel pump(complete unit) - no improvement
5th: replaced the Y pipe that (contains 2 cats) connects to the exhaust manifolds and replaced the third cat - problem solved

I don't know how the dealer tested the exhaust pressure but a simple solution, if you suspect a problem with restricted exhaust, is to disconnect the exhaust at the headers. If it then runs like a bat out of hell when the gas peddle is stomped, you have located the problem.

A thank you to the Jeep Garage folks for the help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC works but does not blow cold air cwalsh Wrangler-YJ, TJ & JK 2 04-24-2014 06:36 AM
Dash lights on but no codes pull up?? readingbabelfish Troubleshooting/Problems 3 10-25-2012 10:43 PM
Rear hatch mis aligned! Bostondan77 Interior/Exterior/Visual 13 10-25-2012 05:26 PM
# 1 spark plug does not fire. pop terry Troubleshooting/Problems 7 03-09-2012 10:54 PM
"Perform Service" but no codes? wkearney99 Grand Cherokee - WK 10 04-26-2010 01:17 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.