Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-13-2010, 01:38 PM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Angry Multiple Codes...could it be one problem??

Okay, i've had some problems with an injector for a little while, but usually a seafoam treatment in the gastank unclogs it and all is well. Oh, and I also stopped using Ethanol when I had a choice. So now over the past few days I've been get more codes....it was a couple, now there are EIGHT!!!! I'm not driving the jeep til i can have it looked at because the engine light is constantly on and has now started flashing randomly. I'll list the codes below, but my question is, if I fix the first problem, is it likely that it is causing all the other problems???

Here are the codes, in the order they came up on my display.

P0204 #1 injector circuit
P0300 Multiple cylinder misfires
P0301 #1 misfire
P0303 #3 misfire
P0304 #4 misfire
P0420 catalyst below threshold
P0305 #5 misfire
P0171 system too lean

The flashing check engine light tells me that severe catalyst damage and power loss WILL occur. Service immediately!!!!!!!!!!!!!!!

Where is the bank one injector?? can i check the wiring or is it likely a bad injector?? My jeep is a 2001 Grand Cherokee with the 4.7 V8. Guess I don't know if it's a high output or what. there a large black "box" that sits on top of where the injector rails area is if that helps any. I know I can't fix this myself, but I also don't want my mechanic to run up my bill trying various "fixes" if I can let him know where to start with this problem.

Thanks for your help!!!!
__________________

__________________
Reply With Quote
  #2  
Old 06-13-2010, 02:08 PM
ducks unlimited's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: May 2009
Location: Warren ohio
Posts: 3,614
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5607
ducks unlimited has a reputation beyond reputeducks unlimited has a reputation beyond reputeducks unlimited has a reputation beyond reputeducks unlimited has a reputation beyond reputeducks unlimited has a reputation beyond repute
Send a message via AIM to ducks unlimited Send a message via Yahoo to ducks unlimited
Re: Multiple Codes...could it be one problem??

one of the WJ guys should be able to help you
__________________

__________________
2010 Chevy Impala LT
Sold-2008 JGC 5.7 HEMI, 20% FRONT TINT, DUCKS UNLIMITED TINTED TAIL LIGHTS, V-LED TURNSIGNALS, REAR STROBE LIGHT, FIRST RESPONDER 24 LED LIGHTBAR ON DASH, QWIK VALVE, MOBILE 1 OIL & FILTER, 18'' CHROME CLAD RIMS, AUTO TILT MIRRORS, SMARTBEAM TECHNOLOGY
Reply With Quote
  #3  
Old 06-13-2010, 03:38 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 588
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2662
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Multiple Codes...could it be one problem??

Looks to me that you're not getting enough fuel. What's the pressure at the rails? How many miles and have you ever changed the fuel filter?
__________________
Reply With Quote
  #4  
Old 06-13-2010, 09:11 PM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Re: Multiple Codes...could it be one problem??

Have no clue yet what the pressure is at the rails?? wouldn't it indicate more than one injector tho if there was a fuel supply problem?? The jeep has appx. 154000 miles and no, i've never had the fuel filter changed. but, that would be a fairly inexpensive place to start I guess.....after I ask my mechanic to test the voltage at the injectors. What are they supposed to be??? 14ohms??
Thanks for your input. anybody else have any ideas to throw at me???
__________________
Reply With Quote
  #5  
Old 06-14-2010, 02:09 AM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113205
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: Multiple Codes...could it be one problem??

You are not getting enough fuel.

Fuel pump and fuel filter would be my guess also

Injector 1 is driver side first one
Injector 3 is driver side second one

Is that Jeep made for Ethanol use (Flex-fuel)? If not the Ethanol E85 ate your fuel system components.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #6  
Old 06-14-2010, 07:53 AM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Re: Multiple Codes...could it be one problem??

Nope, jeep isn't flex fuel.....but I haven't been using E85...only the 10% ethanol blends...So I guess I will have my mechanic change the fuel filter and see if that does it and go from there. by the way, yesterday I disconnected the battery and let it sit a while...wiggled all of the injector wires to see if any were damaged or anything. When i hooked the battery back up no codes. jeep has been started a few times since....still no codes, no engine light...even though it is running a bit rough.
__________________
Reply With Quote
  #7  
Old 06-14-2010, 08:23 AM
ekaz's Avatar
Member
My Jeep: 2009 7.0L SRT8
 
Join Date: Oct 2009
Location: Chicago
Posts: 561
Thanks: 1
Thanked 11 Times in 10 Posts
Rep Power: 2556
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: Multiple Codes...could it be one problem??

Most gas has up to 10% ethanol in it, so that didn't cause anything. Disconnecting the battery cleared all the codes, so keep that list cause your mechanic won't be able to read them anymore.
It does sound like you are not getting enough fuel, start with the simple stuff first, replace the fuel filter and may run some injector cleaner through it.
The flashing check engine light is most likely from the misfires.
__________________
Unlawful Gathering
Click for details!
2012 300 SRT
2011 GC Overland
2009 Modern Blue Pearl (for sale)
Headlights by DC Customs
Powered by PWR
Shifted by SHR
Tooned by Toona
Blinged by Billet Technologies
Reply With Quote
  #8  
Old 06-14-2010, 08:30 AM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Re: Multiple Codes...could it be one problem??

Okay, maybe i can do that myself. Anyone want to give me the step by step to do that??? thanks guys!!!
__________________
Reply With Quote
  #9  
Old 06-14-2010, 12:58 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 588
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2662
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Multiple Codes...could it be one problem??

Quote:
Originally Posted by DebC68 View Post
Have no clue yet what the pressure is at the rails?? wouldn't it indicate more than one injector tho if there was a fuel supply problem?? The jeep has appx. 154000 miles and no, i've never had the fuel filter changed. but, that would be a fairly inexpensive place to start I guess.....after I ask my mechanic to test the voltage at the injectors. What are they supposed to be??? 14ohms??
Thanks for your input. anybody else have any ideas to throw at me???
You might also try to determine if a single injector is plugged (I doubt it's this b/c you have so many missfires). With the engine running and missing, disconnect the wire to each injector. If the miss gets worse, reconnect and move to the next injector. If you disconnect the injector and the miss stays the same, that injector is bad.

The pressure at the fuel rails should be ~49psi (within 5psi). There's a test port on the passenger side where you can connect a gauge. I believe you can rent one from AutoZone if you don't have one. If you have low pressure (which I suspect), then it's most likely the fuel filter or pump. It's most likely the filter w/ the miles you have.

Attachments are of fuel filter and fuel pressure test locations

Quote:
Originally Posted by DebC68
Nope, jeep isn't flex fuel.....but I haven't been using E85...only the 10% ethanol blends...So I guess I will have my mechanic change the fuel filter and see if that does it and go from there. by the way, yesterday I disconnected the battery and let it sit a while...wiggled all of the injector wires to see if any were damaged or anything. When i hooked the battery back up no codes. jeep has been started a few times since....still no codes, no engine light...even though it is running a bit rough.
Like someone said, you've cleared all the codes by disconnecting the battery. Once you drive it so far the codes will come back. If you're going to run some sort of injector cleaner though, don't waste your money on the autoparts "Injector Cleaner" b/c it's crap. Buy a can of SeaFoam and put 1/2 can in when you're down to 1/2 tank of gas.
Attached Images
File Type: gif Fuel Filter.gif (23.3 KB, 14 views)
File Type: gif Fuel Rails.gif (35.8 KB, 16 views)
__________________
Reply With Quote
  #10  
Old 06-14-2010, 07:54 PM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Re: Multiple Codes...could it be one problem??

Well I talked to my mechanic today, he is going to put a new filter on for me in the next couple days. I really hope that fixes the problem. the jeep has been good to me....only few minor things along the way.
__________________
Reply With Quote
  #11  
Old 06-18-2010, 03:07 PM
DebC68's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Jun 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1582
DebC68 is on a distinguished road
Re: Multiple Codes...could it be one problem??

Okay, new fuel filter is on. old one was completely plugged up. ran some injector cleaner thru with 5 gallons of gas........Jeep is still running like shit. the only code now though is P0171...System too lean. Monday it goes back to the mechanic to have the fuel pressure tested. God I hope over the next couple days the injector cleaner does something and it turns out fine!!!

But......if it is my fuel pump..... I noticed on O'Reilly's site that I can buy the fuel pump assembly or I can just buy the pump and two strainers. The second option would save me $100. Anyone know if option to is a good option?? Thanks.
__________________
Reply With Quote
  #12  
Old 06-18-2010, 04:36 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 588
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2662
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Multiple Codes...could it be one problem??

Fuel injector cleaner that's bought at auto parts stores is pretty crappy. Buy some SeaFoam and put 1/2 can into a 1/2 tank of gas. Run that until empty and see what it does.

But the fuel pressure test should tell you if it's the pump or injectors.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community