Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 04-27-2012, 09:24 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,808
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525740
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Multiple codes, running like $h!+

When one or both tranny speed sensor(s) get bad, the tranny will shift very bad. It can be that there is some dirt/moisture in the connector of the input speed sensor. I would start there and clean it with contact cleaner. If the fault continues, you could decide to change the sensor with a new one. Very easy to do, one connector and one bolt and it comes loose. No fluid will come out normally.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple Problems for 99 & 03 tigger75cars Troubleshooting/Problems 2 04-09-2012 11:53 AM
Multiple engine codes hgb8956 Troubleshooting/Problems 30 06-06-2011 04:44 PM
Multiple engine codes hgb8956 Troubleshooting/Problems Discussion 2 05-10-2011 02:38 AM
Multiple Codes...could it be one problem?? DebC68 Troubleshooting/Problems 23 07-19-2010 04:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community