Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-14-2014, 10:32 PM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Unhappy My dads '99 WJ laredo. HELP!!!!!!

Hey all

We are a Jeep Grand Cherokee family. The problem is with my dads 1999 Jeep Grand Cherokee Laredo. Has a 4.7 V8 with ~222k miles. A few problems.

First, the main, is what I think with a transmission. When she is cold, she starts up and drives fine. It seems like at a certain temperature, when she is at either 3rd or 4th gear, all of a sudden the RPM drop to near idle (does not die) and starts shaking a bit. No matter how far you put in the accelerator, the RPM does not go up. If you park on the side of the road for a bit, then you can drive again for a bit and same thing happens. There are no codes given by the computer.

Second, the transfer case is acting weird. If the rear wheels spin, the front almost never kick in. However the 4LO works fine and all wheels are spinning. I know there is no traction control of any form so I do not know what is going on there. No codes are there either.


Please help guys
__________________

__________________
Reply With Quote
  #2  
Old 01-15-2014, 03:04 AM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

are you saying that you are getting stuck in snow unless you put it in manually to 4 wd if not than the system may be working as intended
__________________

__________________
Reply With Quote
  #3  
Old 01-15-2014, 04:53 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,309
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526360
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

The first problem seems to me engine related and not transmission. Could be a low fuel pressure due to bad fuel pump or TPS, however the last should have set a fault code.
For the second problem, is the jeep quadra drive or quadra trac II, then it has the NV 247 T case. This T case has a progressive coupler which should transfer the torque to the front wheels when there is a speed difference between front and rear. This coupler is probably shot. In 4lo front and rear are mechanically coupled and the coupler is bypassed.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 01-15-2014, 11:30 AM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Re: My dads '99 WJ laredo. HELP!!!!!!

We checked the fuel pressure and it was at 45 psi, changed the filter that did nothing. Could it be something else? To me it kinda feels like its trying to engage low gears all of a sudden, but because you are driving too fast, then it won't let it.

He has Qudra drive. So how do we get to that coupler? I am assuming we have to take the T-case off?
__________________
Reply With Quote
  #5  
Old 01-15-2014, 11:31 AM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Re: My dads '99 WJ laredo. HELP!!!!!!

Quote:
Originally Posted by kennzz05 View Post
are you saying that you are getting stuck in snow unless you put it in manually to 4 wd if not than the system may be working as intended

And yes. Unless you are in 4LO, then on slippery roads you are not going anywhere. Rear wheels spin but front aren't
__________________
Reply With Quote
  #6  
Old 01-15-2014, 04:30 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,309
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526360
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

The coupler is very expensive, you better look for a used T case with warranty.
If you have a scanner which shows live data, you could check the TPS position and see if it shows different values when the problem is there.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 01-15-2014, 04:49 PM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Re: My dads '99 WJ laredo. HELP!!!!!!

I am not good with acronyms. Whats TPS? Assuming throttle position sensor. My friend said that when they tested it, it was fine. engine and fuel are fine from what I got.
__________________
Reply With Quote
  #8  
Old 01-16-2014, 02:57 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,309
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526360
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

Yes, TPS is throttle position sensor.
The tests where all done at the moment the problem was there?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 01-16-2014, 10:03 AM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Re: My dads '99 WJ laredo. HELP!!!!!!

Yes they were...
__________________
Reply With Quote
  #10  
Old 01-19-2014, 01:04 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653071
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

I just want to clarify, you tested the fuel pressure when it was acting up?

I agree with Frank, it sounds like a motor issue, if the throttle opens engines WANT to run, if you give it air, the computer will add fuel and you get more rpms, if opening the throttle does nothing, there is something engine/sensor wise going on there, but again, as frank mentioned, likely something unmonitored, like exhaust back pressure or fuel pressure to mention a couple.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #11  
Old 01-20-2014, 10:44 AM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 834
Tuzmaster is on a distinguished road
Re: My dads '99 WJ laredo. HELP!!!!!!

The engine was rulled out.. the pressure readings were taken at the time of problem and was always constant 45 psi.
__________________
Reply With Quote
  #12  
Old 01-20-2014, 02:29 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653071
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: My dads '99 WJ laredo. HELP!!!!!!

How was the engine or an engine sensor, or control (pcm) ruled out? A transmission has no say in engine rpm.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WK2 Laredo :: 2014 Jeep Grand Cherokee Laredo E j.fiore Member Garage Discussions 0 09-26-2013 09:42 PM
My dads Jeep Tuzmaster Troubleshooting/Problems 13 03-07-2013 07:39 PM
my step dads bike 99limited Other Rides 2 03-25-2010 11:47 PM
My Dads other Ride.... Red03SilSS Other Rides 15 06-04-2009 09:32 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.