Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 04-18-2013, 07:27 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,917
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525870
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Never ever again!

I think that the connector where 2005JGC is talking about is the C200, shown in the attached drawing in the lower right corner.
The two codes you got have to do with the PCI data bus, but it could be that the bus wire passes through the C200 connector.
Update: Just confirmed from the wiring schematic that several data wires pass through the C200 connector. See attached connector pinout. Points 10, 16, 21, 50 and 51 are at least data wires.
Maybe its just a matter of cleaning the pins, but when more trouble shooting is needed, you will have the connector pinout already.
Attached Files
File Type: pdf C200.pdf (142.8 KB, 14 views)
File Type: pdf C200 pinout.pdf (57.3 KB, 13 views)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #14  
Old 04-19-2013, 04:35 PM
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 648
Zombie is on a distinguished road
Re: Never ever again!

Nasty old day outside, I'll tear into the C200 idea tomorrow. Once again Frango, you are a saint. I was mistaking the plug in the engine compartment (PCM) for the C200 in our last conversation. I haven't seen any indications of a windshield leak but its at least another culprit to look at. Springtime in this area is NO place for a moisture related problem lol
__________________

__________________
Reply With Quote
  #15  
Old 04-19-2013, 04:52 PM
Milous's Avatar
Senior Member


 
Join Date: Nov 2009
Location: Nottsure, Wair
Posts: 6,443
Thanks: 33
Thanked 2,148 Times in 924 Posts
Rep Power: 2392428
Milous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond repute
Re: Never ever again!

Check the G200 ground bolt under the center console (ground for the MIC and the BCM), clean bolt and surrounding area, re-tighten bolt, to re-establish good ground.

Diagram:

http://www.wjjeeps.com/pdf/Ground_G200_WJ.pdf
__________________
Reply With Quote
  #16  
Old 04-19-2013, 06:25 PM
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 648
Zombie is on a distinguished road
Re: Never ever again!

One more quick question, when did Jeep/Chrysler go to water cooled electrical connections??? I unplugged the C200 and about a teaspoon of water ran onto the floor, I hope I can refill it when I plug it back in.... HA! You guys are the best!!!! In the drying process now and headed for some contact cleaner and hoping that it didn't fry any of the components. Frango, 2005JGC, and everyone else I send you a great big THANK YOU!!! I will post results later. Pretty confident this has been the culprit of my nightmares. Now to find the leak causing this. If you guys ever get to Indiana, I owe you dinner and a beer (:
__________________
Reply With Quote
  #17  
Old 04-19-2013, 06:38 PM
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 648
Zombie is on a distinguished road
Thumbs up Re: Never ever again!

Quote:
Originally Posted by bill_de View Post
Maybe it needs professional help.



---
This is why I came here. I would rather talk to individuals who have dealt with these issues and will be HONEST about possible reasons and not just tell me to buy this and that and charge me $1000 for "diagnostic tests and trouble shooting" You guys are the "PRO's"
__________________
Reply With Quote
  #18  
Old 04-19-2013, 07:03 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,917
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525870
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Never ever again!

Good to hear that the problem is most likely found. Will you now stay with the jeep?
But the credits and.the.dinner should.go to 2005JGC, he mentioned the C200 first.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #19  
Old 04-19-2013, 10:53 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 598
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2704
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Never ever again!

Quote:
Originally Posted by Zombie View Post
One more quick question, when did Jeep/Chrysler go to water cooled electrical connections??? I unplugged the C200 and about a teaspoon of water ran onto the floor, I hope I can refill it when I plug it back in.... HA! You guys are the best!!!! In the drying process now and headed for some contact cleaner and hoping that it didn't fry any of the components. Frango, 2005JGC, and everyone else I send you a great big THANK YOU!!! I will post results later. Pretty confident this has been the culprit of my nightmares. Now to find the leak causing this. If you guys ever get to Indiana, I owe you dinner and a beer (:
Where you at in Indiana? The way it was today, I'm surprised it wasn't an ice cooled connector.
__________________
Reply With Quote
  #20  
Old 04-19-2013, 11:34 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652973
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Never ever again!

Glad you got it figured out, and glad I could help... fortunately frank was quick to the service information to answer any follow up questions you had. What you don't realize is I'm 300lbs, and your promise for dinner and beer just may be more expensive than a trip to the shop Another thing you didnt realize is the reason I pointed you at that specific connector is because in my time working at a shop getting paid to diagnose vehicles its something I have found and repaired before.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #21  
Old 04-20-2013, 12:20 AM
WKYeti's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 76
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 679
WKYeti is on a distinguished road
Garage
Where at in Indiana?
__________________
Reply With Quote
  #22  
Old 04-20-2013, 05:48 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,917
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525870
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Never ever again!

Quote:
Originally Posted by JeepMe View Post
Where you at in Indiana? The way it was today, I'm surprised it wasn't an ice cooled connector.
Quote:
Originally Posted by WKYeti View Post
Where at in Indiana?
You better reserve a whole restaurant Zombie, it will get busy.........
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #23  
Old 04-20-2013, 02:52 PM
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 648
Zombie is on a distinguished road
Re: Never ever again!

Holy crap! I hope everybody likes bologna sammiches. I live in Southern Indiana, just across the river from Louisville,Ky. Well, that WAS the trouble. Fired right up, all functions back to normal. Oh, just to show you how my luck goes. The last time it did this, I let it set for a few days and when it finally started, I check the windows and the driver side regulator broke(plastic cable block). Put the new one in last week. Wellllllllllllll, after it started today, checked the windows and take a WILD guess what happened to the passengers window. HAHAHAHA I love being me, it makes life an adventure. Thanks again fellas
__________________
Reply With Quote
  #24  
Old 04-20-2013, 03:28 PM
WKYeti's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2013
Location: Indianapolis
Posts: 76
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 679
WKYeti is on a distinguished road
Garage
Nice. I live just north of Brown County State Park.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community