new jeep, few problems - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-10-2015, 01:40 AM
New Member
 
Join Date: Mar 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
20_JGC_00 is on a distinguished road
new jeep, few problems

Hello everyone, just picked up a 2000 Grand Cherokee Limited 4.7L on Friday for pretty cheap with only 133k on it. I have fixed a few things already such as Crank Sensor, Throttle Sensor and some other small things. But one of the problems I'm still noticing is the overhead display has some issues, it always says 500miles till empty and 99mpg and i cant reset the perform service message. Not sure if maybe a wire loose or something else, it also says open circuit, which iv heard is for the outside temp sensor, but not sure on it. Also have a few other questions but I'll start with this haha. If any of you know anything about it and can kind of point me in the direction of what I need to check let me know!

Thanks!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-10-2015, 07:33 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,321
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529478
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: new jeep, few problems

The EVIC has besides the ignition switched battery input, also a direct input. Did you already try a battery disconnect for some minutes?
You can do a self test on the EVIC: with ignition switch in OFF, press C/T button and RESET button simultaneously and then switch ignition in RUN. Wait until the EVIC will show the software version and then release both buttons. The EVIC will start a self test and show at the end the fault(s).
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
a few fuses... a few diff. problems. pls. take a peek. mdspinedoc Troubleshooting/Problems 6 11-24-2014 03:36 PM
14 GC Summit, Problems & Problems w/ Dealer VooDooD Trouble Shooting/Problems/Service 24 07-14-2014 06:52 PM
help me out with a few problems? Rgjr702 Troubleshooting/Problems 13 03-23-2014 11:12 PM
My '95 ZJ lmtd. a few problems Tuzmaster Grand Cherokee - ZJ 6 01-24-2014 09:21 AM
a few problems w/ the jeep.... jth_9 Troubleshooting/Problems Discussion 13 02-25-2011 05:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:01 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.