New Member Fusible link - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2015, 10:27 AM
New Member
 
Join Date: Feb 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jkayakdad is on a distinguished road
Talking New Member Fusible link

Hello, Just joined. 2004 Grand Cherokee larado 6 cylinder. 200000 miles without any major work . trying to locate the fusible link now as it just died no power no lights battery is showing 12 volts on my meter HELP

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-17-2015, 09:16 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529482
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: New Member Fusible link

The fusible link only protects the alternator in a case a short down the line. It should be close to the power distribution center. But 12V over the battery terminals is an almost completely discharged battery. A fully charged battery shows 12.7 V ( half an hour after charging).
Also a blown fusible link will not do anything to the battery feeding the system. The alternator can not charge the battery anymore in that case.
If the battery is charged and you still donīt have any light, i would have a look at the battery cables and the connection of the terminals to the battery.
Have a look for corroded battery poles. What happened to some was corrosion of the battery cable under the wire isolation. To find this, you will need to remove some of the isolation close to the battery terminal.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-21-2015, 11:26 AM
New Member
 
Join Date: Feb 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jkayakdad is on a distinguished road
Re: New Member Fusible link

Thanks Frank. Turns out that the pcm module is going bad. Gotta get one and oh the head is leaking now! Me and my mouth. Will get it fixed as soon as weather allows. I just disconnected the battery and re connected it after a minute and symptoms went away My son drove it for a week before it acted up again . He says he saw vapor coming from the head on the right side weather is too cold wet and messy to do anything but park it.

What happened first was I started the gc and it immediately lost all power lights windows starter dash lights everything. Thought I had blown the main power fuse(s) well I didn't find one anywhere. during my search for a definitive fault I came across a posting with similar problems. they solved the problem by resetting the pcm simply removing power from the jeep and then reapplying the power . I did this and viola it worked .. My question now is should I replace the pcm at this point?
Reply With Quote
  #4  
Old 02-21-2015, 12:27 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529482
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: New Member Fusible link

But the fact that no lights where working, point to an other problem. Why do you suspect the PCM? Was the vapor from a head gasket leak, or was it just moisture from the road which was evaporating?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 02-21-2015, 12:33 PM
New Member
 
Join Date: Feb 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jkayakdad is on a distinguished road
Re: New Member Fusible link

Frank I'l give ya a thanks when I figure out how too. as for the vapors I haven't yet seen them myself the car is using up coolant and has an odd smell but it has been doing it for awhile recently had to replace heater core that didnt get rid of smell do have a new radiator thermostat and water pump
Reply With Quote
  #6  
Old 02-21-2015, 02:26 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529482
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: New Member Fusible link

Quote:
Originally Posted by Jkayakdad View Post
What happened first was I started the gc and it immediately lost all power lights windows starter dash lights everything. Thought I had blown the main power fuse(s) well I didn't find one anywhere. during my search for a definitive fault I came across a posting with similar problems. they solved the problem by resetting the pcm simply removing power from the jeep and then reapplying the power . I did this and viola it worked .. My question now is should I replace the pcm at this point?
I didnīt see the second part of your answer on my mobile.
Since you lost all power, i would not suspect the PCM at this point. There must be a problem with the wiring. Many times the battery cables are suspect, they can start corroding inside the insulation and cause strange things to happen. Maybe by disconnecting the battery and bending the wire a bit, contact was restored.
It can also be a bad battery. If it has only 12V, its not properly charged. A properly charged battery has 12.7V half an hour after engine shutdown.
Eventhough the PCM can reset with a battery disconnect, this can have nothing to do with loosing all power to lights, starter or other components.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New MotorTrend Road Test Link transam Grand Cherokee SRT - WK2 5 08-10-2011 04:18 PM
Changes in new sofware for 430N (except Travel Link) JoeSchmoe007 Audio/Visual/Navigation 22 05-01-2011 01:18 PM
Rugged Brown Summit with new 730N RHR...see link Dan JGC Audio/Visual/Navigation 8 02-26-2011 02:43 PM
replace fusible link in alternator/battery harness garyg Troubleshooting/Problems 0 02-15-2011 09:14 AM
add the Jeepgarage.org link to your cardomain site! Scottina06 Site News, Help, and Feedback 60 08-10-2009 01:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:36 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.