Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-18-2012, 09:05 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
o2 crapped after motor rebuild..

so i am getting o2 codes for either efficency or something ill post tommorrow morning when i scan with scan gauge.. i have emissions testing due in end of august..... i know everyone says oem but are these 4.7 that finicky on o2.? i called dealer they quoted me almost 200 each. i went to mopar website and they say 80....do i chance it or have to bite bullet. and go dealer,, or did a fuse pop? i remember some cars have fuses for o2 but idk if jeep does...
__________________

__________________
Reply With Quote
  #2  
Old 07-18-2012, 09:55 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525696
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 crapped after motor rebuild..

The O2 sensors on the Jeeps are from Denso, so you could look for those. The Bosch ones give problems due to the longer heatup time.
Depending on which emission system your Jeep has, there is (are) one or 2 fuse(s) in the PDC for the O2 heaters.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 07-19-2012, 05:29 AM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
OK ill look

Turbo charged G2X using tapatalk 2
__________________
Reply With Quote
  #4  
Old 07-19-2012, 06:03 AM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
0159 0141 0161. my codes

Turbo charged G2X using tapatalk 2
__________________
Reply With Quote
  #5  
Old 07-19-2012, 06:41 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525696
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 crapped after motor rebuild..

Indeed all O2 sensor related.
P0141 = Heater performance bank1
P0159 = Slow response bank 2
P0161 = Heater performance bank 2

There is a common fuse in the PDC, fuse 16, for the O2 heaters. For the downstream sensors there is also a relay in the PDC and seems that for some models that there is even a relay for the upstream sensors.
Would not expect both sensors to be bad at the same time, maybe a wire damaged or just the fuse blown?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 07-19-2012, 09:06 AM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
well coolant was leaking.into #8 and burning it so its either that or.any wires that run along passenger head area

Turbo charged G2X using tapatalk 2
__________________
Reply With Quote
  #7  
Old 07-21-2012, 09:19 AM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
fuse and relay are OK.

Turbo charged G2X using tapatalk 2
__________________
Reply With Quote
  #8  
Old 08-02-2012, 09:36 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
so I'm doing this fix this weekend . I know its gonna be.a 50/50 if its a cat issue.or o2 issues. now that I posted my codes how many o2 sensors do I have? I found carquest sells denso.60-70 each. for upstream and 90 each downstream ... looking at my codes which ones would I need? both on right side or all 4? if there are four ....

G2X tapaTalk
__________________
Reply With Quote
  #9  
Old 08-02-2012, 10:15 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,093
Thanks: 95
Thanked 68 Times in 64 Posts
Rep Power: 331882
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: o2 crapped after motor rebuild..

I'd at least change both front and rear on the #8 side. Antifreeze seems to take them out every time.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #10  
Old 08-03-2012, 12:44 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
both front? there are two on the.pre cat and.one after cat? if so holy crap. ill do all "4" if they exist per carquest

G2X tapaTalk
__________________
Reply With Quote
  #11  
Old 08-04-2012, 12:40 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525696
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 crapped after motor rebuild..

Depending on the emission package your jeep has, there are some options. But as Dave says, start changing the bank 2 upstream and downstream sensors and see what it does.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 08-04-2012, 12:47 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 981
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2327
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
OK will do

G2X tapaTalk
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission rebuild manual Frango100 Grand Cherokee - WJ 4 06-16-2012 12:26 AM
Wj front diff rebuild help Jeff_Jeske Troubleshooting/Problems 10 02-11-2011 11:01 PM
Rebuild ? citizinsoldier11B Troubleshooting/Problems 0 02-01-2011 11:47 PM
Axle rebuild question psyco6string Grand Cherokee - WK 2 02-11-2010 06:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community