Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-17-2013, 08:03 AM
New Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jeepguy2004 is on a distinguished road
o2 sensor help

I own an 04 grand cherokee with the 4.0 motor.

I have two codes coming up with P0135 Generic o2 heater circuit (Bank 1, Sensor 1)

Also (Bank 2, Sensor 1)

I am trying to order o2 sensors, but not sure if they are down stream, upstream, right, left, etc..

If i could get some help on this it would be great!!

Thanks!!
__________________

__________________
Reply With Quote
  #2  
Old 02-17-2013, 10:08 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525695
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 sensor help

The upper sensors, closest to the engine manifold are the 1 sensors, the downstream sensors are the 2 sensors.
The forward manifold is bank 1, so the aft manifold is bank 2.
So bank 1 sensor 1 is the forward manifold upper sensor and bank 2 sensor 1 is the aft manifold upper sensor. See also attached picture.
Also the OEM sensors are from Denso. Eventhough Bosch sensors are good, they heat up more slowly then the Denso sensors and could throw you a fault code again.
Oh, and check the heater fuse first before ordering, fuse 16 (15Amp) in the power distribution center.
Attached Files
File Type: pdf O2 SENSOR 4.0.pdf (128.5 KB, 16 views)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-24-2013, 07:39 AM
New Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jeepguy2004 is on a distinguished road
Thanks!! Appreciate the help. I ordered sensors I need.
__________________
Reply With Quote
  #4  
Old 08-05-2013, 07:16 PM
New Member
 
Join Date: Aug 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
devin.rocks is on a distinguished road
Re: o2 sensor help

I am hoping that you will see this thread. I replaced all of my O2 sensors with Bosch because I didn't know any better before reading this post and my jeep is again showing the same fault code for the bank 1 sensor 1. I have reset the ECM three times. How do I get rid of this code if the sensor is heating up to slow? I could really use some advice.
__________________
Reply With Quote
  #5  
Old 08-05-2013, 09:51 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525695
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 sensor help

There are guys who use the Bosch sensors without any issues, but they could heat too slowly for the jeep PCM and then a fault code is set. If this is the problem, then only replacing with the Denso sensors will help. But ofcourse the problem could be something else. Did you check the fuses for the O2 heaters? The problem could also be with the wiring.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 08-05-2013, 10:41 PM
New Member
 
Join Date: Aug 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
devin.rocks is on a distinguished road
Re: o2 sensor help

I did check the fuses and everything is ok. I also checked all of the wiring and there were no red flags. I made it 10 miles the last time and it came back on. I am at a loss now.
__________________
Reply With Quote
  #7  
Old 08-05-2013, 11:47 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525695
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 sensor help

You could swap both upstream sensors and see if the fault follows. Could be a problem with one of the new sensors.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 08-06-2013, 09:32 AM
New Member
 
Join Date: Aug 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
devin.rocks is on a distinguished road
Re: o2 sensor help

I already replaced the sensor again.
__________________
Reply With Quote
  #9  
Old 08-06-2013, 12:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525695
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 sensor help

And that solved the problem?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 08-07-2013, 10:21 PM
New Member
 
Join Date: Aug 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
devin.rocks is on a distinguished road
Re: o2 sensor help

No, it is still giving the same code.
__________________
Reply With Quote
  #11  
Old 08-07-2013, 10:51 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,773
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525695
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: o2 sensor help

Still Bosch sensors?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i need help with a sensor 05WK4.7 Grand Cherokee - WK 4 11-12-2012 09:54 PM
What is this sensor from? honda_fox3 Troubleshooting/Problems 3 07-10-2012 10:38 AM
Which O2 Sensor is Better? SoCalMoparWK Grand Cherokee - WK 5 04-07-2011 04:04 PM
TPS sensor and Cruise Control sensor dhryan44 Troubleshooting/Problems 15 03-03-2011 01:17 AM
What's that sensor-looking thing? THEPRFCT10 Grand Cherokee - WK2 - 9 01-03-2011 01:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community