Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-05-2014, 03:37 PM
oilslick's Avatar
Premium Member
My Jeep: 2001 4.0L
 
Join Date: Mar 2010
Location: N.E. Pa.
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1673
oilslick is on a distinguished road
Occasional starting problem

Hey folks, maybe someone has had the same issue with their G.C.

I have a 2001 G.C. Laredo I-6 and it occasionally has a problem starting. Every once in a while when I turn the ignition to start it will do nothing
. But when I turn the ignition switch back to off and then back to start it starts. I did notice that it usually loses power to it's electronics such as the radio and door locks. (radio time has to be re-set)

Also, not sure if it's related but one time after this happened, I noticed that the ABS light and brake light came on and the odometer numbers were flickering/blinking. This happenened a few times also without the starting issue and a code came up with a problem with the ABS control unit.

So, I'm not sure if I have two issues or just one here.

Any ideas anyone? Thanks in advance!!!
__________________

__________________
Do not argue with an idiot! He will drag you down to his level and beat you with experience!
Reply With Quote
  #2  
Old 07-07-2014, 07:46 PM
oilslick's Avatar
Premium Member
My Jeep: 2001 4.0L
 
Join Date: Mar 2010
Location: N.E. Pa.
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1673
oilslick is on a distinguished road
Re: Occasional starting problem

Any clue?
__________________

__________________
Do not argue with an idiot! He will drag you down to his level and beat you with experience!
Reply With Quote
  #3  
Old 07-07-2014, 07:52 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 857
Thanks: 35
Thanked 74 Times in 66 Posts
Rep Power: 1527
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Occasional starting problem

Sounds like you have an electrical short somewhere that's draining the battery down over time. Voltage gets too low, obviously it won't start. It also makes the gauges go bonkers and you can get any number of codes. It's all related.

When was the last time you replaced the battery? If it's near or over 3 years old it's probably time for a new one. On my 02, I had to replace my battery every 3 years, almost to the day.
__________________

Garage: The Ghost
Reply With Quote
The Following User Says Thank You to MDBones For This Useful Post:
  #4  
Old 07-07-2014, 08:03 PM
oilslick's Avatar
Premium Member
My Jeep: 2001 4.0L
 
Join Date: Mar 2010
Location: N.E. Pa.
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1673
oilslick is on a distinguished road
Re: Occasional starting problem

The battery is not drained though. (it's 2 yrs. old BTW) When it happens, the first time I turn the ignition to start it's like it has zero power. But when I try again a second later it immediatly fires right up with no long, slow cranking. Weird.

It just did it again about an hour ago.
__________________
Do not argue with an idiot! He will drag you down to his level and beat you with experience!
Reply With Quote
  #5  
Old 07-07-2014, 08:13 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 857
Thanks: 35
Thanked 74 Times in 66 Posts
Rep Power: 1527
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Occasional starting problem

Batteries are fickle things. The only other thing that could cause that would be an intermittent ground problem... like a loose connection.
__________________

Garage: The Ghost
Reply With Quote
The Following User Says Thank You to MDBones For This Useful Post:
  #6  
Old 07-07-2014, 08:24 PM
oilslick's Avatar
Premium Member
My Jeep: 2001 4.0L
 
Join Date: Mar 2010
Location: N.E. Pa.
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1673
oilslick is on a distinguished road
Re: Occasional starting problem

Quote:
Originally Posted by MDBones View Post
Batteries are fickle things. The only other thing that could cause that would be an intermittent ground problem... like a loose connection.
Well, it can't hurt to test it right? Thanks for the reply!

I have to get the oil changed on friday, so I'll check it out then.

I'll advise if I can resolve it.
__________________
Do not argue with an idiot! He will drag you down to his level and beat you with experience!
Reply With Quote
  #7  
Old 07-07-2014, 08:29 PM
MDBones's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 857
Thanks: 35
Thanked 74 Times in 66 Posts
Rep Power: 1527
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Occasional starting problem

Good luck, hope they track it down for you.
__________________

Garage: The Ghost
Reply With Quote
  #8  
Old 07-07-2014, 08:40 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,970
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525932
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Occasional starting problem

The battery would be the first thing to check, but when it starts the second time without hesitation, i would think that the battery is not the issue. But a check from a shop would proof that.
I would almost think about a bad ground strap (corrosion at the stud) or, what is also well known on the WJ, corrosion on the battery cables close to the battery terminals. You will need to peel back the wire isolation to check for this corrosion.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #9  
Old 08-12-2014, 07:34 PM
oilslick's Avatar
Premium Member
My Jeep: 2001 4.0L
 
Join Date: Mar 2010
Location: N.E. Pa.
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1673
oilslick is on a distinguished road
Re: Occasional starting problem

UPDATE: Problem resolved!

Well, the starting problem got worse over the last month so I finally took it to my friend's garage and checked for loose wires, connections etc.

After finding nothing loose, corroded or any bare wires, we decided to change the ignition elec. switch and the battery. Well, that did the trick! Now, after two weeks of starting with no problems, I have to say that the battery was the issue, it probably had some sort of internat short because the headlights (which has direct power) only worked sometimes when the issue arose.

So, thanks to you guys for your help and advice!! Much appreciated!
__________________

__________________
Do not argue with an idiot! He will drag you down to his level and beat you with experience!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
01 Limited 4.7 occasional no start problem SilverLimited Troubleshooting/Problems 5 11-02-2012 07:49 PM
Lifted Jeep- Occasional Grinding Noises (ESP?) Kayak83 Suspension/Brakes/Wheels/Tires 4 06-21-2012 11:31 AM
Occasional thump/bang at stop? TTDAD Troubleshooting/Problems 6 12-16-2011 02:45 PM
Occasional hard-start condition dr.lee.baugh Grand Cherokee - WK 2 06-20-2011 06:38 AM
occasional faint beep tone when doors lock... weird JDubya Grand Cherokee - WK 7 04-09-2011 04:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community