Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-21-2012, 02:38 PM
Member
My Jeep: 1999 WJ
 
Join Date: Aug 2011
Location: Santa Cruz, CA
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1243
beto4632 is on a distinguished road
Oil Presure Drops to Zero?

HI guys i recently noticed that my oil pressure drops down to zero on my i6 wj. At times it reads it normally. When i turn the car on it jumps but once i run the car for about 10min or more and i stop at a red light or start slowing down the needle drops down to 0 the check gauges light turns on once i step on the gas it goes up to about 40psi and does not pass that. So i changed my oil thinking it might of been a bad filter. But after a couple days it came back but it stops just above 0 without the check gauges light and as i was searching online my best guess might be the "Oil Sending Unit" might need to get replaced. And replacing it with the Original Mopar sounded like its the way to go. Does anybody have any suggestions on my problem thank you. Or on the Model Number for the original Mopar part so i can possibly get it online?

And there is no knocking or weird things happening to the wj
__________________

__________________
Reply With Quote
  #2  
Old 08-21-2012, 03:25 PM
Duff Daddy's Avatar
Member
My Jeep: 2007 5.7L WK
 
Join Date: Jun 2012
Location: Ma
Posts: 259
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1165
Duff Daddy is on a distinguished road
Re: Oil Presure Drops to Zero?

I would check with a mechanical gauge to make sure it has physical pressure, this will also tell you if its a sending unit or an internal issue with the engine. If all is good then, take a look at the sending unit and double check that the wiring is ok and no oil has been "wicked" up through the harness.
__________________

__________________
Steve Duffy Performance
2007 Grand Cherokee Limited HEMI
1996 Mustang GT RacecaR
Reply With Quote
  #3  
Old 08-21-2012, 03:54 PM
Member
My Jeep: 2009 4.7 HO WK
 
Join Date: Apr 2012
Location: Cherry Hill, NJ
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 998
bumnt is on a distinguished road
Re: Oil Presure Drops to Zero?

Bad oil pressure sensor.

Replace and all should be good.

-k
__________________
Reply With Quote
  #4  
Old 08-22-2012, 06:44 PM
New Member
My Jeep: 2001 4.0L WJ
 
Join Date: Jul 2012
Location: Harpers Ferry WV
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
nitroburn is on a distinguished road
Re: Oil Presure Drops to Zero?

Just experienced the same thing yesterday after taking an 800mi. trip.Pulled in driveway and check gauges light comes on. Zero pressure raised rpm's and came up to 45lbs. and then dropped back to zero.Shut it down to look at oil,for signs of thinning or foamimg seen nothing out of the ordinary.Going to check sensor tomorrow and change and inspect oil and filter for metal. Will let you know of my outcome.
__________________
Reply With Quote
  #5  
Old 09-01-2012, 09:09 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Jan 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1086
bigdee is on a distinguished road
Re: Oil Presure Drops to Zero?

I also have the same problem. Spent alot of time obsessing about it,verified with mechanical gage to be 5psi at HOT idle (650rpm) and 22psi at 2000rpm. This was 8 months and many miles ago. I drive it and don't worry about it any more. Low pressure is caused by wear 99% of the time and the ONLY solution is to fix the root cause. If your engine is quiet and the lifters are not collapsing at idle you may be able to drive it for a long time. Don't focus on pressure,even if you could raise it it would not solve anything. The interesting thing, assuming that you have engine wear is the fact that you HAVE GREATER oil FLOW now due to the increased clearances. Flow is much more important than pressure. Like I said the only real fix is to replace whatever is worn...if you are not ready to do that there is no need to worry about the pressure.
__________________
Reply With Quote
  #6  
Old 09-02-2012, 08:21 AM
Member
 
Join Date: Feb 2010
Location: CT
Posts: 968
Thanks: 1
Thanked 6 Times in 5 Posts
Rep Power: 22072
jeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond reputejeepster23 has a reputation beyond repute
Re: Oil Presure Drops to Zero?

Quote:
Originally Posted by bumnt View Post
Bad oil pressure sensor.

Replace and all should be good.

-k
X2 be careful it happened to me and I tried to put off changing it for a couple days till the weekend came and it finally completely blew and started pissing oil everywhere. Thank God I was at home and just idling letting it warmup when it happened cause I was able to shut down without damage to the engine.
__________________
Reply With Quote
  #7  
Old 09-02-2012, 08:44 AM
ItsAJeepThing's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: Jun 2009
Location: BROOKLYN, NYC
Posts: 1,009
Thanks: 7
Thanked 12 Times in 12 Posts
Rep Power: 388433
ItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond reputeItsAJeepThing has a reputation beyond repute
Re: Oil Presure Drops to Zero?

I had the same problem on my i6 wj. Changed the oil pressure sensor and all was good.
__________________

__________________
1999 Jeep Grand Cherokee Laredo I6 4.0 227k miles SOLD 10/13/11
2009 Jeep Grand Cherokee Limited V6 3.7 29k miles
SRT8 Front/Rear bumpers, SRT resonators/tips, Flowmaster Super 44 series muffler, KnN 77 series CAI, 8000k HIDs Lows/Fogs, Brilliant Black SRT Grill, 22" Gloss Black SRT Reps, 20% Tints, and a lot more to come =]


Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phone now drops out after pairing with uConnect hammer1234 Audio/Visual/Navigation 5 03-21-2012 05:45 AM
Transmisson drops to neutral - power off solution? tcjeep Wrangler-YJ, TJ & JK 2 09-17-2011 08:20 AM
RPM drops while stopped if A/C is on... is there a solution to fix this? thex2 Grand Cherokee - WK 4 11-22-2010 02:59 PM
99 WJ RPM drops! Andrew Engine Performance/Intake/Exhaust 37 10-30-2010 07:10 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.