Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-07-2011, 12:15 PM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Nov 2011
Location: Knoxville, TN
Posts: 73
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1361
PeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond repute
P0432 Code

I got a code this morning.

P0432 Main Catalyst Efficiency Below Threshold (Bank 2) ; Catalyst 2/1 efficiency below required level.

I have searched and surprisingly no one else has had this happen on this site.

This is the second time I have received this code. Both times I was sitting at the exact same stop light, at approx the same time in the morning on my way into the office.

A little history:
Each time I get the light about a week after I do a seafoam treatment.
Each time I am sitting at idle when light comes on.
Jeep has a rough idle. Changed plugs and oil. 75k miles on odo. 4.7L HO.

Is this a bad cat or bad O2 sensor?
Opinions, thoughts are welcomed and appreciated.
__________________

__________________
Reply With Quote
  #2  
Old 12-07-2011, 12:36 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54180
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: P0432 Code

I would check the wires, its possible one is damaged and causing an intermittent signal loss. Otherwise it sounds to me like you have the right ideas, either the O2 sensor is shot or the Cat is no good. Very low mileage for either to go out, but I would suggest replacing the sensor first, easier and cheaper than a new Cat (assuming its not rusted in too bad).
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 12-07-2011, 01:29 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Strongstown Pa.
Posts: 3,025
Thanks: 87
Thanked 65 Times in 61 Posts
Rep Power: 331691
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: P0432 Code

I would check the O2 sensors for sure.That's the problem I have with everybody running Seafoam through their vacuum line. These o2 sensors hate contamination of any kind.You even have to watch what kind of sealant you use. All that concentrated Seafoam at one time burning and running through your exhaust probably is screwing up the sensors. Don't get me wrong I use it all the time just in the oil and gas. I had a plenum gasket go in my work car and it was leaking antifreeze into the combustion chambers. After i fixed it about a few days later the o2 sensors crapped out. Could be a coincidence but I think it was the antifreeze.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #4  
Old 12-07-2011, 01:31 PM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Nov 2011
Location: Knoxville, TN
Posts: 73
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1361
PeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond repute
Re: P0432 Code

Ok thanks. I will check out new sensors.
Next time I do seafoam, I will put old sensors in while treatment is being done, then put new sensors in when finished.
__________________
Reply With Quote
  #5  
Old 12-07-2011, 03:51 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,335
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: P0432 Code

Seafoam through the vacuum line is in fact removing all the carbon buildup in the cilinders and the oil dirt in the inlet duct. All this oily stuff burning away so quickly, is causing a lot of particles which can foul the O2 sensor, but i heard that it can also cause (partly) clogging of the small holes in the Cat.
Cleaning or changing the O2 sensors would be my first action as well.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 12-17-2011, 09:22 AM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Nov 2011
Location: Knoxville, TN
Posts: 73
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1361
PeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond repute
Re: P0432 Code

UPDATE:
I took the Jeep to the dealer. I still had a warranty on the catalysts. They replaced the two precats. Much more flow, but I think my third cat, right before the muffler, is a little clogged too. So far, no code.
__________________
Reply With Quote
  #7  
Old 12-18-2011, 05:56 PM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Nov 2011
Location: Knoxville, TN
Posts: 73
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1361
PeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond repute
Re: P0432 Code

Can an O2 sensor be bad and NOT throw a code? I am still having a rough idle and unless it's me, I think the Jeep is running below its potential.
I wish someone close to me had an HO so I could compare how this thing is supposed to sound/run.
My only other means of comparison is my 4.6 interceptor and it sounds and feels so much more powerful, but the stats show the HO is a more powerful engine than my Ford cruiser.
__________________
Reply With Quote
  #8  
Old 12-18-2011, 07:00 PM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Nov 2011
Location: Knoxville, TN
Posts: 73
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1361
PeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond reputePeterB16 has a reputation beyond repute
Can O2 be bad without a code?

Quote:
Originally Posted by PeterB16 View Post
Can an O2 sensor be bad and NOT throw a code? I am still having a rough idle and unless it's me, I think the Jeep is running below its potential.
I wish someone close to me had an HO so I could compare how this thing is supposed to sound/run.
My only other means of comparison is my 4.6 interceptor and it sounds and feels so much more powerful, but the stats show the HO is a more powerful engine than my Ford cruiser.
edit title
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
P 0158 Code Joe's2001Laredo Troubleshooting/Problems 4 09-13-2011 10:24 PM
P 0513 code? ONEbadHEEPtruck Grand Cherokee - WK 1 06-15-2011 03:36 PM
P0174 Code?!? Jay Grooms Grand Cherokee - WK 7 05-22-2011 08:09 PM
Code Robert Palmer Trouble Shooting/Problems/Service 14 05-17-2010 11:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community