Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-04-2012, 02:43 PM
Senior Member
 
Join Date: Jul 2009
Location: Scotland, UK
Posts: 1,878
Thanks: 20
Thanked 15 Times in 15 Posts
Rep Power: 79924
Martyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond reputeMartyp has a reputation beyond repute
P1495 LDP Solenoid Circuit

Here is a question for you all.

Now, my truck has never once thrown me a code since I have owned it.

I have ran both stock PCM and Superchip'd 91 Perf PCM. However, Saturday I received my SCT tuner and my PCM P/N wasn't in the supported list.

On the bright side I did manage to overwrite it to a stock 02 PCM which Ryan loaded on it for me [I crossed everything and didn't breath for the entire time it was downloading, a brain damaged Jeep was not what I was wanting].

I turned the key to the IGN on position and started her up, first time fired up and idled smoothly @ 550rpm as normal. However, the CEL came on too. I checked the code with the SCT and it read P1495 upon a Google search this relates to the Leak Detection Pump (something to do with the EVAP canister).

I took it for a run today and it runs just like my stock tune but the CEL won't go off. If I clear it, it comes right back on again upon next start.

Just restored to my stock tune and have no CEL or codes showing.

This leads me to believe it is just something I can just ignore right? Perhaps the US tune has different tolerances or sensors for this thing causing it to throw the CEL?

Checked all the vac lines and they are all plumbed in and uncracked etc, can't hear any sucking noises (minus the CAI).


Just wondered if any of you had this in the past or would agree I can just ignore this. Put the stock tune back on just now anyway as I hate having lights on the dash, its kinda embarrassing.
__________________
Marty

"Even though I walk through the valley of the shadow of rice, I will fear no turbo for thou torque art with me. Thy rods and crankshaft, they comfort me."
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crankshaft Position Sensor Circuit n8jay Engine Performance/Intake/Exhaust 6 10-15-2013 06:55 AM
Replacing the Governor Pressure Sensor and Solenoid Amelie Troubleshooting/Problems 0 10-16-2011 05:02 PM
p1494 LDP replacement violant00 Troubleshooting/Problems 4 03-03-2011 11:39 AM
Replacing an electric fan solenoid Joe in PA Tech Tips DIY/How To 4 04-09-2010 01:02 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community