Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-14-2010, 11:44 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Mexicali, Mexico
Posts: 113
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1756
Hac_PTR is on a distinguished road
Problems P0161 & P030 WJ

Need help

Iím getting this codes on my Wj 4.7 HO 2002 Overland:
P0161 O2 Sensor Heater Circuit (Bank 2 Sensor 2)
P0303 Cylinder # 3 Misfire


when my WJ is on Parking I can feel a litle of shake or small vibration, definitely something is not working right:
What Can I do?
I already replace Spark Plugs and nothing happen.
I was wondering if, first I need to test Oxygen Sensor, but I do not how to test.
Or any idea?
__________________

__________________
Reply With Quote
  #2  
Old 02-14-2010, 11:54 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,787
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717365
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Problems P0161 & P030 WJ

did you maybe break the bolt or not tighten the bolt on the #3 coil? Did you gap the plugs? Sounds like the #2 02 sensor needs replaced. Use only the oem 02.
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 02-14-2010, 11:56 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 24 Times in 24 Posts
Rep Power: 63339
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: Problems P0161 & P030 WJ

Change the O2 Sensor. Like Scott said above make sure you get an OEM one.
__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #4  
Old 02-15-2010, 12:37 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Mexicali, Mexico
Posts: 113
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1756
Hac_PTR is on a distinguished road
Re: Problems P0161 & P030 WJ

Scott & Paul thank you for your prompt response"
Scott Yes all the nuts and wires where connected in the same way it was before I removeed the spark plugs.
I didn't check the gap on the spark plug, I will check tomorrwo, what is the right Gap?
On the other hand Do you now if there is any way to test the sensor before replace it? and which on of the O2 sensor I will need to replace?


Sorry for many questions but I'm a beginner on cars!

Gracias !
__________________
Reply With Quote
  #5  
Old 02-15-2010, 12:41 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,787
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717365
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Problems P0161 & P030 WJ

sorry bro.....Im not sure of the gap on the ho 4.7...but I will try to find it. Also check the coil on #3 as well....it could be bad. Send a pm to sleepy4.7 about the 02 sensor. Im not sure where the #2 02 sensor is on the 02 4.7 ho. Sorry Im not too familiar with the WJ exhaust set up.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #6  
Old 02-15-2010, 12:46 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,787
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717365
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Problems P0161 & P030 WJ

here ya go bro....
http://www.wjjeeps.com/service/sparkplugs.htm

dont use a wire-type gapping tool. Use a tapered-type gauge. The Gap specification is 0.040 for the 4.7L HO engine.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #7  
Old 02-15-2010, 12:47 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,787
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717365
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Problems P0161 & P030 WJ

check this for the 02 sensors

http://www.wjjeeps.com/oxygen.htm
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #8  
Old 02-15-2010, 02:01 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Mexicali, Mexico
Posts: 113
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1756
Hac_PTR is on a distinguished road
Re: Problems P0161 & P030 WJ

????
__________________
Reply With Quote
  #9  
Old 02-15-2010, 02:25 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,787
Thanks: 831
Thanked 815 Times in 627 Posts
Rep Power: 7717365
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Problems P0161 & P030 WJ

Quote:
Originally Posted by Hac_PTR View Post
????

can you not view the wjjeeps.com pages? I pulled the gap info here...but there are pics showing the 02 sensor locations on wjjeeps link I posted
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #10  
Old 02-15-2010, 03:57 PM
Rich's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2009
Location: CT
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1881
Rich is on a distinguished road
Re: Problems P0161 & P030 WJ

Quote:
Originally Posted by Hac_PTR View Post
Scott & Paul thank you for your prompt response"
Scott Yes all the nuts and wires where connected in the same way it was before I removeed the spark plugs.
I didn't check the gap on the spark plug, I will check tomorrwo, what is the right Gap?
On the other hand Do you now if there is any way to test the sensor before replace it? and which on of the O2 sensor I will need to replace?


Sorry for many questions but I'm a beginner on cars!

Gracias !
I think you can test O2 sensors with a multimeter, though not sure of proper impedance? anyone?
__________________
~Rich
White 05 WK 5.7 Limited

Added: REC Nav w/ In Motion Hack, Sirius, iPod | Mopar CAI | Hardwired V1
Reply With Quote
  #11  
Old 02-15-2010, 04:04 PM
Rich's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2009
Location: CT
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1881
Rich is on a distinguished road
Re: Problems P0161 & P030 WJ

Ok I was wrong, should be looking for voltage change not ohms...

See:
http://mr2.com/TEXT/O2_Sensor.html
__________________
~Rich
White 05 WK 5.7 Limited

Added: REC Nav w/ In Motion Hack, Sirius, iPod | Mopar CAI | Hardwired V1
Reply With Quote
  #12  
Old 02-18-2010, 05:58 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Mexicali, Mexico
Posts: 113
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1756
Hac_PTR is on a distinguished road
Re: Problems P0161 & P030 WJ

Just to let you know °
I went with my mechanic and we found that 1 head was crack, unfortunately.

The miss fire codes was because the coolant was leaking in to the cylinder and it looks like the code of the O2 is because is reading humidity.
We remove the spark plugs from Cyl #3 and #5 and they were with residues of Antifreeze.
I didn’t notice but the coolant from my radiator start to go low and it was because of the leak.
The repair will cost me around $500.00 USA dll!
I will not replace the O2 until I have my rebuild cylinder heads on !


Thank you all four your support and comments !
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
more advice on I-6 problems tju4u Troubleshooting/Problems Discussion 8 02-11-2010 07:30 PM
problems 99limited Audio, Video, Navigation & Electronic Modifications 6 10-23-2009 12:30 AM
K&N Air intake installed - but some problems! Andrew Engine Performance/Intake/Exhaust 42 09-15-2009 09:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:12 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community