Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-10-2011, 05:53 PM
Jeff_Jeske's Avatar
Member
 
Join Date: Aug 2010
Posts: 468
Thanks: 2
Thanked 5 Times in 5 Posts
Rep Power: 2262
Jeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond repute
Signal lights stopped working.....

So this has happened twice now.... both left and right signal lights stopped working but if I turn my hazards on they do work and afterwards my signals start to work again. Ideas?
__________________

__________________
Reply With Quote
  #2  
Old 02-10-2011, 07:52 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,167
Thanks: 9
Thanked 118 Times in 111 Posts
Rep Power: 526183
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Signal lights stopped working.....

The hart of this system is the combination flasher, an electronically controlled relay. Would suspect this one , or the switch. The relay is installed under the drivers side dash.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-13-2011, 11:39 PM
Jeff_Jeske's Avatar
Member
 
Join Date: Aug 2010
Posts: 468
Thanks: 2
Thanked 5 Times in 5 Posts
Rep Power: 2262
Jeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond repute
Re: Signal lights stopped working.....

Got a pic?
__________________
2013 Ford Edge Sport AWD
2011 Jeep Grand Cherokee Overland w/Hemi
2006 Mitsubishi Evolution 9 - Highly Modified Time Attack Car - DYNO (PUMP/E85)
Reply With Quote
  #4  
Old 02-14-2011, 12:23 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,855
Thanks: 5
Thanked 28 Times in 28 Posts
Rep Power: 26275
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: Signal lights stopped working.....

that sounds like the problem I had a few weeks back. It was the flasher unit.
they talk about it here
http://www.wjjeeps.com/fuses.htm#FLASHER
basically you need to pop off the trim behind the steering wheel in front of the guage cluster and there are 2 screws to remove beneath that, 1 more screw on side of dash on drivers side, and then 2 bolts under dash, and then remove lower dash. You need to reach up with some tiny hands (LOL) and pull out the old flasher unit and replace with new. People say they are cheap and you can find them at any parts store, good luck with that. I found 1 locally it was 40something, and dealer had it was well for over 50. I bought a used one from someone parting out a WJ. Mine has been fine since I replaced it. There is also talk on that link I posted about opening the unit and soldering 2 pieces that get cracks in them, I have heard a lot of people do that successfully also. Good Luck.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
uConnect/VR Stopped Working - 430N granto3k Audio/Visual/Navigation 19 02-16-2014 11:53 PM
remote keyless entry have stopped working ithinkfit914 Troubleshooting/Problems 9 01-09-2011 06:38 AM
Accessory LED Turn signal/brake lights c_nall Visual Modifications 9 11-06-2010 05:00 AM
Trailer signal lights not working Canyon Dancer Trouble Shooting/Problems/Service 10 10-30-2010 07:16 AM
Blue Tooth stopped working NHWK05 Audio, Video, Navigation & Electronic Modifications 2 02-05-2010 06:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.