Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-22-2011, 11:51 AM
Member
My Jeep: 2002 4.0L WJ
 
Join Date: Oct 2010
Location: Palm Harbor, Florida
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1349
ChiefNWA is on a distinguished road
Something wrong?

Okay, so recently I've noticed something weird. I was idling at Dairy Queen last night, for maybe 5 minutes and all the sudden the rpms dropped down to 400-500. So, I give it a little gas, I hear a popping sound, it hesitates a little, revs up like its suppose to then its fine. O.o This is the 2nd time this week its happened. I'm not to mechanically savvy when it comes to cars (atleast not yet) since I'm only 18. Other than this happening, the Jeeps running fine. No other weird anomalies or noises etc. Anyone have an idea whats wrong?
__________________

__________________
Reply With Quote
  #2  
Old 10-22-2011, 02:04 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Jun 2011
Location: Mesa, AZ
Posts: 199
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1667
DrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond repute
Re: Something wrong?

I am like you...not mechanical, but it has to be fuel related.
Good luck and I hope your problems are solved fast.
__________________

__________________
'04 Stock WJ:)
With Spare Tire:D
Reply With Quote
  #3  
Old 10-22-2011, 02:06 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,319
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524711
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Something wrong?

Was the AC on when it happened? The PCM is suppost to keep idle constant using the IAC stepper motor, which is a variable air passage. Before the AC will kick on, the PCM will compensate already for the heavier load. If the idle air control is dirty, i could give problems like this, eventhough i also would expect unstable idle without the AC on then.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 10-22-2011, 04:09 PM
Member
My Jeep: 2002 4.0L WJ
 
Join Date: Oct 2010
Location: Palm Harbor, Florida
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1349
ChiefNWA is on a distinguished road
Re: Something wrong?

IIRC the first time it happened the AC was off. The one last night I had the heater on. I don't know if this is connected, but sometimes when I start the car it takes maybe 2 clicks longer to turn over and when it does its weak. It idles around that 400-500 range. It just made me worry recently when I'm hearing the popping noise.
__________________
Reply With Quote
  #5  
Old 10-23-2011, 06:33 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,319
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524711
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Something wrong?

I would start cleaning the throttle body and especially IAC plunjer and air passage. The popping sound i don´t know.
When the engine turns over slowly during starting, i would let my battery checked out first.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's wrong? HELP Crestwood1001 Grand Cherokee - WK 11 06-20-2011 10:23 PM
thermometer wrong? THA06 Troubleshooting/Problems Discussion 1 12-11-2010 03:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community