Stalling! Ugh! - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-31-2015, 05:45 PM
New Member
My Jeep: 2002 4.0L WJ
 
Join Date: Jan 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
anson is on a distinguished road
Stalling! Ugh!

Just joined today. I have a '02 Grand Cherokee that I purchased last year (May) with 134K miles or so. Just this past week it has stalled twice without warning. It's like it just lost power similiar to when the electricity goes out in your house. The battery was replaced yesterday and after I drove it for about 20 minutes today it did the same thing. I've been reading with much interest all the other posts about stalling issues as the mechanic doesn't seem to know what to do. There's no check engine light on and no current codes being thrown. I'm curious about the crankshaft sensor as he said that they can tell this particular vehicle has thrown that code (among several others) in the past but he has no idea how long ago. I'm not a mechanic and unfortunatley don't have the skill/tools to do much in way of repair so I'm trying to avoid fixing multiple things in the hope one of them works.

Thanks for any advice you may offer!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-31-2015, 06:58 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,257
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529369
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Stalling! Ugh!

Without good trouble shooting it can be a shot in the dark, but indeed this looks as a bad crank position sensor. Especially with the code for the sensor in the memory. You donīt have a family member or firend who is a bit handy with tools. There is a good writeup on here with pictures from i believe jeepme.
Edit: Yes, here it is: How To: Replace Crankshaft Position Sensor
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight issue UGH DGoral31 Troubleshooting/Problems 6 01-20-2015 12:08 AM
Ugh!! SeaRay Trouble Shooting/Problems/Service 5 12-28-2012 10:01 AM
5150 Curb Weight....Ugh!!! P-Dawger Grand Cherokee SRT - WK2 69 05-19-2011 11:40 PM
ugh, debadging issues burton907 Visual Modifications 9 06-22-2010 08:52 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.