Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-11-2012, 08:18 AM
JeepFreak12's Avatar
Black Widow
My Jeep: 2010 6.1L SRT8
 
Join Date: Mar 2011
Location: Roseville, Michigan
Posts: 2,090
Thanks: 205
Thanked 146 Times in 125 Posts
Rep Power: 8294
JeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond repute
Garage
Re: Starting prob?

The fuel pump shouldnt effect the drag on starting. If it was a bad fuel pump it would turn over just not start.
__________________

__________________
Reply With Quote
  #14  
Old 09-12-2012, 05:57 AM
JeepFreak12's Avatar
Black Widow
My Jeep: 2010 6.1L SRT8
 
Join Date: Mar 2011
Location: Roseville, Michigan
Posts: 2,090
Thanks: 205
Thanked 146 Times in 125 Posts
Rep Power: 8294
JeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond repute
Garage
Re: Starting prob?

So i finally fixed the problem last night! Was a bad ground from the battery to the block. Im glad it wasnt anything more serious! Thanks guys for your help.
__________________

__________________
Reply With Quote
  #15  
Old 09-12-2012, 06:49 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,160
Thanks: 9
Thanked 116 Times in 109 Posts
Rep Power: 526176
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Starting prob?

Good to hear ots fixed.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
REC nav joystick prob. SRTDZGN Audio/Visual/Navigation 4 07-10-2012 04:37 PM
Prob a dumb question.... ATR135 Grand Cherokee - WK2 - 1 06-06-2012 08:10 AM
Will prob cancel order and go BMW RECDOG Grand Cherokee SRT - WK2 59 09-16-2011 09:37 AM
Not starting... Gunswinger Troubleshooting/Problems 8 04-03-2010 08:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.