Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-08-2012, 12:59 PM
Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1006
Overland Neil is on a distinguished road
Strange Flasher/Turn Signal problem !!

Had my 04 Overland for a little while now and so far i'm loving it after coming from an 04 X5 4.8is. Never again !!!
Anyway this evening the car developed a small problem. The turn signals or indicators over here in the UK have started flashing faster than normal,i checked all the bulbs first and all were working fine. The emergency or hazard lights work fine and are at normal speed.
Can anyone shed any LIGHT on this for me ??
__________________

__________________
Reply With Quote
  #2  
Old 06-08-2012, 06:24 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,167
Thanks: 9
Thanked 118 Times in 111 Posts
Rep Power: 526183
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Strange Flasher/Turn Signal problem !!

A burnt bulb or open circuit will increase the flash rate for the turn signals, but not the rate for the hazard lights. Is not one of the bulbs burning less bright then the others? Is the flash rate the same for left and right?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 06-08-2012, 09:24 PM
Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2012
Location: New Jersey
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 914
JGCPROGUY is on a distinguished road
Re: Strange Flasher/Turn Signal problem !!

id say the flasher relay is starting to go bad.
__________________
Reply With Quote
  #4  
Old 06-09-2012, 07:31 AM
Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1006
Overland Neil is on a distinguished road
Re: Strange Flasher/Turn Signal problem !!

Thanks for the input but i managed to find the fault eventually,there was a fault on the tow hitch electrics.
__________________
Reply With Quote
  #5  
Old 06-09-2012, 08:01 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,167
Thanks: 9
Thanked 118 Times in 111 Posts
Rep Power: 526183
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Strange Flasher/Turn Signal problem !!

Good to hear you have found the LIGHT. Was there a short or something in the tow hitch electrics?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 06-10-2012, 01:49 AM
Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1006
Overland Neil is on a distinguished road
Re: Strange Flasher/Turn Signal problem !!

I don't know about the US but in the UK the original JEEP towpack electrics have a little microswitch mounted in the electric socket. I presume this is to disable the rear parking sensors when towing. But anyway this switch had somehow come apart. Hey presto,disconnect the microswitch and all is good,i don't even have parking sensors !!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal relay sibbit Troubleshooting/Problems 3 05-07-2012 02:22 AM
Turn Signal Issue RobM Cherokee-SJ and XJ 7 02-05-2012 02:30 PM
new turn signal problem StatensDevilDog53 Troubleshooting/Problems 5 11-08-2011 08:18 AM
Turn signal problem SvenskaJeepGuy Grand Cherokee - WK 22 04-30-2011 09:52 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.