Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-04-2013, 05:16 AM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1208
honda_fox3 is on a distinguished road
Stupid heater!!!!!!!

So the wife and I are headed to he parents house, her in the WJ me in the car, I get a call that the heater isn't working. After about 20 min on the side of the freeway in 0 F temps trying to fix it she decided that her and the kids would just suck it up until we got there. Only 10 more miles. Get there and after looking at it here is what I came up with.

Fuses-good
Coolant level-good
Blower motor-good
Blend doors-I think good........
Blowing air thats colder then outside temps-good

I felt the hoses going to the core one is warmish the other cold. I'm assuming some kind of blockage. Considering that this happend with it so cold out I'm leaning towards frozen coolant. Must not have been a strong enough mix. At least thats what I hope it is. With the hoses like that I don't think blend doors but maybe and maybe even both if I'm super lucky.

Now I get to freeze my arse off trying to fix the thing without a garage.
__________________

__________________
Reply With Quote
  #2  
Old 01-04-2013, 05:57 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,668
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525479
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Stupid heater!!!!!!!

That sucks. The flow through the heater core is constant as long as the engine is running, independent if heating is requested or not. Was the heating not working since the beginning of the trip? If it would be frozen lines, you could warm them with some hot water and see if that cures the problem.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 01-04-2013, 06:10 AM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1208
honda_fox3 is on a distinguished road
Re: Stupid heater!!!!!!!

Quote:
Originally Posted by Frango100 View Post
That sucks. The flow through the heater core is constant as long as the engine is running, independent if heating is requested or not. Was the heating not working since the beginning of the trip? If it would be frozen lines, you could warm them with some hot water and see if that cures the problem.
That was my understanding. The lines should be close to the same temp as the lines going to and from the radiator roughly. All the time.

Yes it was cold the whole time. We stopped and looked at it after about 12 miles of driving then drove the other 10. Engine temp was good at 188.6 F. I was hoping that just driving it would thaw things out and it would start working but nope. I'll try to warm it up again during the day when the ambient air temps are balmy 20's to see if I can get it to break free. Heat gun it a good call, maybe I can heat up the heater core with that while running the motor and see if that will give it enough heat. At any rate it looks like I'll be draining my coolant and replacing with a stronger mix.

I really don't want to work on this thing in the freaking cold weather.
I was just getting ready to order a BB lift and new tires too
__________________
Reply With Quote
  #4  
Old 01-04-2013, 10:58 PM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1208
honda_fox3 is on a distinguished road
Re: Stupid heater!!!!!!!

So I was hoping that it was just froze a little. Put a heat light under the hood all night and most of today to see if I could thaw it out. Started and ran for about 20 min before I even checked it and it's blowing hot as ever.

Guess I'll be draining some coolant to replace with a stronger mix. So glad it was just that, and it didn't freeze hard enough to cause damage
__________________
Reply With Quote
  #5  
Old 01-05-2013, 06:40 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,668
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525479
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Stupid heater!!!!!!!

Depending on when the coolant was changed for the last time, you could better drain it completely and fill it up with fresh coolant. The coolant has several additives, which deplete over time. If you would mix fresh coolant with old coolant, the additive level could still be too low.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 01-05-2013, 08:15 AM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1208
honda_fox3 is on a distinguished road
Re: Stupid heater!!!!!!!

Coolant isn't very old, less than a year. It was put in when I put in the new radiator over the summer. I did flush the system with the hose when I did the radiator, so I would guess I didn't get all the water out which caused my weak mixture.
__________________
Reply With Quote
  #7  
Old 01-25-2013, 09:41 PM
Member
 
Join Date: Dec 2012
Posts: 144
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 718
sl1980able is on a distinguished road
Re: Stupid heater!!!!!!!

cool trick Ill keep that in mind.
__________________
Reply With Quote
  #8  
Old 01-25-2013, 09:50 PM
Trav1s's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2012
Location: Cedar Rapids, IA
Posts: 689
Thanks: 0
Thanked 17 Times in 16 Posts
Rep Power: 1618
Trav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond repute
Garage
Re: Stupid heater!!!!!!!

Plugged core came to mind. Me thinks that stuff that settled while it was sitting before you picked it up is coming back to haunt you. I would do a complete system flush and fill.
__________________
2004 Columbia Edition WJ 4.7 HO
RB4/Moog HD Steering Stabilizer/PML trans pan 10304/OME 10MM Spacers/Bilstein shocks/Rubicon Moabs/255/65r17 Cooper Discoverer AT3/Factory chrome tow hooks/Mopar hitch & a loose nut behind the wheel
Reply With Quote
  #9  
Old 01-25-2013, 10:14 PM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1208
honda_fox3 is on a distinguished road
Re: Stupid heater!!!!!!!

Turns out it was just a weak mix of coolant. When I flushed it I must have not gotten all the water out then put in a 50/50 mix, combine that with temps in the single digits and negatives for a couple weeks straight and thats what I get. Never froze hard enough to do any damage thankfully. Now I have a better mix and a MOPAR freeze plug heater installed.
__________________
Reply With Quote
  #10  
Old 01-28-2013, 02:30 PM
Member
 
Join Date: Jul 2012
Posts: 81
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 814
JRK5892 is on a distinguished road
Re: Stupid heater!!!!!!!

really so you swapped out the coolant and that did the trick huh?! may have to swap mine out!
__________________

__________________
Joe
Chicago, Il
Lots of powder coating and a ton of mods done on my jeep
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
heater only blows warm air when heater is on vondy7 Troubleshooting/Problems 10 01-26-2013 11:35 AM
stupid,stupid me jeep5.7 Grand Cherokee - WK 9 10-16-2011 02:23 PM
This may a stupid question, but sometimes my stupid questions pay off. southernfryedyankee Wheels/Tires/Brakes 5 03-27-2011 11:25 AM
stupid ? Rosewood Trouble Shooting/Problems/Service 17 03-09-2011 12:56 AM
NEW AND STUPID but need advice young-gun Troubleshooting/Problems 16 09-14-2010 12:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community