Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-11-2009, 04:33 AM
CherokeeChief's Avatar
Member
 
Join Date: Sep 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1929
CherokeeChief is on a distinguished road
Symptoms of Bad Engine Mounts

I was wondering which are the symptoms of bad engine mounts. I feel a slight vibration on my gas pedal, shifting is not perfect (feel like trans is slightly slipping) especially between 2nd and 3th during hard acceleration and I feel a little loss of power, like someone is pressing and releasing the brake pedal. I already changed my trans mount and I know my motor mounts are broken, one has the rubber completely disconnected from the metal. Could be these symptoms related to bad engine mounts ?
__________________

__________________
Marco - Location: Italy
Now: Belen - 2002 WG 4.7 V8 HO Overland, Xenon 6000K, LPG Bigas, Gas A-Just Shocks, ADDCO rear Sway bar,Superchips 3865 Performance 91 ECU setup

Ex 1999 WJ 4.7 V8 - USA Original.
Reply With Quote
  #2  
Old 09-11-2009, 06:56 AM
Member
 
Join Date: Jun 2009
Location: Columbus,NJ
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2252
saleen032 has a reputation beyond reputesaleen032 has a reputation beyond repute
Send a message via AIM to saleen032
Re: Symptoms of Bad Engine Mounts

I highly doubt it, but I guess it could be possible that if the mounts were "toast", that the engine couldmove enough to maybe cause an electrical connection to start coming apart...causing issues....but I really dont think that is happening
__________________

__________________
Reply With Quote
  #3  
Old 09-11-2009, 07:03 AM
CherokeeChief's Avatar
Member
 
Join Date: Sep 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1929
CherokeeChief is on a distinguished road
Re: Symptoms of Bad Engine Mounts

I don't think to an electrical problem... I don't have codes with the 3 On/Off and the dealer checked it with the DRB Scan tool. The dealer says that everything is ok. He just upgraded my Trans SW for the second OD, but I have these issues before i did it.
__________________
Marco - Location: Italy
Now: Belen - 2002 WG 4.7 V8 HO Overland, Xenon 6000K, LPG Bigas, Gas A-Just Shocks, ADDCO rear Sway bar,Superchips 3865 Performance 91 ECU setup

Ex 1999 WJ 4.7 V8 - USA Original.
Reply With Quote
  #4  
Old 09-11-2009, 09:51 AM
RedRocker's Avatar
Member
 
Join Date: Jul 2009
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2306
RedRocker has a reputation beyond reputeRedRocker has a reputation beyond repute
Re: Symptoms of Bad Engine Mounts

The vibration in the gas pedal is probably your engine mount. The hesitation/slipping is probably your transmission. Have you had it serviced regularly including band adjustment? How many miles?

(Incidentally, you can check for broken motor mounts by opening your hood and pushing in on the throttle linkage by hand to "goose" the engine. If the mounts are good, you should see just a little vibration in the engine, if the mounts are gone, you'll see a more dramatic vibration.)
__________________
Reply With Quote
  #5  
Old 07-16-2010, 09:25 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12442
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Symptoms of Bad Engine Mounts

need to find transmission and motor mounts for my WK I'm having no luck

Will the liberty mounts fit ?
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do I like the 4.7L engine? AIR_RAM Performance Modifications 38 01-24-2013 05:42 PM
How clean is your engine bay m4xm1l10n Detailing 142 12-08-2011 08:30 AM
One bad ass ZJ Knightrider03m Grand Cherokee - ZJ 6 08-23-2009 02:01 PM
how hot does your engine get> jeeppro Grand Cherokee - WK 28 08-10-2009 11:53 PM
Need advise truck running bad{video} BUBBADOG Performance Modifications 7 07-12-2009 11:16 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.