Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-19-2013, 02:06 PM
New Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
EmilyS is on a distinguished road
TCC problem HELP!

Can anyone help me... I have a 2000 Jeep Grand Cherokee 4.0L. With 110,000 miles on it. It keeps throwing the P0740 code. I have replaced the both sensors in the trans, temp sensor all wires are good. The jeep shift perfect!!!! The only thing that I'm stuck on is, it throws the code whenever! Meaning I was stopped at a traffic light and it put out the code. It has done this several times!! I get no shuddering and nothing is making any noises. Does anyone know what this might be?? Any help would be great!
__________________

__________________
Reply With Quote
  #2  
Old 11-20-2013, 05:17 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: TCC problem HELP!

Did you change the overdrive and lockup solenoid assy inside the transmission? Or only the pressure solenoid and pressure sensor?
Have a look at this site as reference of the parts: Dodge Heavy Duty Master Solenoid Kit 2000 and Up
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C Problem Sh0rtBus Trouble Shooting/Problems/Service 14 08-12-2013 09:15 AM
OBD diag problem or car problem?? jeeper_57 Troubleshooting/Problems 0 06-25-2013 11:24 AM
I have a serious Problem ChrisOC Grand Cherokee - WK2 - 9 09-12-2012 05:58 PM
another problem please help tyler05wk Troubleshooting/Problems 0 01-09-2012 01:18 AM
has anyone else had this problem? 99limited Audio, Video, Navigation & Electronic Modifications 14 04-01-2010 05:17 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community