Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 05-06-2010, 06:10 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

I am going to order new TPMS sensors today. It was determined that 1 is done. I am going to order a new set of 4. My EVIC only shows pressure for 4 tires. That definitely means the spare has no sensor correct?
thanks
__________________

__________________
Silver 2004 Jeep Grand Cherokee Special Edition I6 4.0
stock 'cept for
Pioneer Primere Deh-P840 headunit XMD-1000 (xm receiver) Audionbahn Bandpass Box with 2 Audiobahn 12" subs powered by Audiobahn Amp|
Escort 8500 X50 radar detector hardwired to auto dim rearview mirror|V3 projector headlights with 6K HIDs in Lows, 3K HIDs in Fogs|black brush guard & black nerf bars|Hyper White LEDs in interior lights, and Rear License Plate|16" JK unlimited wheels

Custom 2001 Mitsubishi Galant pics can be seen here
Reply With Quote
  #14  
Old 05-06-2010, 09:58 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

disregard above post. I just gotta check the spare and see whether it has metal valve stem or black rubber one that is the answer
__________________

__________________
Reply With Quote
  #15  
Old 05-06-2010, 10:33 AM
vicpick58's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Dec 2009
Location: Ceres CA
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1761
vicpick58 is on a distinguished road
Re: TPMS Issue

I have a 2004 Overland and have had that message on the EVIC. I ended up having to replace two of the five sensors. But it was after several months of hearing that blasted noise every time I started the Jeep.

I paid nearly 100 dollars per sensor from the dealer. (a couple years ago)

If I had known about that online aftermarket resource that you showed us, I would have just replaced all five and been done with it.
__________________
[SIGPIC][/SIGPIC][/SIGPIC] Former owner of a 2004 Grand Cherokee Overland, was mostly stock, was used as a work vehicle, had K.O.R. Hard Steering Stabilizer, Monroe Reflex Shocks.

Traded in for a new 2012 4Runner Trail Edition at 218k miles.
Reply With Quote
  #16  
Old 05-06-2010, 10:45 AM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

ouch. I was quoted 129 for 4 of them shipped to my door
oh and for anyone that ends up in this post doing a search the site is http://www.tpmswholesalers.com/
__________________
Reply With Quote
  #17  
Old 05-12-2010, 06:58 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

Well so far 1 sensor was installed yesterday and we couldn't get it to train properly. My mechanic spoke to someone that specializes in TPMS sensors and apparently my current sensors are fine. And my computer just needs to be reprogrammed. I am going to this person next week to see what the deal is. I am most likely going to have the new sensors installed to since I have them, and the place they came from isn't going to take them back.
__________________
Reply With Quote
  #18  
Old 05-21-2010, 09:26 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

okay well. I brought the WJ in the other day to a shop that deals with vehicle electronics all the time. 1st they said they got the message cleared out, they were wrong I started jeep and there it was. They then told me I need to drive for 10-15 minutes over 20mph, so I took a ride. The message turned off (I didn't realize that all along after a few minutes the message would shut off, I was clearing it right off the bat) anyways, I pull over and shut jeep and start up again and the message is back. I drive around some more and same situation over and over. I go back to the shop and they diagnose further and then tell me the battery is dying on the left front. I show them the sensors I have and the owner of shop says you need OEM ones, the ones you have a garbage. I am in the process of getting the company they came from to refund me my money, so I can purchase OEM ones. The rep I spoke to yesterday understands I am having a problem, but couldn't authorize the refund, the person I have been speaking to in email says they should work and they don't need to be OEM. Those 2 are supposed to have talked and got back to me yesterday. I haven't heard back yet, I will be calling again on Monday to see what's up. Wish me luck on getting my refund.
__________________
Reply With Quote
  #19  
Old 05-22-2010, 11:49 AM
vicpick58's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Dec 2009
Location: Ceres CA
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1761
vicpick58 is on a distinguished road
Re: TPMS Issue

So that aftermarket sensor is not such a great deal after all.

Not only should they refund your money, they need to remove the, Jeep Truck,-Grand Cherokee,-2004, from their list of what that part number OEC1001 will fit.

This kind of stuff really pisses me off!

Thanks for posting this, hopefully it will help keep anyone else (like me) from making the mistake of thinking these sensors would work on their WJ.
__________________
[SIGPIC][/SIGPIC][/SIGPIC] Former owner of a 2004 Grand Cherokee Overland, was mostly stock, was used as a work vehicle, had K.O.R. Hard Steering Stabilizer, Monroe Reflex Shocks.

Traded in for a new 2012 4Runner Trail Edition at 218k miles.
Reply With Quote
  #20  
Old 05-22-2010, 12:00 PM
vicpick58's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Dec 2009
Location: Ceres CA
Posts: 100
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1761
vicpick58 is on a distinguished road
Re: TPMS Issue

I think this may be the best choice for replacement sensors.

http://www.justforjeeps.com/litiprmo.html

At least they are the OEM and should have no problems training them.
__________________
[SIGPIC][/SIGPIC][/SIGPIC] Former owner of a 2004 Grand Cherokee Overland, was mostly stock, was used as a work vehicle, had K.O.R. Hard Steering Stabilizer, Monroe Reflex Shocks.

Traded in for a new 2012 4Runner Trail Edition at 218k miles.
Reply With Quote
  #21  
Old 05-22-2010, 05:26 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

Quote:
Originally Posted by vicpick58 View Post
So that aftermarket sensor is not such a great deal after all.

Not only should they refund your money, they need to remove the, Jeep Truck,-Grand Cherokee,-2004, from their list of what that part number OEC1001 will fit.

This kind of stuff really pisses me off!

Thanks for posting this, hopefully it will help keep anyone else (like me) from making the mistake of thinking these sensors would work on their WJ.
yeah we'll see what happens as in the last email I received from them they basically said they will work and I am not training them properly, which is definitely not the issue. Each time their sensor was installed and tried to train to the system, the message on the EVIC changed from "train left front" to "training aborted" as the left front didn't synch up as it should.[
Quote:
Originally Posted by vicpick58 View Post
I think this may be the best choice for replacement sensors.

http://www.justforjeeps.com/litiprmo.html

At least they are the OEM and should have no problems training them.
thanks for the link. I actually found OEM ones with a discount from Kolak. But I just need to get the refund back for these 1st.
__________________
Silver 2004 Jeep Grand Cherokee Special Edition I6 4.0
stock 'cept for
Pioneer Primere Deh-P840 headunit XMD-1000 (xm receiver) Audionbahn Bandpass Box with 2 Audiobahn 12" subs powered by Audiobahn Amp|
Escort 8500 X50 radar detector hardwired to auto dim rearview mirror|V3 projector headlights with 6K HIDs in Lows, 3K HIDs in Fogs|black brush guard & black nerf bars|Hyper White LEDs in interior lights, and Rear License Plate|16" JK unlimited wheels

Custom 2001 Mitsubishi Galant pics can be seen here
Reply With Quote
  #22  
Old 05-24-2010, 05:27 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

well I woke to an email from them today stating to send the sensors back and they will refund my money. So I am back to square 1 and going to order OEM ones.
__________________
Reply With Quote
  #23  
Old 02-18-2012, 04:20 PM
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2010
Location: Woodbridge NJ/Staten Island NY
Posts: 6,812
Thanks: 4
Thanked 26 Times in 26 Posts
Rep Power: 26096
mrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond reputemrjaydeeone has a reputation beyond repute
Send a message via AIM to mrjaydeeone Send a message via Yahoo to mrjaydeeone
Re: TPMS Issue

just to revisit this. When I came out of work last night I discovered my left rear tire to be flat. 1 of the aluminum caps on the lug nuts came off and I had nothing to fit and ended up waiting for AAA to come and help me out. They got there quick and I was on my way. Friggin' screw in the tire. My wife offered to take it in this AM and have it fixed since I wont be off work until Tuesday. The shop told her that in that wheel the TPMS sensor was cracked and they fixed it some how. The one upfront that has been throwing the error message has also had a slow leak. The shop noticed that one is cracked also. Finally I know what has been wrong with that one, although it has been reading properly and let me know about the leak there. So I am going to look for another set now, as well as some better lug nuts haha.
__________________
Reply With Quote
  #24  
Old 02-18-2012, 07:24 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,076
Thanks: 95
Thanked 68 Times in 64 Posts
Rep Power: 331822
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: TPMS Issue

I guess I'm old school Jay but take the thing to the dealer and have that useless buggy piece of crap turned off and throw a tire gauge in the glove compartment. Either that or for the $400 you're gonna spend on valve stems buy a Superchips,tune your engine,turn off the tpms yourself and put $40 in your pocket. Just sayin.....
__________________

__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tpms ducks unlimited Troubleshooting/Problems Discussion 9 01-05-2010 04:45 PM
Tpms NHWK05 Grand Cherokee - WK 26 12-15-2009 04:58 PM
TPMS Sensors saleen032 Grand Cherokee - WK 8 10-20-2009 06:08 PM
Tpms 08Hemi Grand Cherokee - WK 3 07-29-2009 07:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community