Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-24-2011, 09:17 PM
Member
 
Join Date: Nov 2010
Posts: 18
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1453
JeepGC60thAE is on a distinguished road
Post Trans rebuilt-something isnt right

I just had my transmission rebuilt on my 01 WJ quadre-drive. The dreaded 545-rfe. My jeep has 146k miles and everything has been maintained properly. The CEL is not on.

When i picked my Jeep up from the tranny rebuild, I immediately noticed a vibration/rubbing and growling sort of sound from the underside. It is most noticeable in reverse, and at low speed. It seems to be worst when going up hills, or when accelerating hard. I do notice vibration at all speeds and throttle position. It really depends on how much throttle is applied at any given speed how bad the vibration is.

My guess is a U-joint? I don't know much about transmissions, etc. , so I don't want to just throw parts at it hoping to solve the problem. The transmission rebuild hurt enough!
It just doesnt feel the same as it did before the rebuild. It seems like it's losing power. The engine sounds like it has to work harder, and it doesnt seem to accelerate as quick as before.
Any suggestions would be appreciated.
__________________

__________________
Reply With Quote
  #2  
Old 12-25-2011, 12:35 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,053
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526039
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Trans rebuilt-something isnt right

What was the reason for the tranny rebuild? If there was debris in the pan, also the torque converter has to be serviced or replaced. Vibration is always hard to pinpoint. But when the vibration was not there before the rebuild, it could have to do with one of the propeller shafts. The front one you can easily remove and testdrive again, to see if there is any change. They always say to mark the propeller shafts before removing them, to be sure that they are put back in the same position as they where, to prevent vibration.
Also check if all bolts are tightened underneath, because they have to remove a lot when removing the tranny.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 12-25-2011, 11:17 AM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Jun 2011
Location: Mesa, AZ
Posts: 199
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1858
DrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond reputeDrLocke has a reputation beyond repute
Re: Trans rebuilt-something isnt right

I am not understanding why you don't park your WJ in front of the rebuilder's shop and demand that they make it right. Does it not come warranteed? Do they not guarantee their workmanship? It sounds like it is their problem.
Did you cancel payment on your CC?
Just thinking out loud.
__________________
'04 Stock WJ:)
With Spare Tire:D
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebuilt 4.7...Will not idle Addaam Engine Performance/Intake/Exhaust 21 10-10-2011 07:36 PM
Water in rebuilt Transmission... Why? Where? 05HemiGcherokee Grand Cherokee - WK 12 06-21-2010 06:02 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.