Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-10-2014, 12:52 AM
Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
solo17 is on a distinguished road
Transmision Over Temp Help...Sensor Failure?

Ok Guys,

I'm in a bit of a problem.. and it's a bit of a time sensitive issue. Anyways, I have a '02 WJ with the 4.7L HO.

I recently drove out of town to work (700 miles) and had no issues. Running a few errands I get my check engine light to come back on and it throws P1698 and P0700 codes. Not long after I get a Trans Over Temp light to come on and so I pull over. When I had to put it in reverse, it shifted hard and felt like it got stuck in second gear when i put it back into drive. Turning vehicle off and back on would fix this immediately (although temporarily).

Trying to troubleshoot on the side of the road I pull the dipstick from my transmission and notice no strange or burnt smells and the fluid is clear and red. Dealership told me that my transmission cooler was not connected properly and the fluid was burnt and chunky black -- I couldn't have driven more than 25 miles from where I was until I got to the dealership. They're trying to charge me $6k for a new tranny, and I need to leave for home asap due to family obligations.

I'm calling BS. Any advice on what to check or how to tell if I really need a tranny? I'm also in North Dakota so options are limited.
__________________

__________________
Reply With Quote
  #2  
Old 05-10-2014, 01:20 AM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

guess they figure you got a pocket full of that bakken money. try disconnecting the battery and ground the two terminals against each other while disconnected from the battery to discharge any residual power that may be held in the computer., its free and somewhat easy
__________________

__________________
Reply With Quote
  #3  
Old 05-10-2014, 01:25 AM
Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
solo17 is on a distinguished road
Re: Transmision Over Temp Help...Sensor Failure?

I did try that, but the codes came back up maybe 45 min later. I'm going to go get my keys tomorrow and park it on the street somewhere if I have to, but I don't trust these guys.
__________________
Reply With Quote
  #4  
Old 05-10-2014, 07:47 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,195
Thanks: 9
Thanked 121 Times in 114 Posts
Rep Power: 526214
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

Your jeep has the 5-45RFE transmission. The P1698 code means that there is a data connection problem between PCM and TCM. This can be a wiring problem, moisture in one of the connectors (TCM/PCM) or a TCM problem. I would start removing the connectors on TCM and PCM and clean them well with contact cleaner, dry them and reconnect.
The transmission overtemp however seems to be pointing towards an other problem. What the stealer ment with " transmission cooler not connected properly" i have no idea. A loose line would have given a low level and you said that you checked the level and colour already.
The TCM will put the transmission in third gear when it sees a problem that could harm the transmission (limp mode). Once in limp mode, it will stay there until you switch ignition off and on again.
It can be that the stealer found other codes with their DRBIII scanner, but if they tell you that the fluid was burnt and black after 20 miles that would be strange.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 05-10-2014, 08:08 AM
Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
solo17 is on a distinguished road
Re: Transmision Over Temp Help...Sensor Failure?

Thanks for clearing that up. I have been searching through forums and have found people with almost an identical problem and saying it could have been he governor pressure sensor and/or solenoid. If that sensor also controls transmission temp, could that mean it's just that sensor/solenoid?? And is that an easy fix? Thanks again guys
__________________
Reply With Quote
  #6  
Old 05-10-2014, 08:21 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,064
Thanks: 1
Thanked 5 Times in 5 Posts
Rep Power: 2506
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

My fix for these darn 545rfe is a rebuild.
__________________
Reply With Quote
  #7  
Old 05-10-2014, 08:43 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,195
Thanks: 9
Thanked 121 Times in 114 Posts
Rep Power: 526214
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

Governor pressure solenoid is part of the TRS solenoid block inside the transmission on top of the valve body. It controls the line pressure, which is used to activate the clutches. The governor pressure sensor is a separate unit (named line pressure sensor on this transmission), which sits outside of the transmission on the right aft side (close to the exhaust hanger).
You said that when you put it in reverse, it shifted hard. Reverse on this transmission is mechanically controlled with a mechanically operated valve inside the valve body. Line pressure ofcourse is still electronically controlled. A hard shift would indicate high line pressure, or there is something mechanically wrong inside the transmission. Also high idle speed will give a hard shift into reverse. If you would drive for prolonged time with the transmission in limp mode (third gear and no torque converter lockup), transmission temperature will get high as well and could eventually give a trans overtemp light. High fluid temperature however normally comes from lack of cooling, or slipping clutches (low line pressure). It would be interresting to see what the line pressure is. I still wonder however where the P1698 is coming from.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 05-10-2014, 11:45 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,195
Thanks: 9
Thanked 121 Times in 114 Posts
Rep Power: 526214
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

Just checked the wiring manual for the ground for the TCM. It is G102 and it sits on the right side of the engine block just behind the front mount. Check this ground to be free of corrosion and if its tightened well.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 05-10-2014, 09:50 PM
Member
 
Join Date: May 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 582
solo17 is on a distinguished road
Re: Transmision Over Temp Help...Sensor Failure?

Well I appreciate all the help, but I went back to the dealership and they just had my jeep sitting in the back lot without a transmission. The new one hasn't even arrived. If it's not driveable by the time I absolutely need to leave, I will just have to rent a car and deal with this situation later. I'll still make sure to check everything you mentioned when I get that thing back in my possession.
__________________
Reply With Quote
  #10  
Old 05-11-2014, 07:39 AM
Trav1s's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2012
Location: Cedar Rapids, IA
Posts: 754
Thanks: 23
Thanked 20 Times in 19 Posts
Rep Power: 1805
Trav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond repute
Garage
Re: Transmision Over Temp Help...Sensor Failure?

The 545rfe is a good transmission if it is maintained. At this point I would hunt down a low mileage used piece and have them swap it in. Drain the fluid, change filters, and refill with the correct ATF. I would expect that to be accomplished for less than $1500.
__________________
2004 Columbia Edition WJ 4.7 HO
RB4/Moog HD Steering Stabilizer/PML trans pan 10304/ Autometer trans temp and oil pressure gauge/UpCountry springs & OME 10MM Spacers/Bilstein shocks/Rubicon Moabs/255/65r17 Cooper Discoverer AT3/Factory chrome tow hooks/Mopar hitch & a loose nut behind the wheel
Reply With Quote
  #11  
Old 05-11-2014, 08:24 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,195
Thanks: 9
Thanked 121 Times in 114 Posts
Rep Power: 526214
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

Quote:
Originally Posted by Trav1s View Post
The 545rfe is a good transmission if it is maintained. At this point I would hunt down a low mileage used piece and have them swap it in. Drain the fluid, change filters, and refill with the correct ATF. I would expect that to be accomplished for less than $1500.
Eventhough a used transmission is a good option, the P1698 is pointing towards a problem of communication between PCM and TCM.
What did the stealer say about this code? It would be a pitty to get an other transmission swapped in to have it ruined by an external fault.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 05-11-2014, 03:36 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,064
Thanks: 1
Thanked 5 Times in 5 Posts
Rep Power: 2506
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: Transmision Over Temp Help...Sensor Failure?

I performed my trans swap for 300$ 13*k trans
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 5.7 transmision problems only 1-2 Jarek5_7 Troubleshooting/Problems 14 07-11-2012 12:47 PM
A/c leak causes o2 sensor failure Mr Chill Troubleshooting/Problems 6 05-05-2012 07:31 PM
My WJ won't start after changing Transmision Domingo Troubleshooting/Problems 7 04-30-2012 01:37 PM
FCW sensor failure demaio411 Trouble Shooting/Problems/Service 12 08-11-2011 05:17 AM
Can someone help with "Transmission Over Temp" ?? newofoundxglory Grand Cherokee - WK 10 05-30-2011 04:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.