Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-06-2011, 01:29 PM
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Nov 2010
Location: Belmont, NH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1380
OffCenter is on a distinguished road
transmission advice

Have a 96 ZJ. When driving more times then not while shifting from I think its 1st to 2nd it feels like it is sticking until about 3500rpms and then finally pushes itself into the right gear. Brought it to Aamco since it had a free check they did the standard, not electrical, will break down in future needs a rebuild, here's 100 off coupon. Some people say stay clear from Aamco, others say probably doesn't need a rebuild but I should try tightening the TV cable(btw don't know what that is or how to tighten it so if anyone wants to tell me I'd gladly read ur instructions. So my questions are many but here they are. Does anyone have first hand experience with Aamco and their work? Does anyone know how to tighten the TV cable? Does anyone have/had or heard of this problem and if so any other suggestions on what and how to fix? Also, I live in Belmont, New Hampshire if anyone knows of a guy/garage/service center that is good with tranny's please let me know. I do bring it to have fluids changed (not flushed) and the garage said they didn't think that would fix my problem and that I shouldn't spend the 160 to change fluid if it wasn't my problem. Thanks
__________________

__________________
Reply With Quote
  #2  
Old 01-09-2011, 09:33 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,698
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525513
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: transmission advice

They most probably talk about the Throttle Valve Cable. Here below the adjustment procedure as described for the 42 RE transmission in the WJ, not sure if the ZJ is exactly the same.

ADJUSTMENT VERIFICATION
(1) Turn ignition key to OFF position.
(2) Remove air cleaner.
(3) Verify that lever on throttle body (Fig. 241) is
at curb idle position. Then verify that the transmission
throttle lever (Fig. 242) is also at idle (fully forward)
position.
(4) Slide cable off attachment stud on throttle body
lever.
(5) Compare position of cable end to attachment
stud on throttle body lever:

Cable end and attachment stud should be
aligned (or centered on one another) to within 1 mm

(0.039 in.) in either direction (Fig. 243).
If cable end and attachment stud are misaligned
(off center), cable will have to be adjusted as

described in Throttle Valve Cable Adjustment procedure.
(6) Reconnect cable end to attachment stud. Then
with aid of a helper, observe movement of transmission
throttle lever and lever on throttle body.
If both levers move simultaneously from idle to
half-throttle and back to idle position, adjustment is

correct.
If transmission throttle lever moves ahead of, or
lags behind throttle body lever, cable adjustment will

be necessary. Or, if throttle body lever prevents
transmission lever from returning to closed position,
cable adjustment will be necessary.
ADJUSTMENT PROCEDURE
(1) Turn ignition switch to OFF position.
(2) Remove air cleaner if necessary.
(3) Disconnect cable end from attachment stud.
Carefully slide cable off stud. Do not pry or pull
cable off.
(4) Verify that transmission throttle lever is in
fully closed position. Then be sure lever on throttle
body is at curb idle position.
(5) Pry the T.V. cable lock (A) into the UP position
(Fig. 243). This will unlock the cable and allow for
readjustment.
(6) Apply just enough tension on the T.V. cable (B)
to remove any slack in the cable.

Pulling too tight will cause the T.V. lever on the transmission to

move out of its idle position, which will result
in an incorrect T.V. cable adjustment.

Slide the sheath of the T.V. cable (D) back and forth until the

centerlines of the T.V. cable end (B) and the throttle
bell crank lever (C) are aligned within one millimeter
(1mm) (Fig. 243).
(7) While holding the T.V. cable in the set position

push the T.V. cable lock (A) into the down position
(Fig. 243). This will lock the present T.V. cable

adjustment.
NOTE: Be sure that as the cable is pulled forward
and centered on the throttle lever stud, the cable
housing moves smoothly with the cable. Due to the
angle at which the cable housing enters the spring
housing, the cable housing may bind slightly and
create an incorrect adjustment.
(8) Reconnect the T.V. cable (B) to the throttle
bellcrank lever (C).
(9) Check cable adjustment. Verify transmission

throttle lever and lever on throttle body move simultaneously
Attached Files
File Type: zip Doc3.zip (140.9 KB, 5 views)
File Type: zip Doc4.zip (61.8 KB, 4 views)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 01-09-2011, 10:14 PM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1951
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: transmission advice

hmmm.this may be my day for finding cures to all my jeep problems...I have a 98 4.0L with the same problem with an engine check code indicating speed sensor malfuntion but i'm still work at replacing front axel ujoints and haven't gotten farther than the code on the trans fix.
__________________
Reply With Quote
  #4  
Old 01-23-2011, 09:29 PM
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Nov 2010
Location: Belmont, NH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1380
OffCenter is on a distinguished road
Re: transmission advice

Thank u Frango100, didn't realize u posted a reply, so thanks again. So far the concensis is that I won't need a rebuild but I am not going to bank on it. But I have an appt this week to have it looked at, I'm not mechanically inclined at all.
__________________
Reply With Quote
  #5  
Old 01-24-2011, 06:44 AM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1951
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: transmission advice

Another note; my 98 4lt. holds in 2nd. and won't shift to 3rd.till 3500 rpm. however if i release the gas at around 2000-2200 rpm and coast it will shift to 3rd. and I can apply the gas and carry on then the shift into 4th is fine. this only happens with the 2-3 shift. As stated above the code I get relates to the vehicle speed sensor. I have been advised to swap this sensor and the problem will go away...I tried to swap it out with one from a 4lt.95 ltd but it was a different transfer case and would not fit.
I would not take it to a chain trans. shop as 9 times out of 10 they say Rebuild, ask around try and find someone who knows jeeps. find out what exactly is the problem before you even consider a rebuild
I am sure this is not a trany problem as it shifts fine when you back off the throttle...
its somthing to do with a sensor telling it not to shift IMHO...or something as simple as the cable out of adjustment or disconnected, vacuum leak?
__________________
That's the WRONG side of this fence Bub, and these ain't Halos.. Daddy don't like nobodyz in here with his jeeps!!! Let's play chase yer balls, you gotz any balls, do ya?

07 WK LTD 5.7, with 13000 klm (7600 miles)So Far... repaint and debage, probly shoulda just got the SRT in the begining...now Im gonna hafta go expensive exotic aftermarket to be Blissfully Demented. SRT Nose and Stillens shiney new shoes SRT springs, Front/Rear Sways, WK HD Bilsteins, a couple of plastic bits from JforJ, all ready to go on. SRT Headers and mid pipes with cats waiting for the new predator inTune ( it'll match my new iPhone...Wait maybe its a iPhone app ) SRT coil covers & roof rails another problem to be solved
Reply With Quote
  #6  
Old 02-07-2011, 07:11 PM
Member
My Jeep: 1996 4.0L ZJ
 
Join Date: Nov 2010
Location: Belmont, NH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1380
OffCenter is on a distinguished road
Re: transmission advice

Ok took to a shop. and had a friend who mec inclined to a degree, he and the garage said that it shifts fine and that with the troque of 1st and 2nd that this is normal. just needed fluid change not a flush. they adjusted one of the cables. but the sensor in the tranny was spot on. no unusual metal in pan, all looks good except the leak around front of tranny. so in a nut shell it's a jeep thing. thanks alot for all the help. I hope i'm writting back in a week or month saying tranny just went.
__________________
Reply With Quote
  #7  
Old 02-08-2011, 05:22 AM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1951
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: transmission advice

"I hope i'm writting back in a week or month saying tranny just went."

Why would you wish transmission failure in yourself
I'm thinkin' thats not what you meant

It is a jeep thing... my oldest jeep starts shifting a little weird, first thing I look at is fluid, and when I last changed it...change the fluid and filter, it shifts great again.besides opening the pan or diff covers when you change your fluid you can usually tell right away if bad things are going on in there...maybe in time to correct it cheep.

ps. looks like I was right in the earlier post...maybe I'll check my TV cable before I replace the sensor.
__________________

__________________
That's the WRONG side of this fence Bub, and these ain't Halos.. Daddy don't like nobodyz in here with his jeeps!!! Let's play chase yer balls, you gotz any balls, do ya?

07 WK LTD 5.7, with 13000 klm (7600 miles)So Far... repaint and debage, probly shoulda just got the SRT in the begining...now Im gonna hafta go expensive exotic aftermarket to be Blissfully Demented. SRT Nose and Stillens shiney new shoes SRT springs, Front/Rear Sways, WK HD Bilsteins, a couple of plastic bits from JforJ, all ready to go on. SRT Headers and mid pipes with cats waiting for the new predator inTune ( it'll match my new iPhone...Wait maybe its a iPhone app ) SRT coil covers & roof rails another problem to be solved
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm new here and looking for some advice ilirdino Interior/Exterior/Visual 43 10-31-2010 04:02 PM
New here looking for advice. overlander5.7 Grand Cherokee - WK 4 10-12-2010 09:21 PM
New here looking for advice. overlander5.7 Grand Cherokee - WK 1 10-12-2010 11:50 AM
Need A Little Advice nightcrooks Grand Cherokee - WK 8 04-21-2010 07:01 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community