Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-22-2012, 03:46 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54177
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Transmission code P0750

I have been having trouble lately and the transmission is going into limp mode. I should mention, its a 01 WJ with the 545rfe. The code is P0750, shift solenoid A malfunction. Here is an exact quote from wjjeeps.com:

Note: If code P1767 (Transmission Relay Always On) is also present: Replace transmission solenoid assembly. See note provided. When transmission is in limp mode the relay that provides power to the solenoid group is switched off. This is normal and is designed to provide operation in one gear only.

Engineering department suggests to replace transmission solenoid assembly anytime these two trouble codes occur together. See applicable service manual section (21) for solenoid assembly replacement directions. IMPORTANT: When performing this repair always check torque on all valvebody accumulator cover plate screws. Proper torque specification is 70 inch pounds. If any accumulator cover plate screws are damaged or missing replace the valvebody assembly. NOTE: If any other trouble codes are present do not replace solenoid assembly. See test in the applicable Transmission Diagnostic Procedures Manual.

This only mentions if code P1767 is also present, but it is not. Anyone else seen these codes? I should mention that they came on a few weeks ago, I cleared the code, and it was fine for a while. Now this weekend it came up, I cleared it, and it came back again. Any help would be appreciated. Thanks.
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #2  
Old 01-22-2012, 09:42 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Strongstown Pa.
Posts: 3,023
Thanks: 86
Thanked 65 Times in 61 Posts
Rep Power: 331686
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission code P0750

Aaron do you have a service manual? If not pm me your address.
__________________

__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #3  
Old 01-23-2012, 04:54 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,328
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission code P0750

Normally with this code there is something wrong with the solenoid block. But before changing anything, have a look at the connector on the left hand side of the tranny. The connector could be loose or have dirty connector pins. Clean it out with some contact cleaner,let it dry, reconnect and try again. When the fault returns, then its probably the solenoid block itself.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 01-23-2012, 09:59 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54177
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission code P0750

Quote:
Originally Posted by Frango100 View Post
Normally with this code there is something wrong with the solenoid block. But before changing anything, have a look at the connector on the left hand side of the tranny. The connector could be losse or have dirty connector pins. Clean it out with some contact cleaner,let it dry, reconnect and try again. When the fault returns, then its probably the solenoid block itself.
Thanks for the tip Frank! I will check that out as soon as the winter crap dries up a bit around here, we are finally getting a decent amount of snow.
__________________
Reply With Quote
  #5  
Old 01-23-2012, 11:42 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54177
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission code P0750

Ok, so while driving to work this morning the code came back. When I got to work I cleared it and before leaving to lunch I used my superchips to return the vehicle to stock. No codes since. I am starting to wonder if maybe the solenoid is on its way out and the tuning (plus maybe the way I drive with it on) is causing the problem. Seem possible? I know its only been one day I plan on running a while without the tune and see what happens.
__________________
Reply With Quote
  #6  
Old 01-24-2012, 12:55 AM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Strongstown Pa.
Posts: 3,023
Thanks: 86
Thanked 65 Times in 61 Posts
Rep Power: 331686
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission code P0750

Quote:
Originally Posted by 01grand View Post
Ok, so while driving to work this morning the code came back. When I got to work I cleared it and before leaving to lunch I used my superchips to return the vehicle to stock. No codes since. I am starting to wonder if maybe the solenoid is on its way out and the tuning (plus maybe the way I drive with it on) is causing the problem. Seem possible? I know its only been one day I plan on running a while without the tune and see what happens.
I hope not leadfoot!
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #7  
Old 01-24-2012, 03:03 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,328
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission code P0750

Iīm not familiar with tuning, but isnīt it only changing the programming of the PCM, or does it do something with the TCM as well?
Well, only time will tell now if it has something to do with it.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 01-24-2012, 09:21 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54177
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission code P0750

I believe the tuning bumps up the line pressure and changes shift points, and I know it makes harder, quicker shifts.

Also, I keep getting P0456 lately, which is a very small vacuum leak. I tightened my gas cap again, but I'm starting to think its something else. Guess I will have to start checking vacuum lines.
__________________
Reply With Quote
  #9  
Old 01-24-2012, 02:17 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Strongstown Pa.
Posts: 3,023
Thanks: 86
Thanked 65 Times in 61 Posts
Rep Power: 331686
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission code P0750

Try a new cap first Aaron.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #10  
Old 01-24-2012, 02:21 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,328
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission code P0750

And if the cap doesn't help, the rubber hoses above the rear axle are known to get dry and crack.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #11  
Old 01-27-2012, 05:12 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54177
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission code P0750

Update: No codes have come back all week. I cleared the codes Monday morning and took the tuning off then. No codes, so on Wednesday I decided to try the mileage tune to see if that makes a difference for the 3 hour trip I have this weekend. No codes since then, and hopefully none over the weekend, I will report back on Monday.

This leaves me wondering, do I have a weak solenoid that fails under the added pressure of the performance tuning? If all goes well this weekend I will try the tuning again next week, I think that would confirm the problem if it comes back.

I did not get a chance to check the wire connector like you suggested Frank, but I'm thinking now that if the connector were loose it wouldn't make a difference if the tuning was on or not.
__________________
Reply With Quote
  #12  
Old 01-27-2012, 05:46 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,328
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission code P0750

I donīt know what the tuning exactly does Aaron, but indeed you would expect the same problem with or without the tuning if it was related to the connector.
Or if the solenoid would draw more current due to switching a higher line pressure, it could still have to do with a resistance problem in the connector.
If the problem comes back, that would be the first thing i would check, and it would only cost some time and contact cleaner.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble code 2005 WK Grand Cherokee - WK 2 11-06-2011 10:46 PM
P0750 ?? sdionne Grand Cherokee - WK 12 10-09-2011 06:23 PM
P0700 code SLVRLTNG Trouble Shooting/Problems/Service 18 08-31-2011 06:30 PM
P0750 code for 04 Jeep Laredo spice2728 Troubleshooting/Problems 2 01-25-2011 09:42 PM
Code Robert Palmer Trouble Shooting/Problems/Service 14 05-17-2010 11:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community