Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #49  
Old 11-20-2012, 02:01 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,217
Thanks: 9
Thanked 124 Times in 117 Posts
Rep Power: 526237
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission slipping

Just be sure that the SC tune doesn't increase the line pressure already before installing the resistor. Otherwise you would have an increase over an increase and have a change of blowing seals. I have no tune and just soldered the resistor in there.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #50  
Old 11-20-2012, 06:00 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,808
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54419
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission slipping

Quote:
Originally Posted by Frango100 View Post
Just be sure that the SC tune doesn't increase the line pressure already before installing the resistor. Otherwise you would have an increase over an increase and have a change of blowing seals. I have no tune and just soldered the resistor in there.
I just read on the superchips forum that they do not change line pressure, it seems for the 99-04's they just mess with the engine. In goes the resistor!
__________________

__________________
Reply With Quote
  #51  
Old 11-20-2012, 07:12 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,124
Thanks: 100
Thanked 71 Times in 66 Posts
Rep Power: 332010
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission slipping

Quote:
Originally Posted by 01grand View Post
Ha, ok never mind then, I will just do the battery reset. I'm finally going to put in a line pressure resistor for the shift kit. Wasn't sure if I needed it since I have the SC but hopefully it works as well as Cheap's if not I can always take it off.
Just remember bro solder it don't be tempted by those crimp connectors! Slide a piece of heat shrink on there before you put it together. Then tape it up good. I also used a piece of wire loom stuff over it all for some added protection.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #52  
Old 11-20-2012, 07:16 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,124
Thanks: 100
Thanked 71 Times in 66 Posts
Rep Power: 332010
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission slipping

Frank do you have a separate tcm?
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #53  
Old 11-20-2012, 07:31 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,217
Thanks: 9
Thanked 124 Times in 117 Posts
Rep Power: 526237
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission slipping

:i don't, but the jeep does.
Fo some strange reason my 2004 WJ still has the separate TCM.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #54  
Old 11-20-2012, 07:43 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,124
Thanks: 100
Thanked 71 Times in 66 Posts
Rep Power: 332010
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission slipping

So you could do the #10 snip?
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #55  
Old 11-27-2012, 05:46 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,217
Thanks: 9
Thanked 124 Times in 117 Posts
Rep Power: 526237
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission slipping

Is the #10 snip not only for HO engines? I know its for torque management, but what does it really do?
So after some more days of driving, the shifting is smoothing out a bit, but sometimes when going from 2nd to 3rd it goes really rough, i donīt like that at all. Also the converter clutch engagement is sometimes going with a shock, which previously was only seen as a rpm reduction.
I also got the check engine light back with a P0845 code and a P1775 code. Now i just forgot which one was which, but in the trouble shooting i red that it could have to do with the line pressure sensor signal. Now after removing the connector of the line pressure sensor, both codes didnīt reappaer anymore. Will try an other sensor which i still have, or if that doesnīt help, i will remove the resistor from the Transgo shiftkit and see what that does.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #56  
Old 11-27-2012, 09:22 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,124
Thanks: 100
Thanked 71 Times in 66 Posts
Rep Power: 332010
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission slipping

Anything with the Jtech engine management system.'04 non HO's are supposed to have the NGC system which combines the ECU and TCM into one unit which makes it "unsnipable". But there seems to be a lot of exceptions such as yours. The snip eliminates the timing retard during WOT shifts.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #57  
Old 01-11-2013, 07:13 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,217
Thanks: 9
Thanked 124 Times in 117 Posts
Rep Power: 526237
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Transmission slipping

Transmission, the final chapter?
So after the rebuild the transmission was working well, but i got 2 fault codes set.
A P1775 and a P0845. The first one means that the solenoid switch valve (SSV) in the valve body was stuck in TCC (torque converter clutch) position. When that happens, the TCM will automatically select 2nd gear. The SSV is there, so that they can use the LR/CC solenoid to activate the LR clutch, or the TCC, so only need 1 solenoid for that. There is a pressure switch in the LR circuit which shows to the TCM that there is pressure in the LR circuit, thus the SSV is in 1st gear position.
The P0845 is a failed hydraulic pressure check for the 2C clutch.
So there went i again and opened the tranny pan, opened up the valve body to check the SSV for free movement and changed the repair kit for the solenoid pack, which i had received before. SSV was moving freely and also the solenoid pack didnīt show anything strange.
Put it all together and gues what, ended up with one more code, P0968.
The jeep was driving normally, but as soon as the p0845 popped up, it went into limp mode. I was already getting a bit sick about it, but today i was thinking to install the old solenoid pack which i still had laying on the bench, just for a check.
I first had to clean that one and i took it appart. For the old solenoid pack i have an exploded view image, which i didnīt had for the newer one. Strange also that the repair kit for the newer one came without any instructions. But then when putting the old one together, i found out that i wanted to put the hydraulic pressure switches lip seals contrary to what the manual stated. Then i found out that these seals, which should actuate the switch contact plunjers, only flex towards one side and are quite rigid to the other. I suddenly saw the light and was almost sure that the newer pack was assembled (by me) in the same (read: wrong) way. Opened it up and indeed all 5 switches lip seals where wrongly installed, preventing them to activate the switch, so the TCM wouldnīt see any pressure, even if it was there.
Assembled it all in the right way and gues what, all ok now.
I hope i donīt have to bother you diehards, who are still reading, anymore about tranny issues on my jeep.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #58  
Old 01-11-2013, 07:19 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 134023
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Transmission slipping

Glad it worked out for you! When I saw you posted on this thread again I thought "Awww sh!t. not again" lol. But im glad it worked out for you! No more posts!
__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #59  
Old 01-14-2013, 01:06 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,808
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54419
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Transmission slipping

Whew frank, you had me worried your tranny was messed up again. Dont sweat it, we all make mistakes like that. At least nothing was broken to the point it couldnt be fixed.
__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #60  
Old 01-15-2013, 05:11 AM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,124
Thanks: 100
Thanked 71 Times in 66 Posts
Rep Power: 332010
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: Transmission slipping

Glad everything is ok Frank! Time to lock this thread!
__________________

__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 YJ transmission Sodelcustoms Wrangler-YJ, TJ & JK 3 10-11-2011 04:14 AM
Help with transmission problem Xanatos03 Troubleshooting/Problems Discussion 1 09-19-2011 09:25 PM
Crazy Transmission SupWiz17 Troubleshooting/Problems 16 09-16-2011 11:04 AM
Transmission swap on a 07 WK with the 3.7L MLIB Grand Cherokee - WK 10 01-16-2011 02:23 PM
Which transmission do I have? magradze Troubleshooting/Problems 5 04-07-2010 01:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.