Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
View Poll Results: Have you had the same or similar issues?
Yes 0 0%
No 3 100.00%
Voters: 3. You may not vote on this poll

Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-03-2011, 03:32 PM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: May 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1094
Caleb5995000 is on a distinguished road
Trouble codes... need help!

Hi, I found this forum while searching for solutions to my beloved Jeep's maladies. I found another thread that had similar issues, but mine are different enough that I thought another thread would be advisable.

I've got a 99 Grand Cherokee, 4.7, 175k miles. She starts and runs smoothly. She has plenty of power. Gas mileage is decent-ish: 13 to 18 mpg. Since she runs well, I have been ignoring the check engine light for a while. But I can no longer do so because I need to pass smog in order to renew my registration.

In the past I've been able to use diagnostic codes in conjunction with online research and trial and error to find and replace faulty sensors. But this time I'm way over my head. Thank you for your help in advance. So... here are the codes:

P0203 - Cylinder 3 Injector Circuit Malfunction
P0201 - Cylinder 1 Injector Circuit Malfunction
P0208 - Cylinder 8 Injector Circuit Malfunction
P0133 - Oxygen Sensor Circuit Slow Response (Bank1, Sensor1)
P0171 - System Too Lean (Bank 1)
P0462 - Fuel Level Sensor Circuit Low Input

Additional info: My fuel gauge has never work properly - very erratic. The fuel pump, filter, and fuel level float were replaced several years ago. I think I have a small exhaust leak on the passenger side (manifold gasket?). I already tried cleaning the Mass Airflow Sensor (using brake cleaner).

Cheers,
Caleb
__________________

__________________
Reply With Quote
  #2  
Old 05-03-2011, 08:41 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,330
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Trouble codes... need help!

I would start cleaning the connectors on the PCM with electrical contact cleaner. Reset the codes and see what it will do.
It seems that your bank 1 O2 sensor 1 needs to be replaced.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-03-2011, 08:55 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,128
Thanks: 731
Thanked 701 Times in 563 Posts
Rep Power: 7716602
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Trouble codes... need help!

wow...what a list! Listen to the smart guy just below you!
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
2013 Audi A7 premium plus-phantom black sportback
2012 FIAT 500 Sport-daughters Mopar....LOL


Twitter-The_Jeep_Guy
Instagram-thejeep_guy



Reply With Quote
  #4  
Old 05-03-2011, 09:27 PM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: May 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1094
Caleb5995000 is on a distinguished road
Re: Trouble codes... need help!

Quote:
Originally Posted by Frango100 View Post
I would start cleaning the connectors on the PCM with electrical contact cleaner. Reset the codes and see what it will do.
It seems that your bank 1 O2 sensor 1 needs to be replaced.
Thanks for the speedy response, Frango100!

Is the PCM under the dash?

Regarding the O2 sensor: bank 1 sensor 1 is under the hood on the driver's side, correct? And where can I find that part number? Also, do you recommend a specific manufacturer? I've read that some people do NOT recommend Bosch sensors for Jeeps. In your opinion is there any validity to this concern?

Cheers,
Caleb
__________________
Reply With Quote
  #5  
Old 05-04-2011, 03:26 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,749
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652816
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Trouble codes... need help!

You need:

Throttle position sensor for your injector control issues

Quote:
Case Number919935880 Vehicle IssueMIL on P0203 : 13 : INJECTOR #3 CONTROL CIRCUIT with no drivability issues: Noise in TPS circuit.;Internally the PCM uses the same A/D (analog to digital) converter for TPS voltage as it does for the speed control switch sense. If the v-37 circuit has voltage bleed over from another source, a code of TPS Shorted to voltage, TPS does not agree with MAP may be set in the PCM and or injector fault codes.System or ComponentDTC / Error Message;Yes - IntermittentRecommendationUse A lab scope to check TPS voltage for .02 (or more) voltage change/noise a new TPS may be required.
Modification Date09/30/03 9:17 AM
O2 sensor for slow response and likely your system lean... MIGHT be due to exhaust leak.

for your P0462 - (another star case) The root cause electrostatic discharge between the fuel tank and the PCM through the fuel sending unit circuit.Ground Strap Kit p/n 05139183AA is now in stock and can be ordered. It is supposed to have an I-sheet included.
__________________
Reply With Quote
  #6  
Old 05-04-2011, 06:58 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,330
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Trouble codes... need help!

Didnīt knew about the TPS causing this codes, would be a simple fix.
Regarding the O2 sensor, it would be wise to repair the exhaust leak first, because it could solve those other codes. If not, yes, the bank 1 sensor 1 is on the LH bank exhaust (looking from drivers seat), the first sensor after the gasses exit the cylinders.
I have no personal experience with O2 sensors, but i heard that you can best go with OEM ones. Other sensors are not bad, but it seems that the sensor heating on not OEM sensors is more slow and can cause your Check Engine coming on again.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 05-04-2011, 07:45 AM
TJXJWJ's Avatar
The "pre" SRT 8
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2010
Location: Aurora, OH
Posts: 3,373
Thanks: 192
Thanked 66 Times in 56 Posts
Rep Power: 286577
TJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond reputeTJXJWJ has a reputation beyond repute
Garage
Re: Trouble codes... need help!

IF you're replacing 02 sensors, use OEM. I read an entire article somewhere (forget where) that explained in GREAT detail, why and it had a lot to do with warm up times of the actual sensors (OEM V Bosch).

If you keep calling your Jeep a "she", it will continue to have issues and give you headaches

Lastly, I agree that you should start by replacing the TPS (based on 2005JGC's info) and repairing any exhaust leak and then reset the PCM (under the hood, near passenger's side firewall by the way) and take it from there.
__________________
Tony-04 Limited HO, DkKhaki w/tan leather int. All LED lighting, 5000k Xtreme HID projs. (deambered)&fogs w/CCFL rings, tinted tails&3rd LED brake lt, fnt glass tinted to match, shawty antenna, 6 Polk speakers, K&N FIPK, FR 70mm TB, TCM#10 snip, Flashpaq'ed on 91 tune, Bilstien HD's, Addcos, polished 20" SRT reps, Hankook Ventus Evos (255-45), Weathertech mats, EBC USR rotors, EBC Greenstuff pads, Magnaflow muffler, RB1 Nav w/iPod kit, de-badged, roof rack delete.
09 Liberty KK Rocky Mountain Edition. Added Mopar Remote Start kit, Weathertech Mats, K&N drop-in.
PAST JEEPS : 99 TJ Sport, 98 XJ Sport, 06 WK Laredo
Reply With Quote
  #8  
Old 05-04-2011, 08:06 AM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 564
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2515
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Trouble codes... need help!

Quote:
Originally Posted by Caleb5995000 View Post
Regarding the O2 sensor: bank 1 sensor 1 is under the hood on the driver's side, correct? And where can I find that part number? Also, do you recommend a specific manufacturer? I've read that some people do NOT recommend Bosch sensors for Jeeps. In your opinion is there any validity to this concern?
There's an easy way to determine if it's caused by an exhaust leak or not. Pull the O2 sensors. Swap the positions (bank 1 goes to bank 2, bank 2 goes to bank 1). Reset the codes and see if the error moves to bank 2 or stays on bank 1. If it stays on bank 1, it's most likely an exhaust leak.

Quote:
Originally Posted by TJXJWJ View Post
If you keep calling your Jeep a "she", it will continue to have issues and give you headaches
__________________
Reply With Quote
  #9  
Old 05-05-2011, 01:50 AM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: May 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1094
Caleb5995000 is on a distinguished road
Re: Trouble codes... need help!

Quote:
Originally Posted by 2005JGC View Post
You need:

Throttle position sensor for your injector control issues



O2 sensor for slow response and likely your system lean... MIGHT be due to exhaust leak.

for your P0462 - (another star case) The root cause electrostatic discharge between the fuel tank and the PCM through the fuel sending unit circuit.Ground Strap Kit p/n 05139183AA is now in stock and can be ordered. It is supposed to have an I-sheet included.
Wow! Great info... thanks!
__________________
Reply With Quote
  #10  
Old 05-05-2011, 01:52 AM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: May 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1094
Caleb5995000 is on a distinguished road
Re: Trouble codes... need help!

OK, so I've located the O2 sensor and its stuck... I mean really frozen on there. Any suggeestions?
__________________
Reply With Quote
  #11  
Old 05-05-2011, 01:55 AM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: May 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1094
Caleb5995000 is on a distinguished road
Re: Trouble codes... need help!

[QUOTE=

If you keep calling your Jeep a "she", it will continue to have issues and give you headaches
[/QUOTE]

HAHAHA!! I burst out in laughter when I read that. My girlfriend asked what was so funny, so I read it to her. Now she's mad.


To be honest, even with all her problems my Jeep has been more faithful than any woman I've been with (present girlfriend excepted, of course).
__________________
Reply With Quote
  #12  
Old 05-05-2011, 05:30 AM
Senior Member
 
Join Date: Feb 2011
Posts: 3,143
Thanks: 73
Thanked 42 Times in 36 Posts
Rep Power: 533847
Amelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond repute
Re: Trouble codes... need help!

TJXJWJ: You need to upgrade that signature picture with the Gen III projectors you have lol, Those Gen II's are a thing of the past brotha! lol
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble Codes List SoCalMoparWK Tech Tips DIY/How To 27 01-18-2013 11:38 PM
Reading Trouble Codes alretired Trouble Shooting/Problems/Service 1 01-21-2011 09:14 AM
Trouble Codes are messing with my mind psycojeep Troubleshooting/Problems Discussion 7 08-27-2010 09:04 PM
Diagnostic Trouble Codes Frankie Troubleshooting/Problems Discussion 12 05-30-2009 11:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community