Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-30-2013, 06:06 AM
Member
 
Join Date: Dec 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 258
Jakkie is on a distinguished road
Exclamation V8 Miss-behaving....

Hi Jeepers,

I 'm from Johannesburg, South Africa and I own a 2001 Grand Cherokee 4.7lt V8 Limited

This morning I hitched a trailer from work to the Jeep and 800m's down the road she starts to missfire and die. I manage to restart her, and she sounds like she runs on 4 cylinders.

Do the code read after engine light comes on, shows P300-P302 which according to decoder is missfire in cylinder 1-3.

I checked all fuses and found that the lighter socket is blown, now I'm suspecting a wrongly wired trailer might have caused a short in the harness... Any ideas??

This time of year everyone is closed so I'll be DIY'ing...
__________________

__________________
Reply With Quote
The Following User Says Thank You to Jakkie For This Useful Post:
  #2  
Old 12-30-2013, 07:16 AM
JeepFreak12's Avatar
Black Widow
My Jeep: 2010 6.1L SRT8
 
Join Date: Mar 2011
Location: Roseville, Michigan
Posts: 1,962
Thanks: 185
Thanked 106 Times in 97 Posts
Rep Power: 8082
JeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond repute
Garage
Re: V8 Miss-behaving....

Did you clear the code after the trailer was unhooked? Also pull the plugs to check how they look. You can try having someone keep the rpm's at 2K and un-plug each coil pack one by one. If the motor runs worse, its a good plug/coil. If it stays running the same its a bad coil/plug.
__________________

__________________
2010 Brilliant Black SRT8: MODS = To much to list! Check out My Build
Reply With Quote
  #3  
Old 12-30-2013, 12:15 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,801
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: V8 Miss-behaving....

P0300 is a multiple cylinder misfire code. P0302 is for cylinder 2. Eventhough several things can cause a misfire, many times its caused by a slow closing exhaust valve due to carbon buildup on the valve stems. When operating the engine mostly on short distances and with rpm below 3000 rpm, the carbon will build up more quickly. Also under 3000 rpm the valve will not rotate, adding to the carbon buildup.
A seafoam treatment via the inlet could solve your problem.
There is a TSB about this, will look for the number.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 12-30-2013, 01:37 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,801
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: V8 Miss-behaving....

Ok, here is the TSB. Eventhough its for the 4.0, it is also valid for the 3.7 and 4.7 engine.
If a seafoam treatment doesn't help, you could swap ignition coil #2 with #1 and see if the misfire goes to cylinder #1. Also check the #2 plug for fouling or extended wear and run some injector cleaner in the fuel.
Attached Files
File Type: pdf tsb_wj_0900303.pdf (24.6 KB, 11 views)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 12-31-2013, 01:56 AM
Member
 
Join Date: Dec 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 258
Jakkie is on a distinguished road
Exclamation Re: V8 Miss-behaving....

Frank,

Thank you for the reply... Dont think thats the problem as the Jeep just returned from a 1000km trip without any issues the previous day.

In addition to the other codes, this morning I have a P0108 and P0352 code aswell, the MIL engine light is also permanently on now and the 'Perform Service' message is displayed on the overhead display, even thou she had another 5600km to go to her next service.

Another thing as well, this morning turning the ignition, nothing happened up until about the 5th time I turned the key. Then only did the starter motor kick in and she started easily, but badly misfiring...

Will swop the coils around this afternoon and see if they are bad. Any other suggestions are greatly appreciated...
__________________
Reply With Quote
  #6  
Old 12-31-2013, 02:08 AM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: V8 Miss-behaving....

check all youre grounding connections and clean them up
__________________
Reply With Quote
  #7  
Old 12-31-2013, 02:13 AM
Member
 
Join Date: Dec 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 258
Jakkie is on a distinguished road
Exclamation Re: V8 Miss-behaving....

Quote:
Originally Posted by kennzz05 View Post
check all youre grounding connections and clean them up
Hi Kennzz,

I'm thinkink along those lines too. Think that trailer killed a grounding wire somewhere... The question is where would the grounding wire be for the effected systems...
__________________
Reply With Quote
  #8  
Old 01-03-2014, 02:38 AM
Member
 
Join Date: Dec 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 258
Jakkie is on a distinguished road
Exclamation Re: V8 Miss-behaving....

HI Guys,

Just a quick update on what I've done:

1. Reset the PCM by removing the battery terminals an grounding them.
2. Swopped coils with running cylinders - No effect, 1,2 & 4 remains dead leading me to believe its an electric fault as the coils are fine.

Noted that the EVIC overhead display 'computer' is dead, displays nothing at the moment.

After driving it for about 15km's the codes picked up from the diagnostic is P0351 & P0354 which tells me there's a electrical short in the system.

Questions:

1.Does anyone know where these systems are grounded? Evic and coils.
2. Could the Cam Position Sensor cause this, or be part f the problem?

Any suggestions are greatly appreciated!

PS: Just noticed that the reverse lights do not come on anymore when going into reverse...
__________________
Reply With Quote
  #9  
Old 01-03-2014, 07:46 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,801
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: V8 Miss-behaving....

Just to rule out coincidence, did you check both EVIC fuses? It are #8 and #22 on the junction block. Ground for the EVIC is point G301. This same ground point is used for the left back-up light, but not for the right back-up light. See if the back-up lights come on after selecting reverse several times. The reverse switch is part of the TRS-solenoid block inside the transmission.
The ignition coils are fed with 12V via the auto shutdown relay when ignition is switched on (if you donīt start the engine, the relay will fall off again after some seconds). The ground is made inside the PCM. So check all the PCM ground wires for being clean and well fixed. But this could well be a PCM problem.
Attached Files
File Type: pdf G301.pdf (135.5 KB, 6 views)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 01-03-2014, 07:52 AM
Member
 
Join Date: Dec 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 258
Jakkie is on a distinguished road
Re: V8 Miss-behaving....

Thank you Frango.

Both reverese lights do not come on when selecting reverse.

I will check the Ground connection. This is located under the passenger seat right? I have a right hand drive model.

Both Evic Fises are intact...

Where is the PCM located?

Sorry for all the questions!
__________________
Reply With Quote
  #11  
Old 01-03-2014, 08:00 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,801
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: V8 Miss-behaving....

Just added a picture on my previous post for the G301, but not sure if this is the same for right hand drive.
On my jeep the PCM sits against the bulkhead at the right fender. It has 3 connectors on the front face. I heard of some people having problems of corrosion of the casing, causing shorts inside the PCM. You will only see the corrosion problem when you remove the PCM from its place.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 01-03-2014, 08:04 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,801
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525732
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: V8 Miss-behaving....

Just found an other picture for RHD jeeps. G301 still sits on the left side, but seems to be a bit different spot.
And your question regarding the cam sensor, i wonīt suspect it. When cam (or crank) sensor goes bad, the engine normally wonīt start at all
Attached Files
File Type: pdf G301 RHD.pdf (139.6 KB, 1 views)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Miss Jaimoe Troubleshooting/Problems 1 04-04-2013 07:15 PM
Welcome Summer, oh how I miss u! 6ILES_K Members Rides-Showoff 15 01-10-2013 01:38 PM
Greetings to all and HELP with odd miss-out! jasonsos Troubleshooting/Problems 2 05-01-2012 08:16 PM
I miss this Bitch.... robpp Other Rides 12 06-22-2009 02:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community