Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-13-2012, 02:38 AM
stephanwj's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jan 2012
Location: ND
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5136
stephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond repute
weird trans problem help

my trans or cruise is bing crezy in the vid my, what seems like my torque convertor unlocks and locks when the cruise is on but when i turn the crusie off it works fine but some times the cruise can be on for a wile be for it acts up , any info on this please
__________________

__________________
Reply With Quote
  #2  
Old 02-13-2012, 02:38 AM
stephanwj's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jan 2012
Location: ND
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5136
stephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond repute
Re: weird trans problem help

http://youtu.be/AgOKWGi40wE
__________________

__________________
Reply With Quote
  #3  
Old 02-13-2012, 10:51 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,698
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525513
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: weird trans problem help

There is in fact not a big difference when you have your foot on the accelerator, or when you are in cruise mode, its only a different cable which hold the throttle plate in position.
Its the TCM which controls the torque converter clutch engagement, depending on several inputs. I could not find any different input for manual accelerator or cruise. Did you check for any fault codes with the key dance?
Without any fault codes set, i would start cleaning all connectors on transmission, TCM and PCM.
A faulty TPS sensor could cause the torque converter disengagement, but it would not explain it behaving normally in manual mode.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 02-14-2012, 03:00 AM
stephanwj's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jan 2012
Location: ND
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5136
stephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond repute
Re: weird trans problem help

Ur right about that its crazy do you thing it is my cruise it self doing it
Or a vac leek
__________________
Reply With Quote
  #5  
Old 02-14-2012, 05:53 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,698
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525513
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: weird trans problem help

The cruise control system is vacuum actuated, but if due to a leak the output changes, i would expect that also the speed would change. If you have a scanner which shows the TPS position, you could connect it while driving and check if the TPS position is changing at the moment the torque converter is unlocking.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 02-14-2012, 04:09 PM
stephanwj's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jan 2012
Location: ND
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5136
stephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond reputestephanwj has a reputation beyond repute
Re: weird trans problem help

Ill have to try that. But if there is a leek in the vacuum. On the cruise. Do you think the cruise would open more for the lack of vac and think its many going up a hill and unlocking the TC to anticipate the need for more throttle?
__________________
Reply With Quote
  #7  
Old 02-14-2012, 07:18 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,698
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525513
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: weird trans problem help

The strange thing is that when you accelerate a bit with your foot, that the torque converter doesn´t unlock. Did you try it with a fast acceleration with your foot as well?
The best in fact would be to have the right scanner, which also shows in which gear you are and if the torque converter is locked or not. Then you have the certainty that its the torque converter which is unlocking and not a shift from 5 to 4.
A lack of vacuum could cause a slower response, but i won´t expect the torque converter to unlock due to low vacuum. That would more depend on the actual vehicle speed and the selected speed.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First Weird Problem computerwiz621 Trouble Shooting/Problems/Service 2 02-07-2012 06:48 PM
weird speaker problem TurboDiesel Audio, Video, Navigation & Electronic Modifications 0 11-17-2011 12:21 AM
trans problem, advise needed prplhz96 Grand Cherokee - WK 1 05-12-2011 09:07 AM
Weird Audio Problem... Frankie Audio, Video, Navigation & Electronic Modifications 5 11-11-2010 11:09 PM
Weird Starting Problem silversx05 Grand Cherokee - WK 7 06-06-2010 06:43 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community