Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2012, 09:20 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 620
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2756
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Whistle when Accelerating

Today was really the first day this year that I would even consider to think about calling cold, it was about 20 degrees. Anyways, I started driving my Jeep (4.0L I6 w/ 110k miles) and when I accelerated from the driveway I noticed a high pitched whistle. As I was accelerating it would whistle, when I would let off it would stop. Usually it would whistle at any acceleration once I was about ~1800 rpms. But once the engine warmed up, it went away.

I did some quick searching and it looks like it could be a cracked intake/exhaust gasket, cracked exhaust manifold, or cracked intake manifold. While there's nothing special or difficult about changing any of those, it will take a good amount of time to it (most likely take me a whole day). Before I sink a day into it, does anyone else know anything about this noise? Any other possibilities that would be easier to check? I don't see that there's any way to check the gasket w/out taking it apart.
__________________

__________________
Reply With Quote
  #2  
Old 02-13-2012, 05:53 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,048
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526032
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Whistle when Accelerating

Are you sure it was not the accessory belt which was slipping?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-13-2012, 07:49 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 620
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2756
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Whistle when Accelerating

Quote:
Originally Posted by Frango100 View Post
Are you sure it was not the accessory belt which was slipping?
Yeah, definitely not a belt noise.
I would say a slipping belt is more of a squeal, this is a whistle. It sounds just like the video below (not my video, just found on youtube), but only when I'm accelerating on a cold engine.

__________________
Reply With Quote
  #4  
Old 10-09-2012, 07:45 AM
MogaJeep's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Aug 2012
Location: New York
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 818
MogaJeep is on a distinguished road
Re: Whistle when Accelerating

Hey, Guess I'm bringing this post back from the dead

I just started having the same problem on my '04 4.7L ho.

I'm curious to know how you resolved the problem.

I'm also finding out it could be the IAC motor or maybe a crack in the intake. If anyone can help much appresh!!!
__________________
Reply With Quote
  #5  
Old 10-11-2012, 05:36 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 620
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2756
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Whistle when Accelerating

Quote:
Originally Posted by MogaJeep View Post
Hey, Guess I'm bringing this post back from the dead

I just started having the same problem on my '04 4.7L ho.

I'm curious to know how you resolved the problem.

I'm also finding out it could be the IAC motor or maybe a crack in the intake. If anyone can help much appresh!!!
After much research I decided it was a small crack in the intake/exhaust gasket (they are the same gasket on the I6). I took some high temperature RTV and put a bead around the entire gasket and it's gone.

That's not the "correct" way to fix the issue. Since this is my only vehicle to drive, I didn't really want to replace the gasket at the time.
__________________
Reply With Quote
  #6  
Old 10-13-2012, 09:37 AM
MogaJeep's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Aug 2012
Location: New York
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 818
MogaJeep is on a distinguished road
Re: Whistle when Accelerating

Cool I'm going to check that out today. I hear you on using RTV as not the "correct" way haha but I think that it works pretty damn well.

I've noticed that it only happens when it is cold. once the motor warms up the sound goes away.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Light Throttle Whistle / Whine - V6 / QuadraTrac I - With VIDEO Palmetto Trouble Shooting/Problems/Service 30 02-15-2012 03:40 PM
Whistle from front drivers pillar? gwnewman1 Trouble Shooting/Problems/Service 12 02-08-2012 12:34 AM
94 V8 ZJ stalls when accelerating please help! devzw3 Grand Cherokee - ZJ 6 09-14-2011 03:12 AM
Stall while accelerating (5.7L) justin1569 Trouble Shooting/Problems/Service 13 04-01-2011 01:43 PM
3.6 slight whistle on acceleration jeepin4ever Grand Cherokee - WK2 - 7 12-23-2010 10:16 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community