Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-06-2010, 01:29 PM
00wj's Avatar
Senior Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 1,077
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3081
00wj is a glorious beacon of light
wtf is going on???

last night i was on my way to a party... my radio,lights, and dash all go off and start on again as if i just started the car again. does this about ten times. i get to the parking garage and turn it off. i was in hurry so i said ill deal with it when i come back... i try to put the alarm and it does work at 1st,i try again it it works but sounds very weak. i decide to try to turn on the car and the key wouldnt even turn all the way to turn on the alarm is beeping the whole time but not the way its suppose 2. i open the hood and the alarm stop then close it and it starts again. as the alarm is going off my 2 map lights are flickering and my gauges are twitching. i had no idea what 2 do and didnt want to leave it beeping and acting weird so i open the hood again so it could stop beep and waited for a friend. i've been waiting 4 about 20 min and this guys offers me help and as i am show him the jeep starts working fine wtf. i was able to go the party and get home fine and everything seems to be working fine today except it seems to be driving diffrently i hit 5000+ rpm acclerating to 30 and i cant ever remember seeing that... idk if that beacuase what happen yesterday or im just starting to feel things differently lol
__________________

__________________
[SIGPIC][/SIGPIC] Hector
Reply With Quote
  #2  
Old 02-06-2010, 01:31 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113301
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: wtfis going on???

Weak Battery?
__________________

__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #3  
Old 02-06-2010, 02:23 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,419
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542700
robpp has disabled reputation
Re: wtf is going on???

i would second that escape.........check the battery.
__________________
Reply With Quote
  #4  
Old 02-06-2010, 02:56 PM
SinRG's Avatar
Member
 
Join Date: Jan 2010
Location: Santa Barbara, CA
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1831
SinRG is on a distinguished road
Re: wtf is going on???

I once experienced very similar aberrant behavior out of my 2000 WJ (gauges flipping out, car losing power, etc) and ended up having it towed to a dealership. The service tech there was really cool about it and basically told me it's most likely the battery and it would be expensive to have them replace it. So, I went out and bought a battery from another store and replaced it right there in the dealer's parking lot. Everything worked fine afterward.
__________________
Reply With Quote
  #5  
Old 02-06-2010, 04:34 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12438
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: wtf is going on???

any update ?
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #6  
Old 02-06-2010, 06:01 PM
00wj's Avatar
Senior Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 1,077
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3081
00wj is a glorious beacon of light
Re: wtf is going on???

Quote:
Originally Posted by SinRG View Post
I once experienced very similar aberrant behavior out of my 2000 WJ (gauges flipping out, car losing power, etc)
sounds just like what happen 2 me

just wondering... is it possible that the bolt that holds the battery was too tight because now that i remember... right before that guy tried to help me i had loosened up the battery up a bit and the jeep hasnt done anything wrong today.
__________________
[SIGPIC][/SIGPIC] Hector
Reply With Quote
  #7  
Old 02-06-2010, 07:07 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255446
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: wtf is going on???

same thing happened to me in my old WJ, it is the battery
__________________
Reply With Quote
  #8  
Old 02-07-2010, 04:12 PM
00wj's Avatar
Senior Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 1,077
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3081
00wj is a glorious beacon of light
Re: wtf is going on???

I now have a new battery and everything seems to be running smoothly

Thanks for all your help!
__________________
[SIGPIC][/SIGPIC] Hector
Reply With Quote
  #9  
Old 02-07-2010, 06:05 PM
00wj's Avatar
Senior Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 1,077
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3081
00wj is a glorious beacon of light
Re: wtf is going on???

soo... i thought everything was working fine... but its not. my turn signal arnt working along with my reverse light. wtf? is this a battery/fuse/relay problem or what?
__________________
[SIGPIC][/SIGPIC] Hector
Reply With Quote
  #10  
Old 02-07-2010, 07:07 PM
Chuck's Avatar
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Jun 2009
Location: Queens, NY
Posts: 3,869
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 5884
Chuck has a reputation beyond reputeChuck has a reputation beyond repute
Re: wtf is going on???

Quote:
Originally Posted by 00wj View Post
soo... i thought everything was working fine... but its not. my turn signal arnt working along with my reverse light. wtf? is this a battery/fuse/relay problem or what?
Did you change out your signals? If so, it has to be the fuses.
__________________
2004 Jeep Grand Cherokee Special Edition 4.0
Quote:
Originally Posted by White WK Swagga View Post
I'm here, and I like black jeeps!!!
Reply With Quote
  #11  
Old 02-07-2010, 07:17 PM
mon_21's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Chantilly, Virginia
Posts: 1,165
Thanks: 1
Thanked 11 Times in 8 Posts
Rep Power: 69161
mon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond repute
Re: wtf is going on???

Check fuse first, then replace if need be.....then check ur battery cable wires...not the connectors that goes to the terminal....but the wires itself.
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #12  
Old 02-07-2010, 11:24 PM
00wj's Avatar
Senior Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 1,077
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 3081
00wj is a glorious beacon of light
Re: wtf is going on???

Quote:
Originally Posted by Chuck View Post
Did you change out your signals? If so, it has to be the fuses.
yes i did and i check the hazzard fuses, parking, and rear fogs and they were all fine.
__________________

__________________
[SIGPIC][/SIGPIC] Hector
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FINALLY....wtf CatMan879 Grand Cherokee - WK 6 08-02-2009 08:45 PM
Tpms wtf NHWK05 Grand Cherokee - WK 22 07-21-2009 05:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.