Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-03-2013, 01:05 AM
New Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Austin, TX
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
PeteG45 is on a distinguished road
Yet another defrost only question

I apologize for bringing this issue up again but the previous posts that I have fond are confusing me.

I have a 2004 Grand Cherokee SE with the 6 cylinder engine. It has manual AC controls (not any kind of multi zones or climate control).

Recently the heat, vent and AC starting working from only the defrost vents. I can mix hot and cold air and the AC does chill the air but it will only come out of the defroster vents.

My cruise control does work normally.

Much of what I have read indicates that this might be a vacuum line issue. Some of what I've read indicated that it could only be a vacuum line issue if the cruise was also broken. I have visually inspected all of the hose connections coming from the rear most port on the intake manifold, going across the top of the engine and then running up under the battery platform.

Could this indeed be a vacuum leak if the cruise control still works?

If it could still be a vacuum leak is there a systematic method for determining the location of the leak?

Lastly (and I apologize for the length) the hose fitting that connects to that rear most port on the intake manifold is kind of loose (pulls off easily), how tight should it be and could that be the issue?

Thanks for any answers that you can provide.
__________________

__________________
Reply With Quote
  #2  
Old 02-03-2013, 05:40 PM
New Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Austin, TX
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
PeteG45 is on a distinguished road
Re: Yet another defrost only question

I figured it out.

Yes it was a vacuum leak and yes the cruise worked even though this pretty significant leak existed.

I just traced the vacuum line from the intake manifold out until I found the breech. It was between the tee and the firewall.

The fitting at the intake manifold is not as tight as I would like but with the leak fixed everything works as desired.

Big thanks to Autozone on Burnet Rd for providing 1 1/2" of small vacuum hose to splice the existing vacuum line.
__________________

__________________
Reply With Quote
  #3  
Old 02-03-2013, 10:57 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,794
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Yet another defrost only question

Seems that the hose at the intake manifold gets a bit loose after time. You could just replace it for a better fitting one, to prevent future problems, or just wait until it comes loose once and then repair it.
The leaking vacuum hose happens a lot. Did you see what had caused it to start leaking?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 02-03-2013, 11:09 PM
New Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2013
Location: Austin, TX
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
PeteG45 is on a distinguished road
Re: Yet another defrost only question

The line appeared to have been struck by something relatively hard and straight. Maybe an overzealous oil changer hit it with a wrench or other tool. It definitely was not worn down, it was a clean cut into but not through.

Is it possible to replace just that section of hose from the intake manifold to the start of the harder, more rigid vacuum line?
__________________
Reply With Quote
  #5  
Old 02-04-2013, 06:32 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,794
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Yet another defrost only question

It should be possible yes, i heard from others that they did it.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
front defrost button issue SRT8BLK Trouble Shooting/Problems/Service 4 12-27-2012 11:44 AM
a/c only from defrost vents jrsummersill1 Troubleshooting/Problems 34 08-20-2012 12:58 PM
dual zone windshield defrost question.... 1200RT-P Trouble Shooting/Problems/Service 4 06-20-2011 01:36 PM
Side Mirror Defrost Indicator question Sir Bean Trouble Shooting/Problems/Service 15 11-10-2010 08:29 AM
A/C only coming out of defrost vents DLStryker Troubleshooting/Problems 19 07-21-2010 03:26 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community