Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > 2014+ Cherokee-KL

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2014, 07:58 PM
Member
My Jeep: 2014 3.2L KL
 
Join Date: Feb 2013
Posts: 251
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2437
NHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond repute
8.4A Nav Issue

I had Nav activated in my Cherokee this morning at the dealer and had some problems with it after. It loses GPS signal and then tells me I am miles away from where I am. Happened to me 2X's today.

It takes a good 15 minutes when you start up after it has been off a bit to acquire signal. Totally unacceptable. At one point the map had me going west in a town 15+ miles from where I actually was AND I was actually going east! A GPS should take no more than 30 seconds to a minute max to get signal.

I hope now that it has run a bit that this issue will go away. If not it is back to the dealer. When it did have signal it worked well at least. Have any of you experienced this issue? I hope it goes away or there is a flash or upgrade to fix it. If not Chrysler owes me $600.
__________________

__________________
Reply With Quote
  #2  
Old 02-12-2014, 09:11 PM
Premium Member
 
Join Date: Jun 2011
Posts: 78
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1197
Alphainfinity is on a distinguished road
Re: 8.4A Nav Issue

Yes , this a known issue on the 8.4a on all product lines. My ram 2500 has had the same intermittent issue. Dealer talked to the chrystler rep....no fix is available yet. Make sure you have the latest updates. Hopefully it gets fixed soon.
__________________

__________________
2013 Jeep Grand Cherokee SRT8 4x4
6.4L V8 MDS / 5 Speed
Mineral Grey
850W Harmon Kardon Sound
0-60 in under 5sec
Reply With Quote
  #3  
Old 02-12-2014, 09:40 PM
Member
My Jeep: 2014 3.2L KL
 
Join Date: Feb 2013
Posts: 251
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2437
NHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond reputeNHPATRIOT has a reputation beyond repute
Re: 8.4A Nav Issue

Quote:
Originally Posted by Alphainfinity View Post
Yes , this a known issue on the 8.4a on all product lines. My ram 2500 has had the same intermittent issue. Dealer talked to the chrystler rep....no fix is available yet. Make sure you have the latest updates. Hopefully it gets fixed soon.
Great.

Thanks.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my newest issue - NAV screen goes white nj newb Audio/Visual/Navigation 6 10-09-2013 01:50 PM
UGH...2012 radio/nav issue SRT Darth Vapor SRT Trouble Shooting/Problems/Service 2 06-22-2013 06:01 PM
Rec Nav radio issue darwood Audio/Visual/Navigation 7 10-29-2011 03:04 PM
RB1 Nav/Radio issue WJDave Troubleshooting/Problems Discussion 0 04-09-2011 07:01 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community