Towbar wiring causing flashing ODO - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > 2014+ Cherokee-KL

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-08-2016, 03:26 PM
nzoliver's Avatar
Member
My Jeep: 2015 3.2L KL
 
Join Date: Dec 2010
Location: Canterbury, New Zealand
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2178
nzoliver is on a distinguished road
Send a message via ICQ to nzoliver Send a message via MSN to nzoliver
Exclamation Towbar wiring causing flashing ODO


Morning all from New Zealand!:wink:
Well, we (me and the dealers) discovered that with our factory fitted towbar wiring, after the third startup with the trailer connected the odometer flashes. We get the rear park sensor 'service' required' message up but that is the 'usual' according to the dealer and would be so as the cabling disconnects the power to the module rather than sending a signal to the computer to disable it. :|
We tried on 3 different KLs in the workshop and all did the same. Seems that nobody noticed except me!!!:nerd:
I wonder if this happens with the US and Euro versions of the interface unit?

Oliver:laugh:

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-19-2016, 01:04 AM
SeaComms's Avatar
Member
 
Join Date: Jul 2012
Posts: 90
Thanks: 42
Thanked 13 Times in 10 Posts
Rep Power: 1693
SeaComms is on a distinguished road
Re: Towbar wiring causing flashing ODO

Hmm.. doesnt do it on the Aus version (at least not mine). I have to turn off the park sensors when reversing with the van to stop it beeping all the time.
Reply With Quote
  #3  
Old 03-19-2016, 01:22 AM
nzoliver's Avatar
Member
My Jeep: 2015 3.2L KL
 
Join Date: Dec 2010
Location: Canterbury, New Zealand
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2178
nzoliver is on a distinguished road
Send a message via ICQ to nzoliver Send a message via MSN to nzoliver
Exclamation Re: Towbar wiring causing flashing ODO



Hi, Is yours dealer fitted? The dealers in Oz and NZ use a switch in the sockets to kill the power to the park sensors and this is what causes the flashing odo. The BCU senses there is a module missing and causes the odo to flash. The way they are done here compared to the US versions is odd to say the least.

Reply With Quote
  #4  
Old 03-19-2016, 01:26 AM
SeaComms's Avatar
Member
 
Join Date: Jul 2012
Posts: 90
Thanks: 42
Thanked 13 Times in 10 Posts
Rep Power: 1693
SeaComms is on a distinguished road
Re: Towbar wiring causing flashing ODO

Acording to the wiring diagrams the US version has a pair of connectioms that short out telling the computer a trailer is connected.

Mine is the Chrysler Aust provided Best Bars (NZ) tow bar and chrysler branded wiring loom - all just plug and play with the factory fitted lights controller behind the RHS tail light.
Reply With Quote
  #5  
Old 03-19-2016, 01:38 AM
nzoliver's Avatar
Member
My Jeep: 2015 3.2L KL
 
Join Date: Dec 2010
Location: Canterbury, New Zealand
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2178
nzoliver is on a distinguished road
Send a message via ICQ to nzoliver Send a message via MSN to nzoliver
Exclamation Re: Towbar wiring causing flashing ODO

Quote:
Originally Posted by SeaComms View Post
Acording to the wiring diagrams the US version has a pair of connectioms that short out telling the computer a trailer is connected.

Mine is the Chrysler Aust provided Best Bars (NZ) tow bar and chrysler branded wiring loom - all just plug and play with the factory fitted lights controller behind the RHS tail light.

Howdy, Mine's the same - dealer fitted etc. On NZ and Oz units the computer isn't 'shorted' it has the park module at the rear's power disconnected via a magneticaly operated reed switch in the socket. As soon as you open the socket you can see the magnet in the middle. Kinda crude. Just wondered how the US version of the module is done. Won't be like ours! The odo flashes after the 3rd start. Nobody noticed it even at the dealers until I pointed it out to them!!! Have now mentioned no lights without the keys in on yer trailer!!! I kinda pissed about simple stuff they shouldn't be getting wrong.

I found the part # and it is different by a long way!

Oliver

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Towbar and Long Range Tank fittment lynrick New Members - Welcome! 0 06-21-2014 06:08 AM
New Member from Gold Coast Australia. Towbar issues. Jay Prothero Wrangler-YJ, TJ & JK 1 11-20-2012 02:04 AM
Factory towbar question Matty470 Export Grand Cherokee 2011+ 20 05-29-2012 02:35 AM
Looking for towbar install info K9jackie Wrangler-YJ, TJ & JK 0 03-17-2011 01:51 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.