Uconnect 5in radio not working - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > 2014+ Cherokee-KL

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-26-2015, 01:28 AM
New Member
 
Join Date: Oct 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
bill_tong is on a distinguished road
Uconnect 5in radio not working

My radio no longer works, just shows a black screen with the back light on. Ive done a soft reset holding mute and tune, but no luck.

Anyone experience something similar or have a solution? How can i hard reset it?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-26-2015, 03:49 PM
Jeepster910's Avatar
Premium Member
My Jeep: 2014 3.2L KL
 
Join Date: Nov 2013
Location: West central illinois
Posts: 246
Thanks: 26
Thanked 24 Times in 22 Posts
Rep Power: 1532
Jeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond reputeJeepster910 has a reputation beyond repute
Re: Uconnect 5in radio not working

Quote:
Originally Posted by bill_tong View Post
My radio no longer works, just shows a black screen with the back light on. Ive done a soft reset holding mute and tune, but no luck.

Anyone experience something similar or have a solution? How can i hard reset it?
Call the dealer.
They are the ones that cover it under the 3/36 warranty.


Could be a simple as a ground wire.
__________________
2014 Cherokee Limited
V6 w/AD2
Tech Group
Luxury Group
Tow Group
Navigation
Reply With Quote
Reply

Tags
uconnect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Uconnect phone not working all of a sudden... tank47 Trouble Shooting/Problems/Service 51 05-20-2016 07:12 AM
Uconnect not working jkt009 Troubleshooting/Problems 5 03-19-2016 07:06 PM
Uconnect / Vocie Command Not Working zeepiegirl Troubleshooting/Problems Discussion 1 01-13-2012 12:37 AM
430 RBZ Voice Command and Uconnect Phone button not working Angel Audio/Visual/Navigation 8 01-17-2011 02:10 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.