Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-08-2014, 10:14 AM
Member
 
Join Date: Jan 2014
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 280
Wiley75 is on a distinguished road
2014 WK2 3.0 so far NOT so good

2014 Overland, Diesel, Quadra-Drive II, Adv Tech.

First trip. 138 miles on the odometer. Driving over a mountain pass. The transmission heat shield/cover plate partially fell off and started slamming off the highway and against the bottom of the vehicle. Had to have a tow truck come and get it as I didn't have any tools in the vehicle yet. Ordered new parts with Jeep dealer under warranty.

Second trip. 171 miles on the odometer. All packed up with wife, dogs and a bunch of gear for a weekend trip out of town. Left Friday night. On freeway on-ramp and EVIC beeps and says "service four wheel drive system" and "service air suspension system". Then the EVIC goes absolutely bonkers. Warning lights for ABS and Traction Control. Check Engine light. Vehicle goes in and out of limp mode. Occasionally the brake lights will turn themselves on and won't turn off..... even if the vehicle is just sitting there parked and not running. The EVIC also flickers.

Wow. A $54,000 vehicle with 171 miles on it and already been on a tow truck once and ruined a family outing trip. Not sure I'm impressed with this thing.

As I understand it my vehicle does not apply for the P58 reflash issue. It's too new. But the symptoms sure sound similar?

Sorry. Just had to vent a bit.
__________________

__________________
Reply With Quote
  #2  
Old 03-08-2014, 12:57 PM
Member
 
Join Date: Oct 2011
Location: Chandler, AZ
Posts: 320
Thanks: 2
Thanked 10 Times in 9 Posts
Rep Power: 1863
rubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond reputerubicontrail.net has a reputation beyond repute
Re: 2014 WK2 3.0 so far NOT so good

Quote:
Originally Posted by Wiley75 View Post
2014 Overland, Diesel, Quadra-Drive II, Adv Tech.

First trip. 138 miles on the odometer. Driving over a mountain pass. The transmission heat shield/cover plate partially fell off and started slamming off the highway and against the bottom of the vehicle. Had to have a tow truck come and get it as I didn't have any tools in the vehicle yet. Ordered new parts with Jeep dealer under warranty.

Second trip. 171 miles on the odometer. All packed up with wife, dogs and a bunch of gear for a weekend trip out of town. Left Friday night. On freeway on-ramp and EVIC beeps and says "service four wheel drive system" and "service air suspension system". Then the EVIC goes absolutely bonkers. Warning lights for ABS and Traction Control. Check Engine light. Vehicle goes in and out of limp mode. Occasionally the brake lights will turn themselves on and won't turn off..... even if the vehicle is just sitting there parked and not running. The EVIC also flickers.

Wow. A $54,000 vehicle with 171 miles on it and already been on a tow truck once and ruined a family outing trip. Not sure I'm impressed with this thing.

As I understand it my vehicle does not apply for the P58 reflash issue. It's too new. But the symptoms sure sound similar?

Sorry. Just had to vent a bit.
For the second issue, it may be a bad electrical ground.
__________________

__________________
2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited: Photos & Specifications
Reply With Quote
  #3  
Old 03-08-2014, 05:19 PM
fun2drive's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Florida Panhandle/ Ohio
Posts: 493
Thanks: 14
Thanked 25 Times in 20 Posts
Rep Power: 1152
fun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond repute
Re: 2014 WK2 3.0 so far NOT so good

Sorry to hear of your issues. This isn't how most of us experience the JGC diesel. It certainly starts to sour your impression and I can understand that.
All I can say is that my limited experience with the dealer in my area was super. I hope they have someone that can get this straightened out as it does sound like a connector or two issue. Shield coming off is just plain wrong that should never happen given QC but things slip through.
Here is hoping they get you going again soon. I am thrilled with mine, excellent mileage, very enjoyable to drive and on and on...
__________________
Overland Deep Cherry Red/ LT Biege Inter/ Diesel/ ATG
Reply With Quote
  #4  
Old 03-08-2014, 06:51 PM
Member
 
Join Date: Jun 2013
Location: Washington
Posts: 250
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 1122
crabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond repute
Re: 2014 WK2 3.0 so far NOT so good

Another possibility is you damaged some wiring with the loose skidplate banging around. They will probably find the fault when they scan but if not the general area might be worth a visual inspection.
__________________
2014 Diesel Grand Cherokee
Reply With Quote
  #5  
Old 03-08-2014, 07:06 PM
Member
 
Join Date: Jan 2014
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 280
Wiley75 is on a distinguished road
Re: 2014 WK2 3.0 so far NOT so good

Thanks.

Of course, today when I took it into the dealer it didn't act up. No fault lights or EVIC messages. But it did keep "chiming" at him when they drove it for no apparent reason. And the check engine light remained on. Dealer said they pulled two full pages of stored fault codes off of it however. Seemingly everything went wrong at once (obviously some type of electrical issue).

Dealer has it today and requested permission for the shop foreman to drive it home tonight, (he lives 40+ miles from the shop) drive it for Sunday, and drive it back in to the dealer on Monday. He'll likely put 100-150 miles on it. Kinda weird having a total stranger drive my 171 miles old $54,000 SUV around, but then again, I have to allow them the access to the vehicle that they need to properly diagnose and fix.

Suspicion is that it is some type of issue on the CAN bus system. One module on the system is likely corrupted causing all devices on the network to "freak out."

I'm a long time foreign car guy. I drive 50,000 miles a year and usually buy Honda's because they are crazy reliable and have great resale. This time I went on a limb and bought American with this vehicle. I really hope this JGC diesel doesn't turn out to be a huge pile of sh*t.
__________________
Reply With Quote
  #6  
Old 03-09-2014, 04:11 PM
Premium Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Oct 2013
Location: Tucson, AZ
Posts: 224
Thanks: 40
Thanked 31 Times in 21 Posts
Rep Power: 645
mtnmerlin has a reputation beyond reputemtnmerlin has a reputation beyond reputemtnmerlin has a reputation beyond reputemtnmerlin has a reputation beyond reputemtnmerlin has a reputation beyond repute
Re: 2014 WK2 3.0 so far NOT so good

My two cents:

Others who have had a bunch of errors had a loose battery cable or fuses not fully plugged in.

These are complicated vehicles with lots of stuff that can break or give errors. I have received two errors. One went away after turning the engine off and on twice (a shifter error). The other error (exhaust) went away after I reset it with an OBDII device. I recommend getting an OBDII device and an App (I use the Torque App on my phone) so you can view and reset errors.

I have added some shielding underneath to help protect exhaust components. A couple owners have already had exhaust failures caused by rocks or snow. If you look underneath a couple feet behind the right-front tire, you will see cables, hoses, and injector that look rather vulnerable.

My last 3,000 miles have been trouble free. That includes 1,200 miles towing a 3,000 lb trailer, and quite a bit of off-roading.
__________________
Current rides: 1995 ZJ Laredo 5.2L up-country 109K mi
2014 WK2 Limited 4x4 3.0L ORAII Cashmere Pearl diesel
Reply With Quote
  #7  
Old 03-11-2014, 08:31 PM
Rumline's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2011
Location: Los Angeles, CA
Posts: 259
Thanks: 67
Thanked 33 Times in 22 Posts
Rep Power: 1369
Rumline has a reputation beyond reputeRumline has a reputation beyond reputeRumline has a reputation beyond reputeRumline has a reputation beyond reputeRumline has a reputation beyond reputeRumline has a reputation beyond repute
Quote:
Originally Posted by mtnmerlin View Post
I have added some shielding underneath to help protect exhaust components. A couple owners have already had exhaust failures caused by rocks or snow. If you look underneath a couple feet behind the right-front tire, you will see cables, hoses, and injector that look rather vulnerable.
What kind of material did you use and how did you attach it?
__________________

2014 Overland Ecodiesel 4x4 - Adv. Tech - ORA2

Reply With Quote
  #8  
Old 03-12-2014, 08:30 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1037
Aeroguy is on a distinguished road
Re: 2014 WK2 3.0 so far NOT so good

If mine had those issues at 171 miles, I'd demand a replacement vehicle.
__________________
2012 Overland Summit QD2 Mineral Gray Metallic (traded in).

2014 Overland Diesel Black/Black QDII, Tech package.
Reply With Quote
  #9  
Old 03-12-2014, 10:03 PM
Member
 
Join Date: Jan 2014
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 280
Wiley75 is on a distinguished road
Re: 2014 WK2 3.0 so far NOT so good

Quote:
Originally Posted by Aeroguy View Post
If mine had those issues at 171 miles, I'd demand a replacement vehicle.
I emailed my sales guy about it but SURPRISE no response. At least I've got it documented with them.

The dealership that is working on it (not where I bought it) kept it for a couple of days and drove it for 110 miles. They could not replicate the problem (of course, because Murphy's law always prevails). They checked several issues that other dealers had suggested on some type of dealer knowledge network. The service report says they checked several electrical connections, ground points, sensors, wire harness rub thru areas, etc. They found nothing. So they gave it back.

Yesterday I drove it 200 miles with no issues.

Problem is, most electrical problems like that don't fix themselves. I really wish the dealer had found a smoking gun so to speak. Now I don't trust the damn thing. Sooner or later it'll do it again. And going into limp mode on the freeway isn't fun, or safe
__________________
Reply With Quote
  #10  
Old 03-12-2014, 10:15 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2013
Location: Conway,SC
Posts: 35
Thanks: 2
Thanked 2 Times in 2 Posts
Rep Power: 333
dsent is on a distinguished road
Re: 2014 WK2 3.0 so far NOT so good

Sorry to hear of your problems.

The trouble with intermittent problems is just that they are intermittent.

Its actually better and easier to fix if it breaks all the way!!

The true only way to tell unfortunately if an intermittent is fixed, is time with out a break down.

Hope you get it worked out.

Check into your lemon laws, I think most states the dealer gets 3 tries to repair the same item,then you can start the lemon law process.

I have had to go this route with another MFG and I won the process.
__________________
Regards
Don

Due to economic hard times the light at the end of the tunnel will be turned off until further notice!!!!!
Reply With Quote
  #11  
Old 03-12-2014, 10:38 PM
fun2drive's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Florida Panhandle/ Ohio
Posts: 493
Thanks: 14
Thanked 25 Times in 20 Posts
Rep Power: 1152
fun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond repute
Re: 2014 WK2 3.0 so far NOT so good

It could well be in the process of connecting an disconnecting the a lot of connectors the problem may be corrected. It is hard to understand but hope that is the case. I know how lack of confidence in a ride is a real disappointment.

I had a brand new Malibu that would just shut off driving down the interstate or in town. Dealer never resolved the problem and I sold the car. If you think limp mode is bad try total power loss no lights nothing at nite driving down an interstate...
__________________
Overland Deep Cherry Red/ LT Biege Inter/ Diesel/ ATG
Reply With Quote
  #12  
Old 03-13-2014, 09:28 AM
wraab's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 183
Thanks: 14
Thanked 4 Times in 4 Posts
Rep Power: 459
wraab is on a distinguished road
Re: 2014 WK2 3.0 so far NOT so good

*knock on wood* so far my CRD has been "great" @ 2400 miles.

Yes there are some annoyances, but nothing like what's going on in here.

I do have a rattle in the front driver side that I hear when I hit a bump. Not sure I want to have the dealer look at it as if I've learned one thing, 95% of the time, the dealer makes those problems worse.

Otherwise, my black beauty/black thunder has been a joy. It was great taking the 6 hour drive to hot springs last month.
__________________

__________________
Reply With Quote
Reply

Tags
2014, 2014 wk2, wk2

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Overland so far so good jp467 Trouble Shooting/Problems/Service 7 07-26-2013 05:05 PM
Is the WK2 a good booty car? andyh Grand Cherokee - WK2 - 27 09-19-2011 02:23 PM
For anyone who has ordered a 2012 WK2 SRT8... GOOD NEWS! Milous Grand Cherokee SRT - WK2 31 07-10-2011 05:17 PM
Tires WK2 - OEM Good or Swapping to better? Dougcjohn Suspension/Driveline/Brakes/Wheels/Tires 16 03-06-2011 09:36 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community