Anybody else on their second replacement CAT? - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-14-2016, 11:14 AM
w2kdiesel's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Framingham, MA
Posts: 51
Thanks: 35
Thanked 6 Times in 4 Posts
Rep Power: 1319
w2kdiesel is on a distinguished road
Anybody else on their second replacement CAT?

My first replacement was installed last June @ 34,000 miles. After some more issues and sensor replacements in February- another MIL in May resulted in my second replacement CAT and sensors @ 48,000 miles.

I'm just wondering if others have had this experience yet - and if it is an indication that the problem has yet to be solved.


Sent from my iPad using JeepGarage

__________________
Ordered 9/8/13 - 2014 Limited 4X4 Eco Diesel | Cashmere Pearl | Black/Lt Frost Beige | Luxury Group II | ORA II | Advanced Tech Group | Engine Block Heater | Nav

Weekend Ride: 1980 International Scout II Diesel - The 1st American Diesel SUV (although it has a Nissan engine)
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-14-2016, 12:37 PM
Member
 
Join Date: Jun 2014
Posts: 45
Thanks: 7
Thanked 10 Times in 7 Posts
Rep Power: 1021
timmy_ is on a distinguished road
Re: Anybody else on their second replacement CAT?

Quote:
Originally Posted by w2kdiesel View Post
My first replacement was installed last June @ 34,000 miles. After some more issues and sensor replacements in February- another MIL in May resulted in my second replacement CAT and sensors @ 48,000 miles.

I'm just wondering if others have had this experience yet - and if it is an indication that the problem has yet to be solved.


Sent from my iPad using JeepGarage
I believe they had at least two different versions of the cat upgrade. Depending on when your cat was replaced, it may have been the first revision?
Reply With Quote
  #3  
Old 06-14-2016, 12:46 PM
w2kdiesel's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Framingham, MA
Posts: 51
Thanks: 35
Thanked 6 Times in 4 Posts
Rep Power: 1319
w2kdiesel is on a distinguished road
Re: Anybody else on their second replacement CAT?

They both had the same part number ending in AB - which I think indicates the revised CAT


Sent from my iPad using JeepGarage
__________________
Ordered 9/8/13 - 2014 Limited 4X4 Eco Diesel | Cashmere Pearl | Black/Lt Frost Beige | Luxury Group II | ORA II | Advanced Tech Group | Engine Block Heater | Nav

Weekend Ride: 1980 International Scout II Diesel - The 1st American Diesel SUV (although it has a Nissan engine)
Reply With Quote
  #4  
Old 06-14-2016, 01:46 PM
Member
 
Join Date: Apr 2014
Posts: 60
Thanks: 5
Thanked 9 Times in 8 Posts
Rep Power: 1646
Kidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond reputeKidd_Funkadelic has a reputation beyond repute
Re: Anybody else on their second replacement CAT?

Quote:
Originally Posted by w2kdiesel View Post
They both had the same part number ending in AB - which I think indicates the revised CAT


Sent from my iPad using JeepGarage
Man I hope this issue is resolved for the '15s. I put the GDE tune on mine pretty quickly and would hate to have to fork over $$$ for a new cat, as I'm sure they would deny me warranty coverage...
Reply With Quote
  #5  
Old 06-15-2016, 03:18 PM
Member
 
Join Date: Jun 2011
Posts: 24
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 2105
Sasportas is on a distinguished road
Re: Anybody else on their second replacement CAT?

On my 3rd.

All cat sensors replaced 4 times.

Requiring P046/8 etc....

Drive off dealer lot and within 40 miles same thing.

They've tried 4 times to fix.

Refuse loaner/rental car.

At what point is this a lemon?


Sent from my iPhone using JeepGarage
Reply With Quote
  #6  
Old 06-15-2016, 10:42 PM
trance3's Avatar
Member
My Jeep: 2016 3.0L WK2
 
Join Date: Mar 2016
Location: Annapolis, MD
Posts: 109
Thanks: 52
Thanked 10 Times in 7 Posts
Rep Power: 446
trance3 is on a distinguished road
Re: Anybody else on their second replacement CAT?

Quote:
Originally Posted by Sasportas View Post
On my 3rd.

All cat sensors replaced 4 times.

Requiring P046/8 etc....

Drive off dealer lot and within 40 miles same thing.

They've tried 4 times to fix.

Refuse loaner/rental car.

At what point is this a lemon?


Sent from my iPhone using JeepGarage
I am assuming you have 2014.

You need to check your state lemon laws.
__________________
2016 Overland HA + Diesel + HK
Reply With Quote
  #7  
Old 06-16-2016, 08:32 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Posts: 350
Thanks: 29
Thanked 50 Times in 42 Posts
Rep Power: 20053
Stbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond repute
Re: Anybody else on their second replacement CAT?

Yep, but they jumped the gun to soon and put the same old revision back on.... Then when the recall came out... they put the latest one on. Both done in one day, no charge and neither one did any thing negative other than throw the P20EE code... Kept driving no problems till they got it in.
Had newest one for at least 10K miles and no issues since....
__________________
2014 JGC Summit CRD with rear seat ent. DOM's Plate. Pirelli Scorp Verde Plus tires. Otherwise bone stock...
2004 RAM 2500 Quad Cab Cummins... Owned since new. No Cat or SCR...
Reply With Quote
  #8  
Old 06-16-2016, 09:19 AM
fun2drive's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Florida Panhandle/ Ohio
Posts: 831
Thanks: 17
Thanked 102 Times in 79 Posts
Rep Power: 3517
fun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond repute
Re: Anybody else on their second replacement CAT?

My CAT has 16,000 miles since the change and 41,000 total. Got the CEL at 22,000 back at 25,000 when they changed it. Only thing other than reflashes I have had done. 2014 built 19 Dec 2013 hardly a lemon...


Sent from my iPhone using JeepGarage
__________________
Overland Deep Cherry Red/ LT Biege Inter/ Diesel/ ATG
Reply With Quote
  #9  
Old 06-17-2016, 10:34 AM
Member
 
Join Date: Mar 2016
Posts: 192
Thanks: 33
Thanked 39 Times in 28 Posts
Rep Power: 1327
Nordic1 has disabled reputation
Re: Anybody else on their second replacement CAT?

62,150 miles on my original CAT w/zero problems. 01 June 2014 build.
Reply With Quote
  #10  
Old 06-22-2016, 11:51 AM
Premium Member
 
Join Date: Apr 2013
Location: So. Florida
Posts: 74
Thanks: 7
Thanked 13 Times in 9 Posts
Rep Power: 1495
adw_tdi is on a distinguished road
Re: Anybody else on their second replacement CAT?

I'm on 3rd Cat as well. Similar to above, 1st cat went when I drove thru a puddle before having Dom's plate installed, and I suspect they replaced with non-revised version.

Recently, I have been getting a transient (as in pops-up and goes away after a few days) code to "Service DEF System - See Dealer". First time it happened I brought it in and they didn't have a friggin clue what was causing it. Even though I had about 20% DEF fluid in there, they upped it to 50% and the code vanished. Popped up again a week later, and dropped off on it's own in a few days.

I still love the capability my GC brings, but I will admit that I have been to the Jag dealer and am on a contact list for when they finally get the Diesel F-Pace in to drive...
__________________
OWN:
2017 Pacifica Limited Red Velvet/Alloy
2016 Renegade Trailhawk

Traded-in:
2014 Overland 4x4 Max Steel/Indigo EcoDiesel with ORAII - 45k miles 12/2013 --> 8/2016
SERIOUSLY CONSIDERING:
2017 F-Pace with 2.0 Diesel if/when they make it across the pond...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Borla does not show a cat back on their site BuckeyeSRT Engine Performance/Intakes/Exhausts 7 06-09-2013 08:57 AM
430N in 2013 wont play DVD...anybody else? slickrick Audio/Visual/Navigation 2 10-25-2012 10:03 PM
Anybody else have tranny issues? Panak Troubleshooting/Problems 5 09-14-2011 07:37 AM
Anybody else spiros Trouble Shooting/Problems/Service 5 04-21-2011 12:29 AM
QL Clunk - Anybody Else Hear It? jimoverland Trouble Shooting/Problems/Service 7 12-01-2010 08:15 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.