DEF Level - Gauge Messed Up? - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 12-14-2013, 06:54 PM
Member
 
Join Date: Dec 2013
Posts: 144
Thanks: 4
Thanked 24 Times in 21 Posts
Rep Power: 1576
Bounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond reputeBounty Hunter has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

Quote:
Originally Posted by candyman View Post
Are you using the remote start feature? I read elsewhere on this forum that the DEF gauge shows 0% when the vehicle is remotely started. I have not yet tried to confirm it.
This has been our experience, DEF reading of 0% when using remote start. Odd but predictable.

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 01-03-2014, 06:35 PM
Member
My Jeep: 2014 3.0L
 
Join Date: Nov 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1173
Buckle10 is on a distinguished road
I picked up my CRD last night. The sales person filled the DEF tank with 6.5 gallons. The gauge has sat at 25% since. I drove the Jeep about 190 miles today and throughout the gauge did not move. For people who have had this issue, does it resolve itself? What did you do? I have not used the remote start yet. Everything is with the vehicle has been perfect.
Reply With Quote
  #15  
Old 01-03-2014, 06:52 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,244
Thanks: 57
Thanked 10 Times in 10 Posts
Rep Power: 3718
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
def is like water it freezes.

Sent from my LG-P999 using Tapatalk 2
Reply With Quote
  #16  
Old 01-03-2014, 07:21 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 389
Thanks: 44
Thanked 87 Times in 53 Posts
Rep Power: 581761
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

Quote:
Originally Posted by hoffmanestates View Post
def is like water it freezes.

Sent from my LG-P999 using Tapatalk 2
DEF freezes below water freezing temp at about 12F (-11C). The Jeep has DEF tank heating system and temperature sensors to make sure this doesn't happen. Some users with a stuck DEF level indicated it released after a while and assumed it was a dry sensor that had DEF crystals around it. You might want to drive a bit before reporting it to the dealer.
__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
  #17  
Old 01-08-2014, 09:35 PM
Member
 
Join Date: Jan 2014
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1132
dorskh is on a distinguished road
Re: DEF Level - Gauge Messed Up?

hey guys! new owner here! after reading this thread i went back to the dealer today...i picked up the new ride yesterday. they put 4 gallons in...the level didnt change....drove 115 miles today, still didnt change...pulled into the dealer..he put another 2.5 gallons in...drove another 50 miles..still no change....The service manager is dumbfounded by it and wants to call me tomorrow to see if it changed......very odd if you ask me!
Reply With Quote
  #18  
Old 01-09-2014, 08:07 AM
Member
My Jeep: 2014 3.0L
 
Join Date: Nov 2013
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1173
Buckle10 is on a distinguished road
After about 2 days the gauge normalized for me and has been functioning properly since.
Reply With Quote
  #19  
Old 01-09-2014, 07:34 PM
Shannon's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: May 2013
Location: Lakeville, MN
Posts: 1,588
Thanks: 234
Thanked 223 Times in 143 Posts
Rep Power: 11548
Shannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

Quote:
Originally Posted by dorskh View Post
hey guys! new owner here! after reading this thread i went back to the dealer today...i picked up the new ride yesterday. they put 4 gallons in...the level didnt change....drove 115 miles today, still didnt change...pulled into the dealer..he put another 2.5 gallons in...drove another 50 miles..still no change....The service manager is dumbfounded by it and wants to call me tomorrow to see if it changed......very odd if you ask me!
DEF crystalizes as it dries. Give it a day or two for the new DEF to melt the crystals then you should be fine.
__________________
SFU: : 2016 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater - REPLACED: 2014 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater, with 2000 coats of paint



Current Rides:
2016 Jeep Grand Cherokee Overland Ecodiesel
2015 Cherokee Latitude (wife's ride)
2008 20' Four Winns bow rider speed boat
Reply With Quote
  #20  
Old 01-09-2014, 09:23 PM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 333
Thanks: 89
Thanked 42 Times in 34 Posts
Rep Power: 1465
wraab is on a distinguished road
Re: DEF Level - Gauge Messed Up?

I can verify the remote start and DEF sitting at 0%

Started normally and it was back to 100.
Reply With Quote
  #21  
Old 01-09-2014, 09:35 PM
Member
 
Join Date: Jan 2014
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1132
dorskh is on a distinguished road
Re: DEF Level - Gauge Messed Up?

good news...level went to 100 percent today! while i was at the dealer a Chrysler fuel systems engineer happened to be there and took a huge interest in this DEF issue. He had the service manager follow up with me about what i have read and experienced with the DEF..Sounds like a memo might be being sent to all dealers soon about it..
They told me that the levels show 0 when remote started because with the remote start all of the self vehicle checks do not activate, hence the showing of zero.
hope this helps!
Reply With Quote
  #22  
Old 01-10-2014, 07:35 PM
Member
 
Join Date: Jun 2013
Location: Washington
Posts: 253
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 1981
crabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

Mine is still at 100% with 2k miles, it has never left it whether remote started or not. Eventually I figure I'm going to have to do something about that...
__________________
2014 Diesel Grand Cherokee
Reply With Quote
  #23  
Old 01-11-2014, 06:46 AM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Cicero, NY
Posts: 545
Thanks: 76
Thanked 35 Times in 22 Posts
Rep Power: 1544876
CNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond reputeCNY_WK2 has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

Quote:
Originally Posted by crabman View Post
Mine is still at 100% with 2k miles, it has never left it whether remote started or not. Eventually I figure I'm going to have to do something about that...
Is the blue bar still all the way over....it will always have the 0 and 100. No digital number for current level.
__________________
In the Garage: 2014 JGC Overland - Deep Cherry Red - ATG

Reply With Quote
  #24  
Old 01-11-2014, 08:12 AM
Member
 
Join Date: Jun 2013
Location: Washington
Posts: 253
Thanks: 0
Thanked 24 Times in 17 Posts
Rep Power: 1981
crabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond reputecrabman has a reputation beyond repute
Re: DEF Level - Gauge Messed Up?

First I heard of a blue bar and I've never seen it. All I have is the arc but I'm now going to assume I should be seeing something like the economy display.

I'm going to have to change my position on this one. My gauge has shown empty all along. Lol
__________________
2014 Diesel Grand Cherokee
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need high def. pics of SRT's please! Scottina06 Grand Cherokee SRT - WK2 6 11-02-2013 01:12 PM
I messed up ibleedoil Trouble Shooting/Problems/Service 30 07-24-2013 06:48 PM
I think the dealer Messed w/my car. TimmyB Grand Cherokee - WK 10 04-03-2010 09:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:50 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.