Incorrect DEF - See dealer - Page 14 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #157  
Old 08-27-2014, 09:57 PM
mazster43's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2010
Location: Michigan
Posts: 343
Thanks: 64
Thanked 77 Times in 42 Posts
Rep Power: 72352
mazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond repute
Since the beginning of the year I've had the mil light with code P20EE several times. The first time the mil went out on its own in a couple days. The next couple I manually cleared. One time I actually got to the dealer before the mil went out to document it. Before I could get in for my scheduled repair appointment the mil went out and no code was stored so they did nothing. I've had both rev b and c of tsb 18-018 done on different dealer trips. Had the mil come on and code P20EE after tsb 18-018 rev c. To date I've not seen any message about wrong def or service def.

Reply With Quote
Sponsored Links
Advertisement
 
  #158  
Old 08-27-2014, 10:35 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 386
Thanks: 44
Thanked 86 Times in 52 Posts
Rep Power: 581712
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by mazster43 View Post
Had the mil come on and code P20EE after tsb 18-018 rev c.
Seems like Rev C got the DEF system to a tighter tolerance. I'm considering avoiding this update.
__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
  #159  
Old 08-28-2014, 07:00 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jul 2013
Posts: 158
Thanks: 2
Thanked 39 Times in 23 Posts
Rep Power: 1409
JEB1 is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by netboy View Post
Seems like Rev C got the DEF system to a tighter tolerance. I'm considering avoiding this update.

I wouldn't agree with that. New software immediately cleared my CEL, I was subsequently able to add 2.5 gallons of DEF I bought from Walmart, and I've driven for about 1100 miles since the upgrade with no issues.


Sent from my iPad using JeepGarage
Reply With Quote
  #160  
Old 08-28-2014, 04:49 PM
mazster43's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2010
Location: Michigan
Posts: 343
Thanks: 64
Thanked 77 Times in 42 Posts
Rep Power: 72352
mazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond repute
To add more confusion to this it does not look like I've used any def fluid in the last month. I'm still at just a little over a half tank . I will watch and see if I use any in the future. I just had a 700 mike highway road trip I've the weekend too.
Reply With Quote
  #161  
Old 08-28-2014, 05:03 PM
ExcursionDiesel's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2013
Location: W. TN.
Posts: 1,849
Thanks: 16
Thanked 284 Times in 196 Posts
Rep Power: 4022
ExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by mazster43 View Post
To add more confusion to this it does not look like I've used any def fluid in the last month. I'm still at just a little over a half tank . I will watch and see if I use any in the future. I just had a 700 mike highway road trip I've the weekend too.
Low DEF usage goes along with the chrystalizing DEF issue which clogs the injector and generates a P20EE. I think these problems are possibly all related to that.
__________________
----------------------
The founder of JeepGarage.org, Scottina06, has a son Max who is in need of corrective surgery from an infection at birth that left one leg 4 inches short. We need to support our Jeep brothers. His family has started a fund on giveforward.com. If you have ever been helped by someone else, now is a good time to pay it forward. Here is a link to that page. God bless you! http://gfwd.at/1rz33PW
Reply With Quote
  #162  
Old 08-28-2014, 05:18 PM
mazster43's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2010
Location: Michigan
Posts: 343
Thanks: 64
Thanked 77 Times in 42 Posts
Rep Power: 72352
mazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond repute
Quote:
Originally Posted by ExcursionDiesel View Post
Low DEF usage goes along with the chrystalizing DEF issue which clogs the injector and generates a P20EE. I think these problems are possibly all related to that.
Joy. That was my fear. Secretly I was hoping that rev b or c turned off the def system.
Reply With Quote
  #163  
Old 08-28-2014, 06:02 PM
ExcursionDiesel's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2013
Location: W. TN.
Posts: 1,849
Thanks: 16
Thanked 284 Times in 196 Posts
Rep Power: 4022
ExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by mazster43 View Post
Joy. That was my fear. Secretly I was hoping that rev b or c turned off the def system.
or at least turns off the "I refuse to restart" function. If I knew that the kill mode was disabled in the recent TSB, I'd drive mine anywhere anytime.

I just left the dealer (again) and made it to 121 miles with no CEL so far. My Torque App shows all DTCs passed on the current drive cycle...yay! All they did was reset the CEL fault and drive it 60 miles to observe a regen. The regen was due and has nothing to do with the SCR/DEF system but is related to DTC drive cycle tests. Man, my head is spinning trying to understand all the crap the WPA requires and why things happen on this thing.
__________________
----------------------
The founder of JeepGarage.org, Scottina06, has a son Max who is in need of corrective surgery from an infection at birth that left one leg 4 inches short. We need to support our Jeep brothers. His family has started a fund on giveforward.com. If you have ever been helped by someone else, now is a good time to pay it forward. Here is a link to that page. God bless you! http://gfwd.at/1rz33PW
Reply With Quote
  #164  
Old 08-28-2014, 06:43 PM
WoeIsMe's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: Austin, TX
Posts: 25
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1023
WoeIsMe is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by ExcursionDiesel View Post
or at least turns off the "I refuse to restart" function. If I knew that the kill mode was disabled in the recent TSB, I'd drive mine anywhere anytime.

I just left the dealer (again) and made it to 121 miles with no CEL so far. My Torque App shows all DTCs passed on the current drive cycle...yay! All they did was reset the CEL fault and drive it 60 miles to observe a regen. The regen was due and has nothing to do with the SCR/DEF system but is related to DTC drive cycle tests. Man, my head is spinning trying to understand all the crap the WPA requires and why things happen on this thing.
I hope your vehicle is now trouble free. Got a call from the dealer whom is unhappy about the survey I filled out. They justified waiting for the EGR valve because of a vacuum leak. I still don't know what the EGR valve has to do with low DEF usage and the P20EE code and of course the "Service DEF message'. Guess they didn't like me bringing up the 'Lemon Law'.
Reply With Quote
  #165  
Old 08-28-2014, 11:12 PM
ExcursionDiesel's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2013
Location: W. TN.
Posts: 1,849
Thanks: 16
Thanked 284 Times in 196 Posts
Rep Power: 4022
ExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond repute
Re: Incorrect DEF - See dealer

I'm at 165 miles since the last code reset and no new code yet.

Today my diesel tech was in training so I had another tech start a Star case and I called Jeep Customer Care And Started A File # and discussed buyback and Jeep Tech factory support involvement. I mentioned that I already qualify for my state's lemon law. A factory engineer was working with the local mechanic within 2 hours.

The mechanic was instructed to drive through a regen and a minimum of 60 miles. I got it back with 63 miles on it and no CEL after the reset.. Reading into the results prematurely, I wonder if the DTC onboard emissions test needs to see a regen cycle to permanently clear any codes and be happy. Only more driving will determine this. At this point, I would give good money for a manual that outlines DTC tests and diagnostic code behavior.

Maybe the clogged DEF injector and bad DEF pump was the only issue. We'll see because I'm going to run the wheels of of it tomorrow.
__________________
----------------------
The founder of JeepGarage.org, Scottina06, has a son Max who is in need of corrective surgery from an infection at birth that left one leg 4 inches short. We need to support our Jeep brothers. His family has started a fund on giveforward.com. If you have ever been helped by someone else, now is a good time to pay it forward. Here is a link to that page. God bless you! http://gfwd.at/1rz33PW
Reply With Quote
The Following User Says Thank You to ExcursionDiesel For This Useful Post:
  #166  
Old 08-29-2014, 07:22 AM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 386
Thanks: 44
Thanked 86 Times in 52 Posts
Rep Power: 581712
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by ExcursionDiesel View Post
I wonder if the DTC onboard emissions test needs to see a regen cycle to permanently clear any codes and be happy.
I believe you are mixing DTC's with Emissions Readiness Monitors. DTC's are "Diagnostic Trouble Codes". A single DTC causes all monitors to reset and require new qualification cycles. As long as you have a single active DTC (MIL/CEL is on) you won't be able to even start a driving cycle. I truly wish your vehicle to be trouble free now. I'm also an Engineer and your post of "All they did was reset the CEL fault and drive it 60 miles to observe a regen" made me cringe a little as I knew an engineer would never truly accept resetting a diagnostic tool as a problem resolution. The question I still have is why did you get a MIL after 90 miles of the problem being mechanically resolved? Can it be some residual issue that triggered it and just had to be driven through?
__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
  #167  
Old 08-29-2014, 10:02 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 386
Thanks: 44
Thanked 86 Times in 52 Posts
Rep Power: 581712
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: Incorrect DEF - See dealer

Not to hijack the thread, but you might want to U-turn back to the dealership. Yet another huge recall of ALL 2011-2014 WK's with illuminated visors. There's a thread about it in JeepGarage.
__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
  #168  
Old 08-29-2014, 11:14 PM
ExcursionDiesel's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2013
Location: W. TN.
Posts: 1,849
Thanks: 16
Thanked 284 Times in 196 Posts
Rep Power: 4022
ExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond reputeExcursionDiesel has a reputation beyond repute
Re: Incorrect DEF - See dealer

MIL set again with P20EE today....5 miles after a cold start at 170.3 miles. I reset it and it set again at 90 miles. Back to the dealer.
__________________
----------------------
The founder of JeepGarage.org, Scottina06, has a son Max who is in need of corrective surgery from an infection at birth that left one leg 4 inches short. We need to support our Jeep brothers. His family has started a fund on giveforward.com. If you have ever been helped by someone else, now is a good time to pay it forward. Here is a link to that page. God bless you! http://gfwd.at/1rz33PW
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rack Cross Bars - Thule Fit Guide incorrect K3LAG Interior/Exterior/Visual 24 06-10-2015 09:29 AM
Service DEF - See Dealer cwmccall 2014+ Jeep Grand Cherokee Ecodiesel 3.0 79 06-10-2014 12:52 PM
Outside temp incorrect banjonut Troubleshooting/Problems Discussion 6 06-28-2013 07:15 AM
Time Incorrect BobsWK2 Audio/Visual/Navigation 4 11-29-2011 10:22 AM
P0731 Gear 1 Ratio Incorrect jas535 Troubleshooting/Problems 1 08-14-2010 03:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.