Incorrect DEF - See dealer - Page 34 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Reply
 
Thread Tools Display Modes
 
  #397  
Old 01-06-2015, 06:39 PM
Member
 
Join Date: Feb 2014
Posts: 38
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 1265
FajitaMidland is on a distinguished road
Re: Incorrect DEF - See dealer

I have had my Jeep again with the dealership and they have had the vehicle for 1-1/2 weeks and they still don't know what to do. I told them that I knew what was wrong and handed them the TSB which calls for replacing the Catalyst.

I am sure though nothing will get done until Chrysler says so.

I wonder if Chrysler could be having the dealership install beta test versions of the software fixes in hopes of fixing it. Who knows.

I am hoping to have a definite answer on the solution by the end of the week.

Reply With Quote
Sponsored Links
Advertisement
 
  #398  
Old 01-09-2015, 04:25 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jan 2014
Location: Texas U.S.A.
Posts: 50
Thanks: 50
Thanked 10 Times in 5 Posts
Rep Power: 1303
WhelanFamilyJeep is on a distinguished road
Re: Incorrect DEF - See dealer

I just went through this with our 2014 EcoDiesel with a 12/13 build date. CEL came on with about 7,600 miles on it. My wife drives it primarily and it is mainly short trips back and forth to work and then some highway driving on the weekends with the family. The dealership flashed the ECU with an update (rev. D I believe) and sent me on my way. The next day, the CEL was back. Brought it back to the dealer with a copy of the TSB for the new cat in hand. They called me back the same day and said yup, I needed the new CAT. The new CAT arrived about a week and a half later. Unfortunately it was the day before we were leaving for a 4,000 mile road trip from Austin, TX to Pasadena, CA for the holidays. Drove the entire time with the CEL on and had no issues. I did notice that with the new flash, the amount of DEF being used seemed to increase. Part of this was also due to the extended highway driving I am sure, but we went from one tick below 1/2 tank to getting the 500 miles left warning just before we made it back home. The next day (Tuesday of this week) the dealer installed the new CAT, updated to rev. E and so far everything seems to be fixed. Fingers crossed! The dealer has been great to work with and besides this, the JGC has been an awesome vehicle and we have no regrets purchasing it.
Reply With Quote
The Following 2 Users Say Thank You to WhelanFamilyJeep For This Useful Post:
  #399  
Old 01-14-2015, 01:21 PM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 386
Thanks: 140
Thanked 71 Times in 53 Posts
Rep Power: 1676
wraab is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by wraab View Post
Check engine came on this morning on my way to office and so I pulled the code when I got home...good 'ol P20EE.

Granted I got the same code in mid-Aug and they were able to do a forced regen to clear...but I'm curious if my luck is going to run out considering all the issues people are having. I did notice that the P20EE code is listed in my OBDii as "permanent" ?

I guess I'll be calling the dealer to take it back in.
So just about a month later, I got the P20EE code...same thing. Pulled code, cleared pending codes, went to bed, and next day it was gone.

This will be the 3rd time. First time I took it in and the "fix" was a forced re-gen by the "techs".

So now I am contemplating taking it in and telling them this is 3 times and assume the cat needs replacing (although based on comments they will try a software fix first). I'm pretty close to my next oil interval so I may wait it out until then and then have them do it. They also have an RRT or two to do...although I'm not sure I want them taking off my DEF-PLATE to install zip ties. Don't have much confidence in their diesel techs.
Reply With Quote
Sponsored Links
Advertisement
 
  #400  
Old 01-14-2015, 03:53 PM
aboyce85's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Oklahoma
Posts: 79
Thanks: 2
Thanked 3 Times in 3 Posts
Rep Power: 1417
aboyce85 is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by wraab View Post
So just about a month later, I got the P20EE code...same thing. Pulled code, cleared pending codes, went to bed, and next day it was gone.



This will be the 3rd time. First time I took it in and the "fix" was a forced re-gen by the "techs".



So now I am contemplating taking it in and telling them this is 3 times and assume the cat needs replacing (although based on comments they will try a software fix first). I'm pretty close to my next oil interval so I may wait it out until then and then have them do it. They also have an RRT or two to do...although I'm not sure I want them taking off my DEF-PLATE to install zip ties. Don't have much confidence in their diesel techs.

My Jeep is in the shop now on it's 4th visit for the P20EE CEL, since there are no new flash updates out that they haven't already tried I'm hoping they fix the real problem this time! It's getting a little old and beyond frustrating!
Reply With Quote
  #401  
Old 01-14-2015, 04:50 PM
nookie's Avatar
Member
 
Join Date: Feb 2014
Posts: 341
Thanks: 3
Thanked 56 Times in 41 Posts
Rep Power: 6929
nookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond reputenookie has a reputation beyond repute
Garage
Re: Incorrect DEF - See dealer

3100 Miles since new cat converter and Software Rev "D"


No CEL yet.
(24500 Miles total)
Reply With Quote
  #402  
Old 01-14-2015, 08:11 PM
stoots's Avatar
Member
 
Join Date: Oct 2012
Location: Chicago Suburbs
Posts: 82
Thanks: 4
Thanked 7 Times in 6 Posts
Rep Power: 1811
stoots is on a distinguished road
Re: Incorrect DEF - See dealer

I only have about 1500 miles since the cat replacement and everything is running great. Now if could only get Uconnect for $5 a month 🙏


Sent from my iPhone using JeepGarage
Reply With Quote
  #403  
Old 01-14-2015, 09:44 PM
ROSKOE115's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2014
Location: Midland, Texas
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1025
ROSKOE115 is on a distinguished road
Re: Incorrect DEF - See dealer

Took mine to the dealer again this afternoon for the same issue (2nd time) and still can't do anything with it until next week. If it wasn't for my salesman it would have been February 28! Any how, they tried giving me a Dodge Dart to take on a few hundred mile trip tomorrow full of big body people to a funeral. So I will be taking my chances with the jeep and driving it. I'd rather have it in the ice than a dart any day. We will see what happens, they are all way to uneducated to be in the position they are in. They can't spell DPF as far as I can tell. I did talk to the salesman about them buying this pile back. He said since I technically bought it used at such a cheap price we may be able to trade evenly. Love the jeep but the reliability is a joke.


Sent from my iPhone using JeepGarage
__________________
2014 Jeep Grand Cherokee EcoDiesel 4X4 Overland
2002 Dodge 5.9 2500 2wd sport street/drag project

Reply With Quote
  #404  
Old 01-20-2015, 11:23 AM
Member
 
Join Date: Feb 2014
Posts: 38
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 1265
FajitaMidland is on a distinguished road
Re: Incorrect DEF - See dealer

Well I got my vehicle back today however they only replaced the DEF injector since it was clogged with crystals. My CEL usually comes on every 60 miles. So, I will know something by the end of the week. I pushed really hard to get them to replace the catalyst but I guess you have to go through these other steps first.
Reply With Quote
  #405  
Old 01-20-2015, 01:08 PM
Member
 
Join Date: Feb 2014
Posts: 38
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 1265
FajitaMidland is on a distinguished road
Re: Incorrect DEF - See dealer

Well I drove the vehicle from the dealership to the office and then to lunch. A total of 34 miles before the CEL came back on. I wasn't surprised at all.


At some point the dealership will get tired of me. I am pretty confident the next step is the Catalyst now. Keep your fingers crossed.
Reply With Quote
  #406  
Old 01-20-2015, 07:41 PM
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Jun 2014
Location: Aviano AB, Italy
Posts: 238
Thanks: 2
Thanked 28 Times in 25 Posts
Rep Power: 1337
volvite is on a distinguished road
Re: Incorrect DEF - See dealer

I took my sisters jeep in over Christmas and they did some TSBs and updated the computer but did not replace anything. At this time no CEL on her jeep but is still averaging only about 21.4mpgs.

Not sure if there is anything we can do at jeep without a CEL.
Reply With Quote
  #407  
Old 01-21-2015, 08:19 AM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 386
Thanks: 140
Thanked 71 Times in 53 Posts
Rep Power: 1676
wraab is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by wraab View Post
So just about a month later, I got the P20EE code...same thing. Pulled code, cleared pending codes, went to bed, and next day it was gone.

This will be the 3rd time. First time I took it in and the "fix" was a forced re-gen by the "techs".

So now I am contemplating taking it in and telling them this is 3 times and assume the cat needs replacing (although based on comments they will try a software fix first). I'm pretty close to my next oil interval so I may wait it out until then and then have them do it. They also have an RRT or two to do...although I'm not sure I want them taking off my DEF-PLATE to install zip ties. Don't have much confidence in their diesel techs.
And just for posterity - one week later, MIL for P20EE


Pulled/cleared/gone...we'll see how long it takes for it to come back. The time/mileage between codes is shrinking. Looks like I'll be going to the dealer sooner than I hoped. Chrysler!
Reply With Quote
  #408  
Old 01-21-2015, 08:34 AM
mazster43's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2010
Location: Michigan
Posts: 343
Thanks: 64
Thanked 77 Times in 42 Posts
Rep Power: 72557
mazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond reputemazster43 has a reputation beyond repute
Quote:
Originally Posted by wraab View Post

And just for posterity - one week later, MIL for P20EE

Pulled/cleared/gone...we'll see how long it takes for it to come back. The time/mileage between codes is shrinking. Looks like I'll be going to the dealer sooner than I hoped. Chrysler!
Mine progressed from coming on one a month to eventually every other day after clearing it. The new catalyst is the only fix
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rack Cross Bars - Thule Fit Guide incorrect K3LAG Interior/Exterior/Visual/Lighting 24 06-10-2015 08:29 AM
Service DEF - See Dealer cwmccall 2014+ Jeep Grand Cherokee Ecodiesel 3.0 79 06-10-2014 11:52 AM
Outside temp incorrect banjonut Troubleshooting/Problems Discussion 6 06-28-2013 06:15 AM
Time Incorrect BobsWK2 Audio/Visual/Navigation 4 11-29-2011 09:22 AM
P0731 Gear 1 Ratio Incorrect jas535 Troubleshooting/Problems 1 08-14-2010 02:59 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.