Incorrect DEF - See dealer - Page 37 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #433  
Old 02-05-2015, 09:37 PM
thebc2's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2013
Posts: 110
Thanks: 4
Thanked 15 Times in 14 Posts
Rep Power: 1284
thebc2 is on a distinguished road
Re: Incorrect DEF - See dealer

My saga continues. In short:

I have been dealing with good old P20EE for almost a year now. Going in for new flashes that would fix it for a period of time. It came to a head when I was due for my state inspection sticker back in November and it failed due to the code (emissions). I was given a reject sticker which was good for 2 months.

Since then, the Jeep has spent 2 weeks at the dealer while they flashed for the new TSB (I think I got the D revision), replaced my cat, and replaced my def injector. CEL gone, they send me on my way and tell me to stop back after 100 miles so the sensors that failed emissions with the state inspection computer could reset.

So I stop back in a week later, drove about 150 miles.

"Not reset yet, give it another week"

I come back in the following week after putting on another 250.

"Hmm still not reset, give it another week"

At this point it was around Christmas and I had a weeklong business trip I left for right after new year's. So I stopped back in around mid Jan, at this point I'd driven close to 1500 miles.

"Still not reset, I'll give Chrysler a call"

At this point, I'm a week away from my reject sticker from expiring. Finally got a call yesterday to drop her off as Chrysler wanted the tech to record some data while driving the Jeep to figure out why those sensors won't reset despite the fact that it hasn't thrown a CEL for the last 1500 miles. So, can't legally drive my Jeep until this is fixed.

Make sure to take note of your state inspection schedule and try to get this resolved well before you're due.

__________________
2014 JGC Overland EcoDiesel
Maximum Steel/Black
ORAII
Adv. Tech
Changes: 265/60/18 Goodyear Wrangler AT Adventure w/ Kevlar | Mopar Rock Rails | Weathertechs
Reply With Quote
Sponsored Links
Advertisement
 
  #434  
Old 02-05-2015, 11:43 PM
New Member
 
Join Date: Jul 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
matthappens is on a distinguished road
Re: Incorrect DEF - See dealer

You guys need to start hammering Chrysler. Lemon law in most states is 4 times for the same problem in the first 18mos or 18k miles. Or 30 days at the dealership for any reason.

They need to feel the pain ($$$) on this so they take some f'ing action. I'm one code away from dropping it off and about 7 days shy of the 30 days. The options are: get and new one, get your money back minus miles driven up the first occurrence, or cash and keep the car.

I've been through all the same Flash, Flash, TSB lines/injector, wait two weeks for a pump, wait for SCR. Problems resolved as of now. But my sanity and the amount of time I've spent screaming at Chrysler is absurd.

At one point they were going to wait for the pump, back ordered 2mos. I told them they were going to end up buying it back at 30 days and they just shrugged their shoulder. They just don't care.

Please. Do everyone a favor a hit them with the lemon law. The attorneys fees are covered by Chrylser. Itll light a fire under them and get things moving.
Reply With Quote
  #435  
Old 02-06-2015, 06:54 PM
thebc2's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2013
Posts: 110
Thanks: 4
Thanked 15 Times in 14 Posts
Rep Power: 1284
thebc2 is on a distinguished road
Re: Incorrect DEF - See dealer

Our lemon law here is only 1 year, missed it by a few weeks.

I actually got the call today that the Jeep was ready. They said while on a call with a Chrysler engineer that as they were logging, the sensors literally reset right in front of them. When they got back to the dealership they ran the state inspection on it and it passed. Only took ~2000 miles for them to reset...
__________________
2014 JGC Overland EcoDiesel
Maximum Steel/Black
ORAII
Adv. Tech
Changes: 265/60/18 Goodyear Wrangler AT Adventure w/ Kevlar | Mopar Rock Rails | Weathertechs
Reply With Quote
  #436  
Old 02-07-2015, 09:10 AM
Koko's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: Va Beach
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1206
Koko is on a distinguished road
Re: Incorrect DEF - See dealer

Had a new CAT installed in July at 6200 miles. I'm at 12700 now and just picked up the P20EE on the drive to work this morning. I did not get the redesigned CAT back in July, so this is hopefully not a repeat issue for everyone.


Sent from my iPhone using JeepGarage
Reply With Quote
  #437  
Old 02-07-2015, 05:28 PM
New Member
 
Join Date: Jul 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
matthappens is on a distinguished road
Incorrect DEF - See dealer

Quote:
Originally Posted by thebc2 View Post
Our lemon law here is only 1 year, missed it by a few weeks.



I actually got the call today that the Jeep was ready. They said while on a call with a Chrysler engineer that as they were logging, the sensors literally reset right in front of them. When they got back to the dealership they ran the state inspection on it and it passed. Only took ~2000 miles for them to reset...

I would double check with someone that knows it inside and out just incase. It should go from the first reported incident. Additionally, get on Chrylser to provide some goodwill ie extended warr. Etc... I was given the MaxCare as "goodwill."

Also, I was under the impression that this concern has been resolved by replacing the CAT (the newer part#.) I haven't had any issues since replacing via the TSB dated 11-21-14.

Are we still having on going issues post redesigned CAT?
Reply With Quote
  #438  
Old 02-08-2015, 11:48 PM
thebc2's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2013
Posts: 110
Thanks: 4
Thanked 15 Times in 14 Posts
Rep Power: 1284
thebc2 is on a distinguished road
Re: Incorrect DEF - See dealer

I haven't thrown a CEL since the new CAT and injector were installed. What was happening is that the emissions sensors that our state inspection computer checks wouldn't reset to a "ready" state which blocked me from getting my inspection sticker done. The dealer claimed it would take about 100 miles after the CEL cleared, but in my case it took close to 2000 miles.
__________________
2014 JGC Overland EcoDiesel
Maximum Steel/Black
ORAII
Adv. Tech
Changes: 265/60/18 Goodyear Wrangler AT Adventure w/ Kevlar | Mopar Rock Rails | Weathertechs
Reply With Quote
  #439  
Old 02-09-2015, 01:04 AM
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Jun 2014
Location: Aviano AB, Italy
Posts: 220
Thanks: 1
Thanked 27 Times in 24 Posts
Rep Power: 1158
volvite is on a distinguished road
Re: Incorrect DEF - See dealer

Sisters CEL came back on. This time when she went to the dealer went straight past the service desk and to the service manager. Sat and talked with him for about an hour. Told him all the crap she's been through with the CEL and the dealership's team not listening to her and the information we've provided them about the CEL. He opened up a star report with Chrysler and said he would do some research and get back to her. He called back within two hours and said the information we provided was correct and that they ordered a new CAT for her Jeep. Only problem now is like many others have stated they are all on back order. No expected date of delivery. At least this is a step in the right direction.
Reply With Quote
  #440  
Old 02-09-2015, 01:22 AM
Senior Member
 
Join Date: Sep 2013
Posts: 1,307
Thanks: 46
Thanked 164 Times in 132 Posts
Rep Power: 2871
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by matthappens View Post
Are we still having on going issues post redesigned CAT?
I have the same question, but isn't it too early to tell? How many miles did it take for the original cat/injectors to start throwing codes? Have people with new cats put on at least that much on the new hardware?

This is an interesting problem because I would have guessed my constant short hop in-city driving pattern would predispose my Jeep to risk of P20EE. However, 14,000 miles in and only one episode of DEF codes (P20E9 & P204F, not P20EE) has been thrown.

Of course, maybe P20EE is coming.
Reply With Quote
  #441  
Old 02-09-2015, 09:16 AM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1492
Morax is on a distinguished road
Re: Incorrect DEF - See dealer

Well, I am driving over to dealer to see what code is popping up ( MIL ), 10K miles...I'll have them replace the Air Filter at the same time, the seal is torn on one side... I hope it wont be the P20EE! If it is, I'm ready! LMAO...
Reply With Quote
  #442  
Old 02-09-2015, 12:28 PM
Member
 
Join Date: Feb 2014
Posts: 38
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 1104
FajitaMidland is on a distinguished road
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by Roadkill View Post
How many miles did it take for the original cat/injectors to start throwing codes? Have people with new cats put on at least that much on the new hardware?
I started having issues right around 3,000 miles - appox. four months after purchasing the vehicle. Purchased Feb. 13th, 2014 then on May 22nd P20EE came on. Lots of short trips and a few long trips. Initially P20EE would not appear on long drives and only on short trips. Drove to South Padre Island back 1200 miles with no P20EE code.

FYI - Still waiting for my CAT to arrive - maybe around Feb. 18th
Reply With Quote
  #443  
Old 02-09-2015, 03:06 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1492
Morax is on a distinguished road
Re: Incorrect DEF - See dealer

Update, Yeah well it was the P20EE code. Got the Rev E update, and just waiting for the code to come back before they can order the new CAT. Was told that many had the rev E update and the error never came back...all bets are on!
Reply With Quote
  #444  
Old 02-09-2015, 08:31 PM
GunninIt's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: California
Posts: 197
Thanks: 15
Thanked 9 Times in 5 Posts
Rep Power: 1717
GunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond repute
Re: Incorrect DEF - See dealer

Quote:
Originally Posted by Morax View Post
Update, Yeah well it was the P20EE code. Got the Rev E update, and just waiting for the code to come back before they can order the new CAT. Was told that many had the rev E update and the error never came back...all bets are on!
For what it's worth, Morax, I was in the same situation as yourself. No issues until nearly 7,000 miles - then bam. P20EE. I got the flash to RevE, and have since driven over 800 miles. No problems so far.

I think the update to RevE will solve SOME problems, but not all. The CAT likely WILL fail, and it's a matter of time, but I think it's solved some sensitivity issues. I just hope I'm not on the side of the road in the middle of nowhere when it fails.

For now: blissful ignorance of what's to come.
__________________
2014 GC Limited CRD Bright White/Black LuxII ORAII RA4



The 3.6 in my JKUR is like 6 drunk hamsters banging on bongos. -dugedug
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rack Cross Bars - Thule Fit Guide incorrect K3LAG Interior/Exterior/Visual 24 06-10-2015 09:29 AM
Service DEF - See Dealer cwmccall 2014+ Jeep Grand Cherokee Ecodiesel 3.0 79 06-10-2014 12:52 PM
Outside temp incorrect banjonut Troubleshooting/Problems Discussion 6 06-28-2013 07:15 AM
Time Incorrect BobsWK2 Audio/Visual/Navigation 4 11-29-2011 10:22 AM
P0731 Gear 1 Ratio Incorrect jas535 Troubleshooting/Problems 1 08-14-2010 03:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.