Just had the car serviced - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-27-2016, 09:55 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Melbourne, Australia
Posts: 321
Thanks: 39
Thanked 48 Times in 34 Posts
Rep Power: 1696
chocco is on a distinguished road
Just had the car serviced

As above asked them to investigate the brown sludge in the coolant tank.

No problem they said we just topped it up !!!

ForumRunner_20160128_145516.png

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-28-2016, 07:46 AM
Member
 
Join Date: Jul 2014
Posts: 247
Thanks: 21
Thanked 40 Times in 30 Posts
Rep Power: 1323
definn12 has disabled reputation
Quote:
Originally Posted by chocco View Post
As above asked them to investigate the brown sludge in the coolant tank.

No problem they said we just topped it up !!!
So from what I've heard from multiple resources, the sludge is normal and happens sometimes where the air meets the coolant. On another note, I'd be careful about overfilling the expansion tank. It looks like you're past the max mark. This stuff expands when it's hot and shrinks when it's cold, so if they topped off while it was hot, you might have issues. Just a friendly heads up.
Reply With Quote
  #3  
Old 01-28-2016, 07:53 AM
Member
My Jeep: 2015 3.6L WK2
 
Join Date: Jan 2015
Location: USA
Posts: 318
Thanks: 19
Thanked 62 Times in 47 Posts
Rep Power: 1216
perpster is on a distinguished road
Re: Just had the car serviced

Quote:
Originally Posted by definn12 View Post
So from what I've heard from multiple resources, the sludge is normal and happens sometimes where the air meets the coolant. On another note, I'd be careful about overfilling the expansion tank. It looks like you're past the max mark. This stuff expands when it's hot and shrinks when it's cold, so if they topped off while it was hot, you might have issues. Just a friendly heads up.
Agreed, else you may be posting about the brown sludge all over the engine compartment.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-28-2016, 07:57 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Posts: 470
Thanks: 43
Thanked 65 Times in 55 Posts
Rep Power: 25747
Stbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond reputeStbentoak has a reputation beyond repute
Re: Just had the car serviced

Kinda had the same issue but my coolant was dropping about a half inch every oil change/ 10K miles. When I asked them to look into it, they just filled it up each time and said "We'll monitor it"..... What does that fix?
__________________
2014 JGC Summit CRD with rear seat ent. DOM's Plate. Pirelli Scorp Verde Plus tires. Otherwise bone stock...
2004 RAM 2500 Quad Cab Cummins... Owned since new. No Cat or SCR..

On its way: 2018 Jaguar 20D Diesel F-Pace R sport for wifey...
Reply With Quote
  #5  
Old 01-28-2016, 08:06 AM
Member
 
Join Date: Jul 2014
Posts: 247
Thanks: 21
Thanked 40 Times in 30 Posts
Rep Power: 1323
definn12 has disabled reputation
Quote:
Originally Posted by Stbentoak View Post
Kinda had the same issue but my coolant was dropping about a half inch every oil change/ 10K miles. When I asked them to look into it, they just filled it up each time and said "We'll monitor it"..... What does that fix?
I'd check and see if you've got any oil in your coolant. Could be slipping by the oil cooler
Reply With Quote
  #6  
Old 01-28-2016, 09:45 AM
Swampy's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jul 2011
Location: Oakford, Western Australia
Posts: 765
Thanks: 3
Thanked 84 Times in 62 Posts
Rep Power: 35703
Swampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond repute
Re: Just had the car serviced

Sludge in the coolant expansion tank is symptomatic of incompatible coolant being used to top up the fluid.

My guess is that coolant other than the Mopar specified has been used.

If changing coolant brand or spec, the whole system must be drained, flushed and refilled. That is why it is nearly always best to strictly stay with OEM coolant. You would expect that the dealer would always use OEM products, but not always. Especially if they can save a dollar.
__________________
Regards

Swampy

JGC Overland CRD, Deep Cherry Red

"I'm just here for the biscuits!"
Reply With Quote
  #7  
Old 01-28-2016, 01:29 PM
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Tasmania
Posts: 108
Thanks: 0
Thanked 16 Times in 15 Posts
Rep Power: 722
tasjeep is on a distinguished road
Re: Just had the car serviced

I had that brown sludge, dealer didn't know why but flushed and cleaned the system and it hasn't returned.
I have checked a few others since then and most seem to have it.
Reply With Quote
  #8  
Old 01-28-2016, 01:40 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,118
Thanks: 74
Thanked 295 Times in 259 Posts
Rep Power: 46569
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Just had the car serviced

Quote:
Originally Posted by Swampy View Post
Sludge in the coolant expansion tank is symptomatic of incompatible coolant being used to top up the fluid.

My guess is that coolant other than the Mopar specified has been used.

If changing coolant brand or spec, the whole system must be drained, flushed and refilled. That is why it is nearly always best to strictly stay with OEM coolant. You would expect that the dealer would always use OEM products, but not always. Especially if they can save a dollar.
What he said. I've put over 200K miles on a GC and never had brown sludge in the recovery tank. Always used aftermarket coolant recommended by the dealer and now use only mopar coolant.

I'd also take a good look at what is in your radiator.... even if you have to crawl under and drain a bit.

BTW, it isn't that big a deal to remove the tank and clean it if you have enough water pressure or a LOW pressure washer. Or just buy a new tank.
Reply With Quote
  #9  
Old 01-28-2016, 01:40 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 4,118
Thanks: 74
Thanked 295 Times in 259 Posts
Rep Power: 46569
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: Just had the car serviced

Quote:
Originally Posted by tasjeep View Post
I had that brown sludge, dealer didn't know why but flushed and cleaned the system and it hasn't returned.
I have checked a few others since then and most seem to have it.
Invasion of the brown sludge monsters?
Reply With Quote
  #10  
Old 01-28-2016, 02:28 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Melbourne, Australia
Posts: 321
Thanks: 39
Thanked 48 Times in 34 Posts
Rep Power: 1696
chocco is on a distinguished road
Quote:
Originally Posted by perpster View Post

Agreed, else you may be posting about the brown sludge all over the engine compartment.
I know removing coolant excess today.
Reply With Quote
  #11  
Old 01-28-2016, 04:02 PM
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Oct 2015
Location: Tasmania
Posts: 108
Thanks: 0
Thanked 16 Times in 15 Posts
Rep Power: 722
tasjeep is on a distinguished road
Re: Just had the car serviced

I agree that mixing coolants can cause a sludge or gel but in my case the Jeep only had 1500k's on it so it was ex factory.
Also know of several others that have had the sludge from new and have been purchased from different dealers.
Have no idea what is causing it ex factory but glad I had mine flushed and changed.
Reply With Quote
  #12  
Old 01-28-2016, 04:51 PM
fun2drive's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Florida Panhandle/ Ohio
Posts: 921
Thanks: 19
Thanked 112 Times in 87 Posts
Rep Power: 3841
fun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond repute
Re: Just had the car serviced

That is common on virtually every vehicle I have ever owned. I have only seen this on the original fill and that from what I can tell is not incompatible coolant sludge but actually is residue from the engine block during manufacturing. In fact it is a light film of oil mixed with the coolant.

Very common and totally normal...
__________________
Overland Deep Cherry Red/ LT Biege Inter/ Diesel/ ATG
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just had RRT 13-66 Transmission update done Bborzell Grand Cherokee - WK2 - 5 02-01-2014 10:56 AM
Just had a major issue with my Hypertech interseptor 2011hemigc4me Engine Performance/Intakes/Exhausts 22 06-19-2013 09:30 PM
My poor Baby Just Had Her First Break LiquidOxygen Trouble Shooting/Problems/Service 3 05-22-2011 09:41 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.