MIL & P20EE again & again & again... - Page 15 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #169  
Old 04-28-2015, 09:38 AM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 305
Thanks: 60
Thanked 33 Times in 28 Posts
Rep Power: 1390
wraab is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by wk2chris View Post
I just got my second CEL, 1100 miles from my last one and a "software update". I have to wait a week to get an appointment. Anybody run into issues driving ~300 miles with this P20EE CEL?

I drove at least 600 miles waiting for my new cat - no issues.

Reply With Quote
Sponsored Links
Advertisement
 
  #170  
Old 04-28-2015, 09:44 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1448
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by Owen.H View Post
I am having a P20EE issue again. Apparently, the replacement parts from January 2015 have now failed. Or were never installed. Best part, was on a road trip 200 miles from home. I am now taking a taxi to the local airport to rent a car. I have to deal with the billing on Monday. My dog likes the taxi ride at least. Wife, not so much. Just disappointed. Really.


Sent from my iPhone using JeepGarage
You had the CAT changed in Jan 2015, and you still had a P20EE MIL?
__________________
Phil - JGC 2014 Eco Diesel - 2013 Sept build - NEW CAT INSTALLED! 11K miles.
Reply With Quote
  #171  
Old 04-29-2015, 05:11 PM
Member
 
Join Date: Jan 2014
Posts: 80
Thanks: 4
Thanked 2 Times in 2 Posts
Rep Power: 1121
function12 is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by function12 View Post
Dealer has now agreed to order one but says there is a hold on V8's till next month. The hits keep coming. The jeep is still running good though. So, hopefully it will stay out of the shop until the new one comes in.
ISG called Chrysler about ordering a 4X2 V8 and Chrysler told ISG they will not be madding any 4X2 V8's for the rest of the year. SWELL!!! Now we have to try to find one through dealer trade.
Reply With Quote
  #172  
Old 05-01-2015, 01:28 PM
Chivvalry's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2012
Location: Parkland, FL
Posts: 1,132
Thanks: 186
Thanked 139 Times in 81 Posts
Rep Power: 81938
Chivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond reputeChivvalry has a reputation beyond repute
Re: MIL & P20EE again & again & again...

CEL came on, "software update"... another 500 miles and CEL back on, dropped off the jeep again... "pressure sensor". Several days go by and no word... I call and say what's up. "We stripped a bolt on the cat and ordered a new one." WTF? Okay... another few days, "Cat is backordered with no ETA"

Getting used to smokey smelling Chrysler 200 loaner... that's a bad thing.
__________________
2014 GC Limited CRD Max Steel/Black LuxII ORAII RA4

11/13/13 MINE!! ALL MINE!!!

Reply With Quote
  #173  
Old 05-01-2015, 02:12 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: Los Angeles
Posts: 26
Thanks: 0
Thanked 19 Times in 6 Posts
Rep Power: 1036
frall9 is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by frall9 View Post
Hey Gang,

By way of update, I had my CAT replaced just about 2 months ago after going through the P20EE dance, and have driven about 1500 miles and so far so good on that front. You can find me prior post on the experience earlier in this thread if you're new to this topic.

HOWEVER, I'm now dealing with another related issue that I hope to have resolved next week but wanted to bring to your attention in case anyone encounters the same thing. During one of my first Regens after the repair, I noticed a very strong chemical burning smell, and white smoke was wafting up over the hood and actually getting pulled back into the AC and vented into the cabin. I crossed my fingers and prayed it was just the oils/labels, etc. from the new parts burning off and it would burn off and go away after a couple hundred miles. Now, 3 noticeable Regens and over 1,000 miles later, the issue is continuing to occur. I say "noticeable" Regens because my daily commute has me on the freeway for about 10-15 minutes, which happens to be just enough time for the Regen process to start, but it is often not fully complete by the time I pull into my driveway and the excess heat, and odor is very noticeable when parked.

After some research, I discovered that there is a common issue on the Dodge Ram trucks with the 3.0 Ecodiesel with the turbo coupling which is located just in front of the firewall, cracking and causing an exhaust leak, which in turn results in this exact condition I'm experiencing. I have a service appointment a week from today where they have promised to test the exhaust system for a leak, and if necessary do a forced Regen to see if they can re-create the condition and identify the cause if it happens to be something other than a leaky exhaust coupling so we'll see. My guess is they either cracked the coupling when they installed the new CAT, or the new CAT wasn't properly installed to begin with. We shall see and I'll report back.
Latest update - Dropped my Jeep off on Wednesday morning and showed the service tech a video I took of the white smoke during the regen process. Dealer did a forced regen later that afternoon and immediately saw the white smoke billowing out from under the car and up through the engine bay. The good news is that it was not a cracked coupling at the turbo which I suspected, but instead a bad clamp at the DEF injector that was not re-installed properly when they replaced my cat a few weeks ago. They replaced the clamp, did another forced regen and claim no more exhaust leak. Fingers crossed this is my last major issue for a while, but I'll keep the group posted.
Reply With Quote
  #174  
Old 05-03-2015, 06:39 PM
Zhe Wiz's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Central NY - Ithaca
Posts: 643
Thanks: 164
Thanked 113 Times in 77 Posts
Rep Power: 16680
Zhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond repute
Re: MIL & P20EE again & again & again...

MY TURN!!!

February 2014 build, 14,371 miles. Check engine lit with the now infamous P20EE code. Will call dealer tomorrow and get the ball rolling.
__________________
Zhe Wiz

[SIGPIC][/SIGPIC]
Reply With Quote
  #175  
Old 05-04-2015, 11:24 AM
echo7tango's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: Dec 2012
Location: SF Giants Nation 2010 / 2012 / 2014!
Posts: 844
Thanks: 119
Thanked 168 Times in 121 Posts
Rep Power: 67844
echo7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by Zhe Wiz View Post
MY TURN!!!

February 2014 build, 14,371 miles. Check engine lit with the now infamous P20EE code. Will call dealer tomorrow and get the ball rolling.

Welcome to the club, I'm sorry to say. Be persistent and patient.


Sent from my iPad using JeepGarage
__________________

2016 JGC CRD 3.0L V-6 WK2, QL, QD-II, ORA-II, Wrangler Duratrac 275/55-20
Lemon Law buy-back of my 2014 JGC CRD: http://tinyurl.com/e7t-JGC-CRD-buyBackSummary
SEMPER FIDELIS
Reply With Quote
The Following User Says Thank You to echo7tango For This Useful Post:
  #176  
Old 05-04-2015, 01:02 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: CT
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 994
wk2chris is on a distinguished road
Re: MIL & P20EE again & again & again...

Shop just called. I'm getting a new cat and injector. Fortunately, it should be ready in 2 days. I mentioned that there are a quite a few reporting this issue on the board. The service advisor said they'd had a do a few of these. He said the software update they applied for the first CEL is to slow the amount of DEF being injected, but by the time the computer reports an issue, it is too late and the cat is clogged.
Reply With Quote
  #177  
Old 05-04-2015, 02:57 PM
Zhe Wiz's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Central NY - Ithaca
Posts: 643
Thanks: 164
Thanked 113 Times in 77 Posts
Rep Power: 16680
Zhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by echo7tango View Post
Welcome to the club, I'm sorry to say. Be persistent and patient.
Thanks! My appt is Wed (the 6th) at 10AM. Service dude also said they'd had a few diesels with the issue but that the flash has fixed it and no one has been back for a new cat. I'm guessing that's either a load of crap or those people haven't driven much after the flash. Seems to be near 100% on here needing the cat after flash.

Not a big deal, I knew it was coming.
__________________
Zhe Wiz

[SIGPIC][/SIGPIC]
Reply With Quote
  #178  
Old 05-04-2015, 03:25 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: CT
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 994
wk2chris is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by Zhe Wiz View Post
Thanks! My appt is Wed (the 6th) at 10AM. Service dude also said they'd had a few diesels with the issue but that the flash has fixed it and no one has been back for a new cat. I'm guessing that's either a load of crap or those people haven't driven much after the flash. Seems to be near 100% on here needing the cat after flash.

Not a big deal, I knew it was coming.
Yeah, I'm not buying that. My second light came about 1100 miles after my first. I made my appointment. While waiting, I drove another 200 miles and it happened to clear itself. However, about 150 miles later, the light came back. I only drove a short amount from that point until I brought it for service today. Throughout this time, I did not notice any difference in performance.
Reply With Quote
  #179  
Old 05-04-2015, 09:48 PM
Member
 
Join Date: Dec 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1097
koobos is on a distinguished road
Re: MIL & P20EE again & again & again...

Add me to the list. Just had the cat and dpf replaced. Hopeful this is the last cel error. Really like this rig despite the many visits to the dealer.




Sent from my iPhone using JeepGarage
Reply With Quote
  #180  
Old 05-04-2015, 11:06 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2014
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 816
adl6009 is on a distinguished road
New cat and a new service department

Finally they fixed, I hope, the problem. The most unbelievable part was when the service "adviser", descibing the catylytic converter replacement procedure tells me that one gasket in the exhaust system was "seriously back ordered". His plan was to do the cat replacement and try to reuse the old gasket. When I asked what would happen if the gasket was damaged, his reply was that the truck may be a little louder, maybe it would smell like diesel fumes, but he would give the truck back to me to use until the new gasket arrived. He then refused any further discussion, or "advice", and considered the matter settled. I found that was not acceptable, to release a vehicle with a defective exhaust system, and so did chrysler customer service. With their intervention a "seriously back ordered" gasket was magically obtained and installed. At least thats what I'm told. Now, with all trust lost, I am moving on to the next closest service department.
__________________
2014 3.0L Diesel Quadra-Trac II Granite Crystal Metallic
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P20EE Trigger 2014+ Jeep Grand Cherokee Ecodiesel 3.0 49 12-06-2015 11:49 AM
Flat battery again..and again..and again..etc. spikelet Troubleshooting/Problems 4 07-15-2013 10:34 AM
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 12:22 PM
MIL & OBD lights on GC07 Grand Cherokee - WK 12 03-06-2011 06:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.