MIL & P20EE again & again & again... - Page 25 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #289  
Old 06-02-2015, 10:04 AM
Member
 
Join Date: Nov 2014
Posts: 219
Thanks: 71
Thanked 25 Times in 25 Posts
Rep Power: 1100
mbaessler has a reputation beyond reputembaessler has a reputation beyond reputembaessler has a reputation beyond reputembaessler has a reputation beyond reputembaessler has a reputation beyond reputembaessler has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Are there any 2015's that have crossed and gone beyond the 15-17K mileage barrier and have gotten the dreaded MIL & P20EE SCR code. I feel bad about you guys with the 2014 with this issue. What a hassle! I have 5500 miles on my 2015 and hopefully I won't have to deal with that Cat issue. Any higher mileage 2015's having this issue? MIke

Reply With Quote
Sponsored Links
Advertisement
 
  #290  
Old 06-02-2015, 11:18 PM
netboy's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: CT
Posts: 386
Thanks: 44
Thanked 86 Times in 52 Posts
Rep Power: 581713
netboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond reputenetboy has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by wraab View Post
I have a little time before this becomes a problem for me - however, has anything been done to fix the issue before you get to inspection?
I'm off the hook in my state as it gives 4 year initial emissions pass, and allows up to two not-ready monitors. Unfortunately many states are not as lenient and forgiving. For me it's just OCD kicking in as I can't bare the fact driving a new vehicle with a non-ready emissions status when there's absolutely nothing wrong with it. I will be mentioning it to my dealer on my next TSB/oil job.
__________________
Summit 4x4 Turbo-Diesel, Black / Jeep Brown.
Reply With Quote
  #291  
Old 06-03-2015, 09:19 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Posts: 31
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 1062
blackcoffee is on a distinguished road
Re: MIL & P20EE again & again & again...

I just got my 3rd MIL. I'm sure it will come up as a P20EE code. I immediately made an appointment at the dealer and opened a case with Chrysler. This will be my 9th visit to the dealer for service issues since owning the vehicle. This is unacceptable for any new vehicle let alone one that costs above $45,000.
Reply With Quote
  #292  
Old 06-03-2015, 09:32 AM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 305
Thanks: 60
Thanked 33 Times in 28 Posts
Rep Power: 1391
wraab is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by netboy View Post
I'm off the hook in my state as it gives 4 year initial emissions pass, and allows up to two not-ready monitors. Unfortunately many states are not as lenient and forgiving. For me it's just OCD kicking in as I can't bare the fact driving a new vehicle with a non-ready emissions status when there's absolutely nothing wrong with it. I will be mentioning it to my dealer on my next TSB/oil job.

Thanks - I'm with you. I had to go verify for Texas.

Quote:
Remember Effective October 15, 2008:
For vehicles year model 2001 and newer, we allow one (1) non-continuous monitor to be Not Ready and still pass the test, but two (2) or more Not Ready's will cause the vehicle to fail.
Reply With Quote
  #293  
Old 06-03-2015, 10:43 AM
jaje's Avatar
Member
 
Join Date: May 2014
Posts: 279
Thanks: 5
Thanked 43 Times in 31 Posts
Rep Power: 1217
jaje is on a distinguished road
Re: MIL & P20EE again & again & again...

Got a CEL a couple weeks ago when was out of town (text from wife). Got back in and CEL was off. The other day I had to do an active regen so drove it for a good 30 miles and drove it hard (we have mountains here so did some hard pulls up them). Regen finished and have not had an issue. 21k miles thus far. I also tow 1-2x a month so do work the engine really hard at times - maybe it's something that's needed on the Ecodiesels - a good hard run from time to time to work the engine and get it really hot with lots of higher RPM pulls.
__________________
'14 XV Crosstrek
#74 Exomotive Exocet NASA ST3 / E0
'14 WK2 EcoDiesel (replaces '07 WK CRD)
Reply With Quote
  #294  
Old 06-03-2015, 09:21 PM
Member
 
Join Date: Apr 2013
Location: Broussard, LA
Posts: 58
Thanks: 2
Thanked 22 Times in 10 Posts
Rep Power: 1600
Dan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond reputeDan B has a reputation beyond repute
Re: MIL & P20EE again & again & again...

My P20ee returned again after a couple of hundred miles. Taking the vehicle in tomorrow for the new CAT. Will be interesting to see if the problem is resolved or just temporarily depressed.
__________________
Dan B
Broussard, LA
2014 Jeep Grand Cherokee Overland 4X4 EcoDiesel | Granite / Black | ORAII | Adv Tech GRP | Engine Block Heater
Reply With Quote
  #295  
Old 06-03-2015, 10:15 PM
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Apr 2014
Location: Lower Mainland, BC
Posts: 22
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 995
Magnum2Jeep is on a distinguished road
Send a message via Skype™ to Magnum2Jeep
Re: MIL & P20EE again & again & again...

I have no idea how my Jan '14 build Diesel has not had a MIL - 29,000km and never a message, no apparent regen issues, etc etc.
i can tell you that i am not easy on the truck and average with about 70% urban driving 11l/100km ( 21 miles US Gallon )

i am not unhappy with that considering i am coming out of the most unreliable car i ever owned - an '06 magnum AWD hemi @ 17.7l/100lm ( 13.2m/us Gal )

KRR
__________________
Reply With Quote
  #296  
Old 06-03-2015, 11:33 PM
Shannon's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: May 2013
Location: Lakeville, MN
Posts: 1,585
Thanks: 234
Thanked 223 Times in 143 Posts
Rep Power: 11499
Shannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond reputeShannon has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by Magnum2Jeep View Post
I have no idea how my Jan '14 build Diesel has not had a MIL - 29,000km and never a message, no apparent regen issues, etc etc.
i can tell you that i am not easy on the truck and average with about 70% urban driving 11l/100km ( 21 miles US Gallon )

i am not unhappy with that considering i am coming out of the most unreliable car i ever owned - an '06 magnum AWD hemi @ 17.7l/100lm ( 13.2m/us Gal )

KRR
Mine is in the shop now getting the cat replaced. Supposed to be done this afternoon, then I get a call - they broke a stud bolt off something, and it won't be ready till tomorrow afternoon. Stuck me in a Jeep Compass for the night. I miss my SFU.
__________________
SFU: : 2016 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater - REPLACED: 2014 Overland 4X4 EcoDiesel, Billet Silver/Black. ORAII, Adv Tech, Engine Heater, with 2000 coats of paint



Current Rides:
2016 Jeep Grand Cherokee Overland Ecodiesel
2015 Cherokee Latitude (wife's ride)
2008 20' Four Winns bow rider speed boat
Reply With Quote
  #297  
Old 06-04-2015, 10:38 AM
fun2drive's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2013
Location: Florida Panhandle/ Ohio
Posts: 774
Thanks: 15
Thanked 81 Times in 66 Posts
Rep Power: 2270
fun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond reputefun2drive has a reputation beyond repute
Re: MIL & P20EE again & again & again...

2 days ago got the CEL light and looking like typical problem noted here. I have 23000 miles on mine high percentage hiway so maybe that is why I lasted that long. Dec 19 2013 build date....


Sent from my iPhone using JeepGarage
__________________
Overland Deep Cherry Red/ LT Biege Inter/ Diesel/ ATG
Reply With Quote
  #298  
Old 06-04-2015, 10:57 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Feb 2014
Location: Katy, Texas
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1033
bustergc is on a distinguished road
Re: MIL & P20EE again & again & again...

I am at about 23,000 miles and just had the Cat replaced yesterday. I have been pretty much trouble free before that. I had the 200 mile until no re-start message, so luckily the dealer had a replacement Cat in stock. Only took one day to get it replaced. Hopefully the redesigned SCR Cat actually is a long term fix and not just something that will last another 20,000 miles.

It seems like nearly everyone on this forum with a 2014 has had the SCR cat replaced. Is that true or am I imagining that?
Reply With Quote
  #299  
Old 06-04-2015, 11:06 AM
Senior Member
 
Join Date: Sep 2013
Posts: 1,287
Thanks: 46
Thanked 155 Times in 126 Posts
Rep Power: 2808
Roadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond reputeRoadkill has a reputation beyond repute
Quote:
Originally Posted by bustergc View Post
It seems like nearly everyone on this forum with a 2014 has had the SCR cat replaced. Is that true or am I imagining that?
Polling this forum is subject to selection bias. You're much more likely to have people post their P20EE experience than to chime in to say that hasn't happened.

I have a Dec 2013 build that's at ~16k miles and it has never had a P20EE. Furthermore, as long as we're talking about selection bias, I have never seen a "regen required keep driving at highway speeds" EVIC message despite driving 90% in-city and never getting above 45 mph there. I had the March 2015 RRT PCM flash applied, so we'll see if it truly arrests the SCR damage.

Maybe I'll end up with a new cat. However if I never see a P20EE then that would bode well for those who got a new cat.
Reply With Quote
The Following User Says Thank You to Roadkill For This Useful Post:
  #300  
Old 06-04-2015, 11:39 AM
Zhe Wiz's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jun 2013
Location: Central NY - Ithaca
Posts: 643
Thanks: 164
Thanked 113 Times in 77 Posts
Rep Power: 16681
Zhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond reputeZhe Wiz has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by bustergc View Post
It seems like nearly everyone on this forum with a 2014 has had the SCR cat replaced. Is that true or am I imagining that?
I have a Feb 2014 build diesel. I had a brief MIL at 13,700 miles which scans revealed to be the P20EE code. It went out by itself in less than 100 miles, I've since had the flash done and as of today (15,170 miles) the error has not returned.

I'm pretty sure there are two types of 2014 diesel owners though...those that have already had their cat replaced due to P20EE and those that will. I'm still in the latter category, but don't expect to stay for much longer!

I've never seen a regen message either.
__________________
Zhe Wiz

[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P20EE Trigger 2014+ Jeep Grand Cherokee Ecodiesel 3.0 49 12-06-2015 11:49 AM
Flat battery again..and again..and again..etc. spikelet Troubleshooting/Problems 4 07-15-2013 10:34 AM
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 12:22 PM
MIL & OBD lights on GC07 Grand Cherokee - WK 12 03-06-2011 06:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.