MIL & P20EE again & again & again... - Page 4 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 02-25-2015, 10:09 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1447
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by rab4225 View Post
2015 Ive had less than 2 months, 3600 miles now has P20E for the first time, hoping it will go away.
Ahhhhh great! can't believe we are going to see this on the new 2015 GC's also... Rab4225, what is build date of your GC? thanks!

Reply With Quote
Sponsored Links
Advertisement
 
  #38  
Old 02-26-2015, 07:32 AM
Member
 
Join Date: Oct 2014
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 788
rab4225 is on a distinguished road
Re: MIL & P20EE again & again & again...

On further review, it looks like mine is a P20e9 and may just be def pressure related. On a positive note it was gone this morning so I am keeping my fingers crossed. Either way these exhaust systems are finicky as hell.

My build was November sometime, part of the initial backlog.
Reply With Quote
  #39  
Old 02-26-2015, 02:57 PM
Member
 
Join Date: Feb 2014
Posts: 38
Thanks: 9
Thanked 4 Times in 3 Posts
Rep Power: 1059
FajitaMidland is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by lectricman View Post
Mine is in the shop as I type having the Cat replaced. Hopefully this will do it. I bet I've cleared the code 25 times while waiting the 6 weeks for the part to come in. They're also checking my "service tire pressure monitor system" message that I have gotten twice. And here's a weird one, the pass. side DRL and orange side marker lights did not light 3 times when remote started. I bet I'll be back to the dealer for a TPMS module and a new headlight assembly or module. Ahh, the fun never ends. At least I have a Ram crew cab as a rental.
Thanks for the tibit on how long you waited for the part.
Reply With Quote
  #40  
Old 02-26-2015, 03:53 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Posts: 91
Thanks: 1
Thanked 5 Times in 4 Posts
Rep Power: 1312
lectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by johnmbureau View Post
Lectricman-let us know what you end up with on your pass headlight- mine is doing the exact same thing. Only happens with remote starts.


Sent from my iPhone using JeepGarage
Still in the shop. Hope to get it back today. I'll post what they find.
Reply With Quote
  #41  
Old 02-26-2015, 05:39 PM
GunninIt's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: California
Posts: 197
Thanks: 15
Thanked 9 Times in 5 Posts
Rep Power: 1672
GunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Noted in another thread that I was told the CAT was back ordered (as has everyone), and I ended up getting it in about a week. Not sure why...but my Service Manager told me that a Chrysler rep was looking at my car yesterday, called it in, and it was here this morning. I'll take it...
__________________
2014 GC Limited CRD Bright White/Black LuxII ORAII RA4



The 3.6 in my JKUR is like 6 drunk hamsters banging on bongos. -dugedug
Reply With Quote
  #42  
Old 02-26-2015, 08:31 PM
echo7tango's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: Dec 2012
Location: SF Giants Nation 2010 / 2012 / 2014!
Posts: 844
Thanks: 119
Thanked 168 Times in 121 Posts
Rep Power: 67844
echo7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by GunninIt View Post
Noted in another thread that I was told the CAT was back ordered (as has everyone), and I ended up getting it in about a week. Not sure why...but my Service Manager told me that a Chrysler rep was looking at my car yesterday, called it in, and it was here this morning. I'll take it...
My cat fix seems to have done the trick. So far over 1,000 miles and no MIL.
__________________

2016 JGC CRD 3.0L V-6 WK2, QL, QD-II, ORA-II, Wrangler Duratrac 275/55-20
Lemon Law buy-back of my 2014 JGC CRD: http://tinyurl.com/e7t-JGC-CRD-buyBackSummary
SEMPER FIDELIS
Reply With Quote
  #43  
Old 02-26-2015, 09:03 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1447
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Echo, happy for ya, keep us posted...us with still the old CAT'S ....
Reply With Quote
  #44  
Old 02-26-2015, 09:05 PM
Member
 
Join Date: Oct 2010
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2280
pnwsnow is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by GunninIt View Post
Please do keep us updated.



Mine is in the shop as I type waiting for the part.



How long did you wait for the part - as I assume it, too, was back ordered.

I was lucky. My dealership was able to get a cat from another local dealership. Two days to get the parts and another day to exchange it.



Sent from my iPad using JeepGarage
Reply With Quote
The Following User Says Thank You to pnwsnow For This Useful Post:
  #45  
Old 02-27-2015, 12:06 AM
GunninIt's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: California
Posts: 197
Thanks: 15
Thanked 9 Times in 5 Posts
Rep Power: 1672
GunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond reputeGunninIt has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by pnwsnow View Post
I was lucky. My dealership was able to get a cat from another local dealership. Two days to get the parts and another day to exchange it.

Sent from my iPad using JeepGarage
Yeah. Crazy how fast mine came in. Dropped off at close Saturday. Talked with the service manager Monday at which point he says 'we're trying to expedite, but it's back ordered...' Chrysler rep there yesterday. Part today. Car at home in my garage right now.

I checked the work order, and updated part # was there. For a while, I wondered if I was getting the outdated part. I'm jazzed.
__________________
2014 GC Limited CRD Bright White/Black LuxII ORAII RA4



The 3.6 in my JKUR is like 6 drunk hamsters banging on bongos. -dugedug
Reply With Quote
  #46  
Old 02-27-2015, 08:26 AM
1Zach1's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: NoVA
Posts: 117
Thanks: 6
Thanked 11 Times in 10 Posts
Rep Power: 1194
1Zach1 is on a distinguished road
Re: MIL & P20EE again & again & again...

Well mine is in the shop with the P20EE code. I'm currently stuck driving a horrible mini-van while they check it over. This is the first time it has hit, so I'm assuming that I'll be looking at 2-3 more trips in.
__________________
Limited 4x4 MaxSteel.
Reply With Quote
  #47  
Old 02-27-2015, 09:44 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Posts: 91
Thanks: 1
Thanked 5 Times in 4 Posts
Rep Power: 1312
lectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond reputelectricman has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Sooo, thought I'd get my truck back today but noooo, the dealer broke a bolt on the preconverter while changing the cat. That part won't be in till Wednesday next week. Had to turn in the Ram loaner because enterprise sprayed some stink ass perfume to cover up the puke smell. My wife thought I was having an affair with a cheap hore. I'm now in a minivan without xm. This is getting old real quick.
.
Reply With Quote
  #48  
Old 02-27-2015, 10:19 AM
echo7tango's Avatar
Premium Member
My Jeep: 2016 3.0L WK2
 
Join Date: Dec 2012
Location: SF Giants Nation 2010 / 2012 / 2014!
Posts: 844
Thanks: 119
Thanked 168 Times in 121 Posts
Rep Power: 67844
echo7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond reputeecho7tango has a reputation beyond repute
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by lectricman View Post
Sooo, thought I'd get my truck back today but noooo, the dealer broke a bolt on the preconverter while changing the cat. That part won't be in till Wednesday next week. Had to turn in the Ram loaner because enterprise sprayed some stink ass perfume to cover up the puke smell. My wife thought I was having an affair with a cheap hore. I'm now in a minivan without xm. This is getting old real quick.
Hang in there, have faith that it'll all work out in the end, and soon enough. I too was thinking that my situation was getting old really quick.

The cat install might be tricky because of what you describe, and for me the first install failed because one of the electrical connector plugs didn't seat fully and one of the pins was bent. I had to come back soon after the cat install (sigh). The good news is that the Enterprise rental I got that time was a 2015 JGC, so at least I had another JGC. I even transfered the dog's crate and all my gear from the cargo area. I moved into that JGC, had it for over a week as they had trouble isolating the cause to that failed pin connection.

And, a minivan with no XM? You ain't pickin' up no ho with that sled, my friend. You have to work on your method.
__________________

2016 JGC CRD 3.0L V-6 WK2, QL, QD-II, ORA-II, Wrangler Duratrac 275/55-20
Lemon Law buy-back of my 2014 JGC CRD: http://tinyurl.com/e7t-JGC-CRD-buyBackSummary
SEMPER FIDELIS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P20EE Trigger 2014+ Jeep Grand Cherokee Ecodiesel 3.0 49 12-06-2015 11:49 AM
Flat battery again..and again..and again..etc. spikelet Troubleshooting/Problems 4 07-15-2013 10:34 AM
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 12:22 PM
MIL & OBD lights on GC07 Grand Cherokee - WK 12 03-06-2011 06:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.