MIL & P20EE again & again & again... - Page 7 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #73  
Old 03-10-2015, 12:36 AM
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2015
Posts: 15
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 743
DieselPower is on a distinguished road
Re: MIL & P20EE again & again & again...

Brand new owner of a 2015 GC Limited diesel, traded in my 2012 GC Limited Hemi and thinking it was a big mistake. Only 500 or so miles and the MIL light just came on. Also before I was getting on the fwy today the truck stalled for a sec with a warning of low voltage. Checked the OBD and it stated 13v so who knows what happened. I am also a victim of only getting a quarter tank of DEF fuild upon delivery She will go into the shop on Thursday but they are already refusing to provide me with a loaner, unreal!

Reply With Quote
Sponsored Links
Advertisement
 
  #74  
Old 03-10-2015, 05:55 AM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1530
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Don't worry, I am sure that it is just a minor glitch, something they ( Your stealer, I mean dealer... ) forgot to do upon delivery...keep us posted on the developments!
Reply With Quote
  #75  
Old 03-12-2015, 04:28 PM
Member
 
Join Date: Jan 2014
Posts: 81
Thanks: 4
Thanked 2 Times in 2 Posts
Rep Power: 1204
function12 is on a distinguished road
Re: MIL & P20EE again & again & again...

Well my cat got replaced today. Hopefully that will finally fix this issue.
Reply With Quote
  #76  
Old 03-12-2015, 04:41 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1530
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by function12 View Post
Well my cat got replaced today. Hopefully that will finally fix this issue.
Great! were you waiting for a while? Did they change anything else, sensor? Keep us posted on how it goes! Gluck!
Reply With Quote
  #77  
Old 03-12-2015, 04:59 PM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 345
Thanks: 97
Thanked 43 Times in 35 Posts
Rep Power: 1513
wraab is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by function12 View Post
Well my cat got replaced today. Hopefully that will finally fix this issue.

Same here...picked up about an hour ago.
Reply With Quote
  #78  
Old 03-13-2015, 12:57 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: Los Angeles
Posts: 26
Thanks: 0
Thanked 19 Times in 6 Posts
Rep Power: 1118
frall9 is on a distinguished road
Re: MIL & P20EE again & again & again...

Wanted to add my current experience to this thread...actually feels more like a support group at this point. (My name is John, and I have a P20EE problem...) Anyway, I'd scheduled my 2014 GC for my 10,000 mile service about 10 days ago, along with the few recalls that were outstanding, and a number of the software updates. The day before the service appointment my MIL came on driving to work, so I called and added that to the laundry list. Obviously having read this thread and many others, I knew what to expect, but they returned my car the next day and the MIL was off, and the service advisor told me that it was the P20EE error, but it was fixed via the software update which I was very skeptical about. Unfortunately, but as expected, about 4 days later, the MIL came back on after around 125 miles. I dropped the car off again yesterday, and I'm hoping to hear back shortly that they will need to replace the cat as opposed to another temp fix that we all know won't work. He did tell me its taking them about 10-14 days to get parts so we'll see how long this all takes. Hard to blame the service department as Jeep makes them waste time going through these steps before approving them to replace parts and fix the problem, but I'm certainly worried about the long-term viability of this system. Love the car otherwise as most have stated, but not what you want to deal with after only 10K miles. I'll give an update when I hear back.
Reply With Quote
  #79  
Old 03-13-2015, 01:12 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1530
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by frall9 View Post
Wanted to add my current experience to this thread...actually feels more like a support group at this point. (My name is John, and I have a P20EE problem...) Anyway, I'd scheduled my 2014 GC for my 10,000 mile service about 10 days ago, along with the few recalls that were outstanding, and a number of the software updates. The day before the service appointment my MIL came on driving to work, so I called and added that to the laundry list. Obviously having read this thread and many others, I knew what to expect, but they returned my car the next day and the MIL was off, and the service advisor told me that it was the P20EE error, but it was fixed via the software update which I was very skeptical about. Unfortunately, but as expected, about 4 days later, the MIL came back on after around 125 miles. I dropped the car off again yesterday, and I'm hoping to hear back shortly that they will need to replace the cat as opposed to another temp fix that we all know won't work. He did tell me its taking them about 10-14 days to get parts so we'll see how long this all takes. Hard to blame the service department as Jeep makes them waste time going through these steps before approving them to replace parts and fix the problem, but I'm certainly worried about the long-term viability of this system. Love the car otherwise as most have stated, but not what you want to deal with after only 10K miles. I'll give an update when I hear back.
Hi Frall9, welcome to the support group and thanks for sharing!
Reply With Quote
  #80  
Old 03-19-2015, 10:34 AM
JPC1's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2015
Location: Québec, Canada
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 724
JPC1 is on a distinguished road
Re: MIL & P20EE again & again & again...

Newbie here.

Looks like my DEF/P20EE issues are well documented here. Picked up a 2014 Overland EcoDiesel last September thinking this was going to be the coolest Jeep I ever owned (it's my fifth), but I'm very disappointed to report that as of today my CEL came on (again) for the third time. The first time it did (January 2015), I was told the DEF had crystallized in the injector. So they warmed up the truck for a day inside the garage. They told me they had installed a patch to prevent DEF from being injected from -11 Celsius and colder (which turns out to be BS - does such a patch even exist ? Hven't been able to confirm it anywhere) until the truck came to normal operating temp. All was going to be good, or so they said. It's been damn cold this winter up here in Quebec (good thing I had this -11C patch installed, I thought). And all was good until last week when the CEL came on again. Two codes : P20EE and P204F. The mechanic said DEF was a little "beige" although it tested OK, so he proceeded to flush it and replace it, this was troubleshooting for P204F. Then took the truck for a 120kms road test (!). No CEL. I asked about P20EE, he said he was done troubleshooting since the CEL had not come back on. Well guess what, 72 hours later (less than 200kms), it came back on again today. So here I am, new guy on this forum. I read many instances of this being fixed by either TSB 118-023-15 and/or 18-045-14. I wonder... how come I can find this, but not the mechanic at the dealership ? Is it really as simple as those two TSBs ? Seems to be well documented...

Besides this DEF/CEL annoyance, this Jeep IS the coolest I've owned. Traction up here in the snow, I mean off-roading in a foot+ of powder snow, is unbelievable.

Anyway, if anyone has good advice for me to correct this CEL issue, on top of what is already documented here, please drop me a line.

Great forum.
Cheers.
John
Reply With Quote
  #81  
Old 03-19-2015, 03:48 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2014
Location: Los Angeles
Posts: 26
Thanks: 0
Thanked 19 Times in 6 Posts
Rep Power: 1118
frall9 is on a distinguished road
Re: MIL & P20EE again & again & again...

Sorry to hear you're joining the support group John, but we're all here for you.

As an update on my situation, I was notified by my dealership last Friday that they would in fact be replacing my catalytic converter to solve my P20EE error which probably comes as no surprise to many of you. I challenged the service advisor as to why they waste our time hoping the software updates will solve the issue when they know that won't fix the problem long term. As you would expect, it's all driven by Chrysler corporate, and they of course don't want to spend the money until they are absolutely positive about the problem, but in our cases it seems to be pretty straightforward at this point.

Unfortunately my dealer also informed me the part was back-ordered as many of you have mentioned, and it might take up to two weeks to receive the replacement parts. What I wasn't expecting however is that Chrysler told the dealer I could not drive my Jeep until they performed the repair. Others have mentioned they were able to drive their Jeeps for weeks until the parts came in, but Chrysler stated that this error is often leading to the car going into the infamous limp-mode, so they don't want to take the chance of people getting stranded, or doing further damage to the system.

This turned out to be a huge issue for me as I had a family ski trip planned for this weekend and while the dealer initially provided me a small loaner car, it was entirely inadequate for the trip as I would be without 4WD, my ski rack, etc. Basically all the capabilities that I bought the Jeep for to begin with. I contacted Chrysler immediately, and after some discussion, ultimately my case manager at the corporate level approved a "like-kind" rental with 4wd for as long as needed which ended up being a 2014 Ford Explorer Sport at a rental rate of $70/day as opposed to the normal $35/day limit they usually hold you too.

The Chrysler case manager also expedited shipping of the replacement parts for me, so they actually arrived at the dealership this afternoon, which was under a week and quicker than I expected. The repair should be done by Monday of next week latest, so fingers crossed it will all go well and I can go back to enjoying the car.

Lastly, I will tell you that having spent the last 7 days in different loaner cars, including the Ford Explorer, it really makes me appreciate how good the Grand Cherokee really is....when I'm able to drive it of course....
Reply With Quote
  #82  
Old 03-19-2015, 04:20 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1530
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Well, I am in waiting mode for my new CAT to arrive, still no ETA from FCA. I have now a case manager that is also trying to get the part in faster...My dealer never told me to not use the GC, the parts guy even told me that if you stall or get in limp mode, they will act faster! ahhhhh just freaking perfect, that what i need to be stranded somewhere....his answer, well roadside assistance! god, some just have nothing to do! Anyhow, I just got a 3 MIL, same error again, now they flashed the TSB 18-023-15 which came out on the 14th of March...hope this will keep my MIL off until the new CAT arrives...As anyone here received the new TSB? TIA
__________________
Phil - JGC 2014 Eco Diesel - 2013 Sept build - NEW CAT INSTALLED! 11K miles.
Reply With Quote
  #83  
Old 03-19-2015, 04:25 PM
Morax's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Feb 2014
Location: QC, CANADA
Posts: 410
Thanks: 6
Thanked 41 Times in 38 Posts
Rep Power: 1530
Morax is on a distinguished road
Re: MIL & P20EE again & again & again...

Quote:
Originally Posted by JPC1 View Post
They told me they had installed a patch to prevent DEF from being injected from -11 Celsius and colder (which turns out to be BS - does such a patch even exist ?
John
Hi there John, welcome to the support group! I also live in Quebec and was told the same crap about the -11C DEF excuse...When I asked them how come some owners in Florida had the issue, they had the deer in headlights faces..anyhow, after the second P20EE, they ordered the CAT, but this AM got a third one, and got the newest update...TSB-18-023-15, let's see how it holds up...
__________________
Phil - JGC 2014 Eco Diesel - 2013 Sept build - NEW CAT INSTALLED! 11K miles.
Reply With Quote
  #84  
Old 03-19-2015, 04:26 PM
wraab's Avatar
Member
My Jeep: 2016 6.4L WK2
 
Join Date: Dec 2013
Location: Houston, Tx
Posts: 345
Thanks: 97
Thanked 43 Times in 35 Posts
Rep Power: 1513
wraab is on a distinguished road
Re: MIL & P20EE again & again & again...

It's pretty interesting that different dealers/service departments are saying 2 things in terms of the MIL P20EE.

I was told to drive it as it "was safe" to drive. But also to bring it back if it acted up or caused me concern.

I drove it for about 3 weeks before I had to find out the part was in.


It'll be interesting to see if "driving" will be something they try to use in case the issue is still ongoing.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P20EE Trigger 2014+ Jeep Grand Cherokee Ecodiesel 3.0 49 12-06-2015 11:49 AM
Flat battery again..and again..and again..etc. spikelet Troubleshooting/Problems 4 07-15-2013 10:34 AM
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual/Lighting 23 06-13-2013 12:22 PM
MIL & OBD lights on GC07 Grand Cherokee - WK 12 03-06-2011 06:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.