New TSB 009-006-15 - Page 6 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > 2014+ Jeep Grand Cherokee Ecodiesel 3.0

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 10-30-2015, 09:46 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2013
Location: Kerrville, TX
Posts: 686
Thanks: 89
Thanked 107 Times in 83 Posts
Rep Power: 2486
philbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond reputephilbytx has a reputation beyond repute
Garage
Re: New TSB 009-006-15

Yes, but, currently, it is only available in Washington State........very near the Canadian border eh? LOL !

__________________
Phil C.
2014 GC Overland 4x4, 3.0CRD, ATG, ORAII ("Smiffy")
2015 Lance 1685 Travel Trailer "#4"
2011 Kia Optima EX-L ("MC"
2003 BMW R1150RT "Darth"
Reply With Quote
Sponsored Links
Advertisement
 
  #62  
Old 11-02-2015, 09:27 AM
eaglescout1987's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2015
Location: Alexandria VA
Posts: 59
Thanks: 0
Thanked 13 Times in 10 Posts
Rep Power: 769
eaglescout1987 is on a distinguished road
Re: New TSB 009-006-15

Happy to report that my 780 mile road trip this weekend was perfect. I got 32.2 mpg and the engine purred the whole way at 75mph. Not even the slightest shutter or shimmy the whole time. I am becoming slightly more confident in the repair work done and do think it is worth it if you are experiencing the issue. Just be prepared for it to take a while to get done.
__________________
'14 WK2 Diesel Limited, Luxury Group II, Silver
Reply With Quote
The Following User Says Thank You to eaglescout1987 For This Useful Post:
  #63  
Old 11-03-2015, 08:03 PM
Member
 
Join Date: Oct 2014
Posts: 35
Thanks: 0
Thanked 7 Times in 6 Posts
Rep Power: 906
Aleks192 is on a distinguished road
Re: New TSB 009-006-15

Waiting for my parts to be ordered for this repair. Mine had been having troubles since March, and it was a bit of convincing to the dealer I had a problem. Some days its there, others its not, sometimes after sitting all night, others after being in a parking lot for an hour. I'm not sure my dealership in Calgary has done any, but they've been really good with everything else so far, so I'm optimistic.
Reply With Quote
  #64  
Old 11-08-2015, 02:10 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: New TSB 009-006-15

I've noticed these symptoms a few times. Pretty randomly actually, I thought it could be the music playing, drifting too close to rumble strips, or the DEF protector plate rattling. There's one part of my commute where I hear it often. The past few times, I remembered what the engine was doing when I heard it. I've figured out a way to "force" the sound consistently:

Go up a moderate hill, (no trailer or extra load) paddle shift into 6th gear around 35-40mph, and keep just below 1500 rpm. Rpms are more important than speed... there's a "sweet spot" around 1400 rpm where the ecodiesel grumbles pretty loudly as long as the rpms are kept there.

Are folks willing to give the test a try? Those with and without the new heads? I'd like to make sure the sound really is coming from sticking valves, and not something else. Thanks!

(If I remember) I'll keep an audio recorder running tomorrow
Reply With Quote
  #65  
Old 11-08-2015, 03:20 PM
Member
 
Join Date: Jul 2014
Posts: 247
Thanks: 21
Thanked 40 Times in 30 Posts
Rep Power: 1200
definn12 has disabled reputation
Quote:
Originally Posted by jeepgrandcherokeesal View Post
I've noticed these symptoms a few times. Pretty randomly actually, I thought it could be the music playing, drifting too close to rumble strips, or the DEF protector plate rattling. There's one part of my commute where I hear it often. The past few times, I remembered what the engine was doing when I heard it. I've figured out a way to "force" the sound consistently:

Go up a moderate hill, (no trailer or extra load) paddle shift into 6th gear around 35-40mph, and keep just below 1500 rpm. Rpms are more important than speed... there's a "sweet spot" around 1400 rpm where the ecodiesel grumbles pretty loudly as long as the rpms are kept there.

Are folks willing to give the test a try? Those with and without the new heads? I'd like to make sure the sound really is coming from sticking valves, and not something else. Thanks!

(If I remember) I'll keep an audio recorder running tomorrow
You guys all got me paranoid thinking mine is doing this. Does it actually sound like you're driving over the rumble strips? Or similar in consistency. Because I drove over some for a comparison and the issue I'm having is not as loud or jarring
Reply With Quote
  #66  
Old 11-08-2015, 03:46 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Pennsylvania
Posts: 123
Thanks: 61
Thanked 21 Times in 17 Posts
Rep Power: 1058
jeepgrandcherokeesal is on a distinguished road
Re: New TSB 009-006-15

Quote:
Originally Posted by definn12 View Post
You guys all got me paranoid thinking mine is doing this. Does it actually sound like you're driving over the rumble strips? Or similar in consistency. Because I drove over some for a comparison and the issue I'm having is not as loud or jarring
Sounds like rumble strips? yes. Feels like, no. That's why I think "grumbling" is a better adjective to describe the sound I'm hearing
Reply With Quote
  #67  
Old 11-09-2015, 10:49 AM
eaglescout1987's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Mar 2015
Location: Alexandria VA
Posts: 59
Thanks: 0
Thanked 13 Times in 10 Posts
Rep Power: 769
eaglescout1987 is on a distinguished road
Re: New TSB 009-006-15

I don't remember any real sound when mine did it. Its kind of hard to hold a mic next to the engine at 55 mph. It just felt like I was driving over a washboard or like my wheels were about to fly off. I would shift gears manually and it wouldn't really help. Only getting below 50 or above 70 seemed to get rid of it. If I stomped on the gas real hard it seemed to burn some of it off and keep it from coming back for a bit, but it always came back. When it came back in the middle of a thunderstorm and my wife nearly had a heart attack thinking we were going to crash, I said enough. Fortunately the TSB came out the right before the second time I took it in to have it looked at. There is no way to guarantee reproduction of the problem for the dealer. It didn't take an expert to look at the heads when they pulled them out and see there was a huge build up on them though.

My advise is if yours is doing it, find a dealer with a diesel tech and have it done before it goes out of warranty. Just plan on it taking 1-2 weeks while they figure out how to do it. It would have cost me a small fortune otherwise and the new heads have a slightly modified design from what I have heard to keep it from happening again. With all this emissions BS on these things, my theory is that most every one will have to get this done at some point. Might as well let FCA pay for their mistakes.
__________________
'14 WK2 Diesel Limited, Luxury Group II, Silver
Reply With Quote
  #68  
Old 11-09-2015, 06:19 PM
Member
My Jeep: 2015 3.0L WK2
 
Join Date: Feb 2014
Location: Tacoma, WA
Posts: 255
Thanks: 4
Thanked 25 Times in 21 Posts
Rep Power: 1348
MBDiesel is on a distinguished road
Re: New TSB 009-006-15

The one good thing out of all of this is it falls under powertrain warranty. Most of us aren't approaching 100k yet and even for the earliest 2014's, five years won't come until mid/late 2018. We've got some time.
__________________
2015 WK2 EcoDiesel Overland 4x4 Billet Silver, ORAII, ATG
1990 Mercedes-Benz 300D 2.5 Turbo - 155k
No sparks allowed!
Reply With Quote
  #69  
Old 11-09-2015, 08:56 PM
Member
 
Join Date: Jan 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1131
thereynolds is on a distinguished road
Re: New TSB 009-006-15

Hi all,

Just picked up my 14 GC with about 35K miles on it after having this repair completed. I first reported the problem in August. It took until late October for them to get all the parts; during that two months, the dealer told me I could drive the car with the check engine light on, as long as it wasn't blinking. They reset the light when I first took it in, but it came on again shortly thereafter.

I took the car in last Monday, and I received a call Friday that it would be ready Friday evening (same week, so 5 day repair). I called them and told them I would be in Saturday morning to pick it up.

I drove my rental car to the dealership first, to check with the service dept. to ensure the car was ready. They said it was. So then I took my rental car back, and Enterprise drove me back to the dealer. I did all my paperwork, got my Keyfob, got in the car, pushed the button.... and nothing happened. Just a coil light on the left side of the dash. Ended up having to go back to Enterprise and re-renting my rental car for the weekend.

They called me today (Monday) and said the problem was fixed; the problem with the non-starting was a loose ground, on the alternator I believe. Picked it up tonight, drove about 10 miles home. Engine seems to run OK, but it sounds different, which is what I was afraid of. I think the engine may sound the same generally, but I'm not sure the overall car sounds the same. Sounds like the downshift is different, idle is a bit noisier, and other bothersome, worrisome, but perhaps minor things like that. I should mention that they also did some work with the Catalytic issue, even though as far as I know I had never received the P2EE (or whatever the code is) error message.

I'll post again on what I think after I've driven it for awhile. I guess my feeling right now is that it's BS to have to have such a major repair done so early, and I feel that, combined with other design issues such as the very vulnerable DEF injector, low hanging DEF hose, early hard shifting issues and other problems is affecting the car's value, and that deserves compensation. I also think Chrysler should provide very extended warranties based on these problems. I purchased the longest warranty they offered when I bought the car, but I think that's only 3 years, 100K or something like that. Not enough based on this experience.

Let me know if anyone has any specific questions about the repair. Overall, I'd say the dealer did pretty well, although it took a long time to get the parts. Chrysler needs to own the design issues with the car, and do the right thing for those of us that purchased it and supported this new model. As many of us say, I like the Jeep when it drives well, but I've had to make many visits to the dealer's service center, and who's compensating me for my time in having to do this?
Reply With Quote
  #70  
Old 12-11-2015, 11:34 AM
Member
 
Join Date: Dec 2015
Posts: 8
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 454
JGC EcoDiesel 2014 is on a distinguished road
Re: New TSB 009-006-15

Anyone get TBS-18-094-15 updated yet for their Ecodiesel? Any difference? Inprovements? Dislikes?
Reply With Quote
  #71  
Old 01-13-2016, 08:19 AM
Member
 
Join Date: Oct 2014
Posts: 35
Thanks: 0
Thanked 7 Times in 6 Posts
Rep Power: 906
Aleks192 is on a distinguished road
Re: New TSB 009-006-15

Mine has been having problems since getting it back, which is what I feared. I'm kind of regretting getting the repair done. I had dropped it off mid December, and had received 2 phone calls delaying its return. Finally got a call after 2.5 weeks saying it would be ready the next day, and they were doing some tests. They also replaced the cat under recall (they said p20ee but I've never seen a code). Picked it up, and noticed it smelled terrible. Exhaust smell coming in thru the vents, hissing noise under accelerating conditions, lack of power. Returned it 2 days later and they had it for another 5 days for a leaky injector, and an EGR flange bolt. Was assured it was fixed (but the interior reeks of exhaust). Have had it for 1 week, still has exhaust coming in when remote started or sitting still, vibration/groan when it shifts, and additional vibration or rubbing while idling as well. I've written my dealer again stating I'm unsatisfied with the repair. I've had this vehicle for 1yr 2 months, and I know how it runs, sounds, smells etc. It is not reflective of a $65k cdn vehicle any longer. It smells like an old farm truck when its running and its embarrassing. I used to tell everyone how i was impressed that it never smelled when running, was the cleanest diesel. Now it's terrible.
Reply With Quote
  #72  
Old 01-13-2016, 09:31 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2015
Location: S. MD
Posts: 36
Thanks: 4
Thanked 2 Times in 2 Posts
Rep Power: 467
LS954 is on a distinguished road
Re: New TSB 009-006-15

Quote:
Originally Posted by JGC EcoDiesel 2014 View Post
Anyone get TBS-18-094-15 updated yet for their Ecodiesel? Any difference? Inprovements? Dislikes?
According to my dealer the flash in that TBS has been pulled and they're no longer flashing vehicles with that RRT
__________________
2014 3.0L Summit
2012 ZX14R
1990 Caprice 6.0L iron block LS2
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Attention WK2 3.6L owners - New TSB for Shudder, harsh shifts, performance and more! Milous Trouble Shooting/Problems/Service 232 02-05-2017 04:35 PM
Service Bulletin 21-006-13 '09-'12 WK/'09-'10 XK 5.7L FLASH: Transmission Xjrguy Trouble Shooting/Problems/Service 64 12-21-2013 09:36 PM
Tsb 09-006-11 millzzy Technical Service Bulletins and Recalls 4 03-04-2012 02:21 AM
Important new TSB for 2011 5.7L owners Milous Trouble Shooting/Problems/Service 69 11-25-2011 01:21 PM
New TSB for WK FUEL ECONOMY IMPROVEMENT lewi3069 Technical Service Bulletins and Recalls 15 06-10-2011 07:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.