Augh!!! No Spark! Please help... - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Site Information > New Members - Welcome!

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-04-2015, 12:13 AM
New Member
 
Join Date: May 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jeepkid91 is on a distinguished road
Exclamation Augh!!! No Spark! Please help...

First off I have a 1991 Jeep Charokee with a 4.0 inline 6 cylinder engine, and no spark.

So my wife is driving up an on-ramp and my jeep suddenly killed out on her. My friend and I ended up towing it home so now it sits in my driveway. The wife said there was no "putt putt... " when it quit; just an instant shut-off.

First thing I figured whether it was no spark or no fuel... turned out to definitely be no spark. Wires, plugs, cap, and roter are fairly new and are in good condition. Battery and battery hook-up is fine. After spending time under the hood and reading other forums the first thing I did was put in a new crank shaft position sensor as that seems to quite a common thing. Didn't do me a thing. Then I replaced the ignition coil. Still nothing. Next was the control module in the distributor... nothing. It will crank, but it won't turn over.

So here I am about four months later and I move in the next three. If I don't get this thing fixed now I'm selling it and something that works. I've got a ton of things going on and can't have this thing slowing me down.

If anyone can help I'd really, really, really,... appreciate it. Thanks

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-04-2015, 06:35 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Augh!!! No Spark! Please help...

Welcome to the garage. Since it suddenly stopped working and no "putt putt" was heard when it stopped, i wonder if the timing chain broke. I would remove the cylinder head cover and see if the valves open and close while you crank the engine.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-04-2015, 11:55 AM
New Member
 
Join Date: May 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jeepkid91 is on a distinguished road
Re: Augh!!! No Spark! Please help...

Did it... and all cylinders are working, and I do get compression. Doesn't seem like a broken chain would explain my not having any spark though.
Reply With Quote
  #4  
Old 05-04-2015, 12:14 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Augh!!! No Spark! Please help...

A broken chain would stop the camshaft from rotating and stop the cam sensor from getting any speed signal, so would stop the spark. It would also stop the valves and stop the sound of the engine immediately. For that reason i did mention it. Since you have normal compression, its obviously not the chain.
Did you check all fuses? Do you still get fuel? Did you check the autoshutdown relay?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 05-04-2015, 01:09 PM
ekaz's Avatar
Member
My Jeep: 2015 6.4L SRT WK2
 
Join Date: Oct 2009
Location: Chicago
Posts: 764
Thanks: 9
Thanked 40 Times in 33 Posts
Rep Power: 3648
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: Augh!!! No Spark! Please help...

Are you getting spark at the coil?
__________________
2015 Billet Silver
past:
2012 300SRT, 2009 Jeep SRT, 2006 Charger SRT
Too many mods to list for each, so let's just say a lot was done over the years.
Reply With Quote
  #6  
Old 05-04-2015, 01:16 PM
Long Live the Grey Ghosts

 
Join Date: May 2009
Posts: 13,484
Thanks: 57
Thanked 146 Times in 128 Posts
Rep Power: 543556
robpp has disabled reputation
Re: Augh!!! No Spark! Please help...

cps or tps...... I change them in pairs/

the only time my XJ went home on the flatbed.
__________________
Reply With Quote
  #7  
Old 05-04-2015, 01:43 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Augh!!! No Spark! Please help...

Quote:
Originally Posted by robpp View Post
cps or tps...... I change them in pairs/

the only time my XJ went home on the flatbed.
Crank and cam sensor where already changed by OP.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 05-04-2015, 10:00 PM
New Member
 
Join Date: May 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jeepkid91 is on a distinguished road
Re: Augh!!! No Spark! Please help...

Quote:
Originally Posted by Frango100 View Post
A broken chain would stop the camshaft from rotating and stop the cam sensor from getting any speed signal, so would stop the spark. It would also stop the valves and stop the sound of the engine immediately. For that reason i did mention it. Since you have normal compression, its obviously not the chain.
Did you check all fuses? Do you still get fuel? Did you check the autoshutdown relay?
Ah, that makes sense. I did check the fuses; they're a go. And I do get fuel. I haven't checked the auto shut down relay though. About where would that be?
Reply With Quote
  #9  
Old 05-04-2015, 10:02 PM
New Member
 
Join Date: May 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Jeepkid91 is on a distinguished road
Re: Augh!!! No Spark! Please help...

And no I am not getting spark at the coil.
Reply With Quote
  #10  
Old 05-04-2015, 10:51 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,329
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529492
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Augh!!! No Spark! Please help...

The autoshutdown relay sits in the power distribution center under the hood, but if you get fuel, it should not be the relay, since its feeding both coils and injectors. I donīt have a wiring schematic of your jeep, so it could be a bit different on your jeep though. Did you measure for 12V at the coil?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help help help!! Anyone pleae help! ashenmorality Trouble Shooting/Problems/Service 35 07-17-2014 04:35 PM
Confused about spark plug gap requirements for my 3.7! .040? Input, please. Triplecrown Grand Cherokee - WK 4 03-20-2013 06:21 PM
Spark Plug HELP tydallas Troubleshooting/Problems 16 10-07-2011 06:15 AM
HELP! Spark plug problems dfwt70gt Grand Cherokee - WK 9 05-03-2011 02:27 PM
Engine Oil on spark plugs Help!! ChrisWk Grand Cherokee - WK 18 03-01-2011 07:10 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.